Board index FlightGear Development Aircraft

Assistance Requested, Zivko Edge Instrument Panel Bugs  Topic is solved

Questions and discussion about creating aircraft. Flight dynamics, 3d models, cockpits, systems, animation, textures.

Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby xen_steda » Thu Mar 12, 2020 10:47 am

Hello, I am looking to get a little help with the Zivko Edge 540 that is in the FGAddon Hangar. The plane instrument panel has some graphical bugs that I would like to fix, or at least try.

If anyone would like to help me figure out how to fix this dials, that would be so awesome because this is a very iconic plane and I know people would appreciate it besides myself. How can we get these dials to look right?

In this old thread, the developer talked about adding the smoke feature and it may have messed up the textures:

Torsten wrote in Thu Mar 19, 2009 4:04 pm:It's fixed in the CVS version. The Edge is a smoker again. Should also smoke via multiplayer.

But beware - I messed up the texture of the aircraft. I'll fix it as time permits.

Torsten



There are some dials in the cockpit that seem a bit weird, kind of all black (see red arrows) and very hard to read:
Image

And does anyone know if this G-meter works? The button toggle does nothing.
Image

Thanks for any help!
xen_steda
 
Posts: 234
Joined: Sun Jan 05, 2020 3:53 pm

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby xen_steda » Fri Mar 20, 2020 10:48 am

Hello, so I have found that when I adjust the FOV to 43, the gauges show up like they should (still not that blank rectanglular screen, I haven't found a way to turn that on):
Image

Some of the gauges slowly disappear as I move it out to 74 FOV:
Image

Is there something I could adjust to fix this? Thanks!
xen_steda
 
Posts: 234
Joined: Sun Jan 05, 2020 3:53 pm

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby Maerchenprinz » Fri Mar 20, 2020 11:38 am

Hi!

I gave it a try, but could not reproduce what you see (though I managed to make the Becker comm devices' LCDs disappear - by turning them off :) , which you obviously didn't, regarding the screenshot).
I could not find anything special in animations, except a <range> animation in Models/ZivkoEdge540.xml and some in Models/Acceleration.xml (the one that disappears,too, in your screenshot. I think it is worth a try to e.g. untag these animations and see what happens.

Ciao,

Adrian
User avatar
Maerchenprinz
 
Posts: 243
Joined: Thu Mar 15, 2007 5:24 pm
Location: Bochum, it's better, much better than you think!
Callsign: Adrian

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby xen_steda » Fri Mar 20, 2020 11:51 am

Ok i will try your suggestion thanks! Does the Gmeter screen in the middle work for you?
xen_steda
 
Posts: 234
Joined: Sun Jan 05, 2020 3:53 pm

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby wkitty42 » Fri Mar 20, 2020 3:24 pm

NOTE: i have not looked at the craft to see what is really going on... the following statement is based on the description of the problem only...

xen_steda wrote in Fri Mar 20, 2020 10:48 am:Hello, so I have found that when I adjust the FOV to 43, the gauges show up like they should [///] Some of the gauges slowly disappear as I move it out to 74 FOV:

this sounds like range animations are involved... zooming affects the range so objects can be seen when zoomed in and not when zoomed out... this is one of the reasons that range animations should not be used...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6960
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 20.04

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby xen_steda » Fri Mar 20, 2020 3:55 pm

Hello wkitty42, I commented out the range animations but the problem still remains. For anyone who does not have this problem with this aircraft, could you tell me the version you are using? I have 20160216.
xen_steda
 
Posts: 234
Joined: Sun Jan 05, 2020 3:53 pm

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs  

Postby V12 » Fri Mar 20, 2020 6:36 pm

What about DDS cache in Rendering Options ? With active this feature I had similar troubles in Concorde. With deactivated, all was OK.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 2140
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby xen_steda » Fri Mar 20, 2020 7:25 pm

V12 that was it, thank you! Does the center blank screen actually work on this plane? I think it is supposed to be the G-Meter but I haven't been able to turn it on.
xen_steda
 
Posts: 234
Joined: Sun Jan 05, 2020 3:53 pm

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby PINTO » Fri Mar 20, 2020 8:46 pm

The blank screen is an MFD, it used to work but later FG versions broke it. I haven't had time to investigate it yet. It had various functions. The LED's above the screen are a g-meter.
Actively developing the MiG-21bis (github repo) (forum thread) (dev discord) (fg wiki)

http://opredflag.com is an active flightgear dogfighting community (using a system that isn’t bombable)
User avatar
PINTO
 
Posts: 960
Joined: Wed Oct 21, 2015 6:28 pm
Callsign: pinto
Version: 2016.3.0
OS: Win10

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby wkitty42 » Sat Mar 21, 2020 1:09 am

V12 wrote in Fri Mar 20, 2020 6:36 pm:What about DDS cache in Rendering Options ? With active this feature I had similar troubles in Concorde. With deactivated, all was OK.

if this is the case, we need to find out how to trigger a recache when the files change...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6960
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 20.04

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby V12 » Sat Mar 21, 2020 6:33 am

I had deactivated that feature some month and did not observed any trouble. With activated, clouds LOD did not work well, on some planes was problem with instruments, on my Concorde I converted all grayscale png images to RGB subformat and this trick helped me. Then I converted all cloud png textures from grayscale to RGB too, but it did not work.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 2140
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby Richard » Mon Mar 23, 2020 6:57 pm

xen_steda wrote in Thu Mar 12, 2020 10:47 am:help with the Zivko Edge 540 that is in the FGAddon Hangar


I've just committed a set of fixes for this aircraft to FGAddon. Part of the problem was the grayscale textures that don't work with the DDS-Texture cache - but also the use of transparent textures to do the gauges wasn't a good idea so I've fixed all of the gauges to have geometry for the faces; tidied up the materials and sorted out the textures.

Rev: 4666 - should be available in the 2019.x launcher tomorrow; feedback would be appreciated.
Richard
 
Posts: 791
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby xen_steda » Mon Mar 23, 2020 9:22 pm

Richard wrote in Mon Mar 23, 2020 6:57 pm:I've just committed a set of fixes for this aircraft to FGAddon.


This is a really significant update, thank you! To anyone who hasn't tried this plane in a while, it has a lot more functionality in the panel, awesome job!

Image
xen_steda
 
Posts: 234
Joined: Sun Jan 05, 2020 3:53 pm

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby xen_steda » Wed Mar 25, 2020 2:56 am

I have noticed something with this plane, it may be new, possibly since a recent update (I see in the picture above this post the prop still has the issue), but the propeller is not visible when it is running, from inside the cockpit and outside as well. Is it possible to make the spinning prop visible like some of the other aircraft in FG? Thank you!
xen_steda
 
Posts: 234
Joined: Sun Jan 05, 2020 3:53 pm

Re: Assistance Requested, Zivko Edge Instrument Panel Bugs

Postby Richard » Thu Mar 26, 2020 10:06 am

wkitty42 wrote in Sat Mar 21, 2020 1:09 am:if this is the case, we need to find out how to trigger a recache when the files change...


For the record this is already built in as I use a MD5 hash of the file contents as a filename. There is no deletion of unused items - so the cache will just keep on growing.
Richard
 
Posts: 791
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Next

Return to Aircraft

Who is online

Users browsing this forum: No registered users and 3 guests