Board index FlightGear Support Installation Linux

flightgear package does not have qml-module-qtquick2 as dep

Installing FlightGear, scenery, aircraft etc. on Linux systems like Ubuntu.

flightgear package does not have qml-module-qtquick2 as dep

Postby evranch » Tue Jan 08, 2019 5:08 pm

Just installed the latest version of flightgear from the EDIT: Flightgear PPA stable repository on Linux Mint. The launcher displays an empty window while fgfs itself runs fine.

Turns out that it needs qtquick2, this would be a quick patch just to add it as a dependency. I'm sure lots of people are installing from the repository to find that it does nothing!

qml-module-qtquick2 is not enough on its own, I suspect one of the controls or window packages is also required, but to save myself the effort I just pulled in qml-module-qtquick-* to get it running.
Last edited by evranch on Tue Jan 08, 2019 6:29 pm, edited 1 time in total.
evranch
 
Posts: 8
Joined: Tue May 01, 2018 5:03 am

Re: flightgear package does not have qml-module-qtquick2 as

Postby Hooray » Tue Jan 08, 2019 5:19 pm

Hi & welcome,

anything involving Qt related issues, is best reported using the FlightGear developers mailing list: http://wiki.flightgear.org/index.php/Mailing_list
Or at least using the issue tracker: https://sourceforge.net/p/flightgear/codetickets/


This is due to any Qt related functionality being relatively "new", Qt related code is added primarily for two reasons:

The long-term vision here being to get rid of the legacy OpenGL-based UI engine called "PUI" (from PLIB), as it's no longer compatible with modern OpenGL code (namely most OSG code in FlightGear), background at: http://wiki.flightgear.org/PUI
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11292
Joined: Tue Mar 25, 2008 8:40 am

Re: flightgear package does not have qml-module-qtquick2 as

Postby Thorsten » Tue Jan 08, 2019 6:18 pm

For dependencies on a Linux repository, you need to notify the people who run the repository - the FG project can't do anything on e.g. Linux Mint - we have no influence on what and how they package.
Thorsten
 
Posts: 10226
Joined: Mon Nov 02, 2009 8:33 am

Re: flightgear package does not have qml-module-qtquick2 as

Postby evranch » Tue Jan 08, 2019 6:27 pm

I didn't use the Mint repo which is badly out of date, I used Flightgear's stable PPA. Whoever packaged it should add the necessary dependencies - this will be an issue on Ubuntu or any other Debian based system as well if the user did not install qtquick on their own.

I noticed another recent complaint on this forum of the exact same issue, which was resolved by installing qtquick.

Reported on the Sourceforge issue tracker. The dependencies needed are

qml-module-qtquick2
qml-module-qtquick-window2

Edit: I can see how my original post was misinterpreted, I edited it. Meant to say that I used the Flightgear repo, not the Mint one.
evranch
 
Posts: 8
Joined: Tue May 01, 2018 5:03 am

Re: flightgear package does not have qml-module-qtquick2 as

Postby Thorsten » Tue Jan 08, 2019 7:27 pm

I believe that would be Saikrishna's PPA, and he sometimes monitors this forum so you have some chance of reaching him here, but again:

The FG project provides the source code only for Linux, there is no Linux binary officially supported that I would know of. - so FG developers would not be in a position to fix anything.
Thorsten
 
Posts: 10226
Joined: Mon Nov 02, 2009 8:33 am

Re: flightgear package does not have qml-module-qtquick2 as

Postby Hooray » Tue Jan 08, 2019 8:55 pm

Actually, I do think that there could be a potential correlation in that the corresponding binary packages can be created using the simgear/flightgear-side cmake machinery and the dependencies referenced there - in other words, if people building such binary packages rely on FlightGear's CMakelists.txt, any dependencies missing there, would also be reflected in the binary packages missing those (potentially).
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11292
Joined: Tue Mar 25, 2008 8:40 am

Re: flightgear package does not have qml-module-qtquick2 as

Postby saiarcot895 » Wed Jan 09, 2019 3:17 am

In this case, the dependencies aren't being determined from CMakeLists.txt, but instead from the generated binaries. The dependency detector that Ubuntu uses isn't detecting the QML dependencies (which makes sense, since it doesn't know anything about QML).
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 302
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: flightgear package does not have qml-module-qtquick2 as

Postby saiarcot895 » Thu Jan 10, 2019 6:45 am

The dependency has been added to the packages, and now those two packages should automatically get installed.
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 302
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: flightgear package does not have qml-module-qtquick2 as

Postby evranch » Fri Jan 11, 2019 6:23 am

Just updated my computer and looks like the package is live, removed the qml packages and flightgear. Reinstalled flightgear and it pulled everything in and works out of the box. Looking good here on Mint at least!
evranch
 
Posts: 8
Joined: Tue May 01, 2018 5:03 am


Return to Linux

Who is online

Users browsing this forum: No registered users and 0 guests