Board index FlightGear Support Flying

stuck on vertical stereoscopic screen

Controlling your aircraft, using the autopilot etc.

stuck on vertical stereoscopic screen

Postby John C » Tue Oct 30, 2018 7:02 pm

I'm brand new to FG... have been able to fly the stock Cessna, but was exploring "View" options and clicked on "Stereoscopic View Options">Vertical_Split. view. Now stuck on that screen/view. Have tried exiting FG, restarting, but screen always is split, and the "close" button won't get me out of this view. Nothing else in the "View" menus works either. I wanna fly!!... Using new MacBook Pr0, High Sierra. Downloaded the program from web, but also purchased the DVD from Flight Gear (18.2), and installed it from disk, but flew the Cessna in "normal'view before problem started, if any of that matters.
John C
 
Posts: 4
Joined: Tue Oct 30, 2018 6:43 pm

Re: stuck on vertical stereoscopic screen

Postby Fly-Flot » Tue Oct 30, 2018 9:24 pm

Hi John
sorry I use Win8.1 SO, but to restore normal view
search the file "autosave_2018_2.xml" and open with simple notepad
find this line .... "<stereo-mode type =" string "> VERTICAL_SPLIT </ stereo-mode>" replace "VERTICAL_SPLIT" with "OFF"
save and exit.
now start Flightgear.
I hope in the mac is the same procedure
Fly-Flot
 
Posts: 4
Joined: Sun Jan 15, 2017 1:34 pm

Re: stuck on vertical stereoscopic screen

Postby John C » Sat Nov 10, 2018 2:51 am

OK, I'm frustrated as hell. Mac OSX High Sierra10.13.6, (brand new MacBook Pro), FlightGear 2018.2.2 (purchased DVD from FlightGear.org, because my DSL connection is not the fastest, but is "OK").... I initially was able to run/fly the program from the purchased disk, then got brave and began exploring the menus, and clicked on 'stereoscopic vertical split', and now STUCK in that view- no options in the menu to escape that (stereo) view. So I uninstalled it. Again loaded the disk to install this disk version again, but stereo view AGAIN. Uninstalled it again. Then I eventually successfully downloaded the program from FlightGear.org, over internet, thinking this method would get me out of stereo view. Nope- still stereo view. Nothing is getting me out of "stereo view". Can somebody please direct me... I'm stuck in stereo view!
John C
 
Posts: 4
Joined: Tue Oct 30, 2018 6:43 pm

Re: stuck on vertical stereoscopic screen

Postby curt » Sat Nov 10, 2018 5:13 am

Maybe a mac person can jump in and help with specifics, but isn't there a "reset default options" in the main launcher window (or menu?)
Aerospace Engineering and Mechanics
University of Minnesota
curt
Administrator
 
Posts: 1111
Joined: Thu Jan 01, 1970 12:00 am
Location: Minneapolis, MN

Re: stuck on vertical stereoscopic screen

Postby Maerchenprinz » Sat Nov 10, 2018 5:47 am

Heyy John!

I dearly suspect that it's FG's usual (de-)installation routine on any OS to NOT remove/overwrite the folder with custom-settings (called .fgfs on linux e.g.). So when you find that one, it contains all your saved settings, including the mean "stereo-mode type"-setting...

I'm no Mac person either (what do Scotsmen have to do with this topic anyway?), still, my idea should work (I think):
Search with your favourite search tool for a file named "autosave*.xml (with "*" being a placeholder) - If there's no file named autosave*.xml, then you should search for a file containing the text-string "stereo-mode type". Once found, continue as described by Fly-Flot.

As we all know there's "the Luck of the Scottish", so everything will be fine again...

Ciao,

Adrian
User avatar
Maerchenprinz
 
Posts: 134
Joined: Thu Mar 15, 2007 5:24 pm
Location: Bochum, it's better, much better than you think!
Callsign: Adrian

Re: stuck on vertical stereoscopic screen

Postby John C » Sun Nov 11, 2018 3:02 am

Curt, the only "reset" option I find in the launcher is for using default scenery. And after the program opens up (with the Cessna ready for flight), under "File"> "Reset"; but this only resets the flight, only to again open in stereoscopic view. And, in replying to Maerchenprinz's suggestion, I can see that file named "autosave.xml, but it is "greyed out" and unavailable. I'm not tech-savvy and don't really know much about command lines, placeholders, etc., so I'm lost on that stuff.
John C
 
Posts: 4
Joined: Tue Oct 30, 2018 6:43 pm

Re: stuck on vertical stereoscopic screen

Postby Fly-Flot » Sun Nov 11, 2018 10:42 am

There is another way.
open flightgear with plane c172.
go up with the mouse and open the "VIEW" menu
and follow the images below.

Image

step 2

Image

and

Image

always if flightgear for mac is equal to flightgear for win
Sorry for the bad images
Fly-Flot
 
Posts: 4
Joined: Sun Jan 15, 2017 1:34 pm

Re: stuck on vertical stereoscopic screen

Postby curt » Sun Nov 11, 2018 2:03 pm

The core problem is that once you select vertical split, the mouse no longer aligns with what is drawn on screen. It makes it nearly impossible to do anything inside flightgear after that, including recovering from split screen mode.

John, look outside the flightgear launcher window to the menu that is associated with the application (on the Mac I believe that is along the bar at the very top of the screen ... easy to miss.
Aerospace Engineering and Mechanics
University of Minnesota
curt
Administrator
 
Posts: 1111
Joined: Thu Jan 01, 1970 12:00 am
Location: Minneapolis, MN

Re: stuck on vertical stereoscopic screen

Postby WoodSTokk » Mon Nov 12, 2018 12:33 am

@John C
Start FG from the shell and turn off the stereo view:
Code: Select all
fgfs --prop:/sim/rendering/osg-displaysettings/stereo-mode=OFF --launcher


Or, if you not familiar with the shell, start FG as normal.
In the launcher go to 'Settings' and scroll down.
In the text field 'Additional Settings' add the following line
Code: Select all
--prop:/sim/rendering/osg-displaysettings/stereo-mode=OFF

klick 'Fly!'

If you start FG the next time, you can delete the line from the 'Additional Settings' because this setting will be saved.
WoodSTokk
 
Posts: 89
Joined: Tue Oct 17, 2017 2:30 pm
Location: Milky Way/Sol/Earth/Europe
Callsign: OE-WST
IRC name: WoodSTokk
Version: 2018.2.2
OS: Debian Buster/Sid

Re: stuck on vertical stereoscopic screen

Postby John C » Mon Nov 12, 2018 6:39 pm

Hey, guys- it's fixed! Fly-Flot's suggestion (and Curt's) of finding those 2 "sweet" spots and clicking, then the "Anaglyphic" (sp?) command did the trick! Numerous, numerous attempts at finding these spots. Such a weird fix, but hey... Thanks to all for getting me over this hump. Was about to back-up my MacBook, and flush the OS, and reinstall the OS (as in "fresh from the factory").
John C
 
Posts: 4
Joined: Tue Oct 30, 2018 6:43 pm


Return to Flying

Who is online

Users browsing this forum: No registered users and 2 guests