Board index FlightGear Support Flying

Autostarting the Boeing 767

Controlling your aircraft, using the autopilot etc.

Re: Autostarting the Boeing 767

Postby wkitty42 » Tue Oct 30, 2018 1:34 pm

maybe the OP downloaded it from somewhere else? or maybe put it in the wrong place and overwrote/overrode another file?
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4733
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Autostarting the Boeing 767

Postby kwanza » Tue Oct 30, 2018 3:07 pm

Sorry, I just checked and I still have the AMX-skyteam livery. The problem was certainly due to a *skyteam livery, probably A*skyteam from what I remember. The test I ran was unzipping the raw 767-300 file, then testing FG. It worked. Then I added all my selected liveries. The plane failed to start. So I removed one livery at a time and tried the 767. Once I got to the offending livery, things worked again. It is possible that I was using the wrong version of the livery (probably from the other 7-series planes).
kwanza
 
Posts: 30
Joined: Tue Aug 12, 2008 7:07 am

Re: Autostarting the Boeing 767

Postby kwanza » Sat Nov 10, 2018 9:28 pm

I have to retract my previous comments. The problem has returned yet I did not change a single thing. So it was not the liveries after all. Something more sinister is going on which results in the autostart function failing/working sporadically. The very odd thing about the 767 is that all the other non-essential functions (airport operations, announcements, etc.) work fine, but the really important one (startup) does not! My next guess is that the plane writes to a file and then reads from it on a subsequent session which results in the failures. Does that make sense?
kwanza
 
Posts: 30
Joined: Tue Aug 12, 2008 7:07 am

Re: Autostarting the Boeing 767

Postby legoboyvdlp » Sat Nov 10, 2018 9:29 pm

Hold on, let me check how the autostart works on the 767.

What average frame rate do you have if you don't mind me asking?
User avatar
legoboyvdlp
 
Posts: 5701
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Autostarting the Boeing 767

Postby kwanza » Sat Nov 10, 2018 10:50 pm

I am not sure of the frame rate (how do I get that?), but I can fly without problems if I ever get the plane started.
kwanza
 
Posts: 30
Joined: Tue Aug 12, 2008 7:07 am

Re: Autostarting the Boeing 767

Postby legoboyvdlp » Sat Nov 10, 2018 11:05 pm

Framerate is found in view > view optionw

Sometimes very low frame rate can cause issues with planes, but sounds like that isn't the problem.

I don't see why it should sometiems work and sometimes not :?

If you delete the old 767 and redownload it does it work?

Is fuel freeze enabled? If so try without.

Is there fuel in the tanks? (Equipment > payload in the menu)
User avatar
legoboyvdlp
 
Posts: 5701
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Autostarting the Boeing 767

Postby it0uchpods » Sat Nov 10, 2018 11:27 pm

OK, I'll in a new way:

load FG, run the autostart, then, please send your FGFS.log. This is in $FG_HOME. (Windows: %appdata%\flightgear.org)

perhaps I can find a problem there.

Kind Regards,
Josh
it0uchpods/WTF411

FGFS Aircraft Developer
Lead Programmer at it0uchpods Design Group
Download High Quality Aircraft from it0uchpods Hangar
User avatar
it0uchpods
 
Posts: 3527
Joined: Tue Oct 06, 2015 12:51 pm
Version: 2018.2.1
OS: Windows 10 x64

Re: Autostarting the Boeing 767

Postby kwanza » Sun Nov 11, 2018 12:19 am

OK, I managed to get it to work again after reinstalling the 767-300.zip file. The difference between the original and the new directory is as follows:

Code: Select all
Only in ../767-300+/Models: ANA.png
Only in ../767-300+/Models: LAN.png
Only in ../767-300+/Models/Liveries: ALK.png
Only in ../767-300+/Models/Liveries: ALK.xml
Only in ../767-300+/Models/Liveries: AMX-skyteam.png
Only in ../767-300+/Models/Liveries: AMX-skyteam.xml
Only in ../767-300+/Models/Liveries: ANA.xml
Only in ../767-300+/Models/Liveries: DHK.png
Only in ../767-300+/Models/Liveries: DHK.xml
Only in ../767-300+/Models/Liveries: DLH_SA.png
Only in ../767-300+/Models/Liveries: DLH_SA.xml
Only in ../767-300+/Models/Liveries: GFA.png
Only in ../767-300+/Models/Liveries: GFA.xml
Only in ../767-300+/Models/Liveries: LAN.xml
Only in ../767-300+/Models/Liveries: MXA.xml
Only in ../767-300+/Models/Liveries: QFA.xml
Only in ../767-300+/Models/Liveries: TAM.xml
Only in ../767-300+/Models/Liveries: TWA-N691LF.xml
Only in ../767-300+/Models/Liveries: VRG.png
Only in ../767-300+/Models/Liveries: VRG.xml
Only in ../767-300+/Models: MXA.png
Only in ../767-300+/Models: QFA.png
Only in ../767-300+/Models: TAM.png
Only in ../767-300+/Models: TWA-N691LF.png


The 767-300+ directory is the original one. As you can see the only difference is in the liveries. This is what led me to think that liveries where the cause of the autostart failure. I am not sure any more since at some stage it might fail again.

With regard to fuel, the plane starts off with 0.27 fuel in the left and right tank. This is enough for the short distances I fly. I sometimes increase the payload, but I think this has not effect on the startup.

The frame rate varies from 19 at start to 49. Generally, it is in the 30s or 40s.
kwanza
 
Posts: 30
Joined: Tue Aug 12, 2008 7:07 am

Re: Autostarting the Boeing 767

Postby it0uchpods » Sun Nov 11, 2018 1:38 am

That is very weird... I am without clues.

Kind Regards,
Josh
it0uchpods/WTF411

FGFS Aircraft Developer
Lead Programmer at it0uchpods Design Group
Download High Quality Aircraft from it0uchpods Hangar
User avatar
it0uchpods
 
Posts: 3527
Joined: Tue Oct 06, 2015 12:51 pm
Version: 2018.2.1
OS: Windows 10 x64

Re: Autostarting the Boeing 767

Postby wkitty42 » Sun Nov 11, 2018 3:33 pm

check if you have an %appdata%\flightgear.org\aircraft-data\767-300.xml file... it may be that the craft is saving some settings that are getting restored and causing the autostart to be fouled...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4733
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Autostarting the Boeing 767

Postby kwanza » Sun Nov 11, 2018 6:23 pm

I think I have found a possible culprit, which ironically takes me back to my original theory of liveries. What I did was restore each livery one at a time and check if the autostart function worked. One livery consistently breaks the function. It has the files: 767-300/Models/Liveries/AMX-skyteam.png and 767-300/Models/Liveries/AMX-skyteam.xml. Thus, I would suggest that the A*skyteam liveries in general will mess up the 767 instrumentation. I looked through the logs when it breaks and filtered the bits that mention 767. I get the log below. Note the line that includes "AMX-skyteam.xml". I did not select this livery so it ought not to be using that file.

Code: Select all
:
 input:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Main/options.cxx:2199:aircraft = 767-300
general:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Main/fg_init.cxx:213:found aircraft in dir: /usr/share/flightgear/Aircraft/767-300
general:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Main/options.cxx:2505:   option:aircraft-dir = /usr/share/flightgear/Aircraft/767-300
general:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Main/options.cxx:2505:   option:aircraft = 767-300
general:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Main/fg_init.cxx:757:aircraft-dir = "/usr/share/flightgear/Aircraft/767-300"
sound:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Sound/fg_fx.cxx:122:Reading sound sound from Path "/usr/share/flightgear/Aircraft/767-300/Sounds/767-sound.xml"
systems:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Aircraft/flightrecorder.cxx:97:FlightRecorder: Using custom recorder configuration: 767-300 Flight Recorder
cockpit:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Instrumentation/instrument_mgr.cxx:76:Reading instruments from Path "/usr/share/flightgear/Aircraft/767-300/Systems/instrumentation.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-autopilot.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-autothrottle.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-autobrake.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-spoilers.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/pushback.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-flt-ctrls.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/pressurization.xml"
cockpit:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Cockpit/cockpitDisplayManager.cxx:68:Reading cockpit displays from Path "/usr/share/flightgear/Aircraft/767-300/Systems/instrumentation.xml"
 at /usr/share/flightgear/Aircraft/767-300/Models/Liveries/AMX-skyteam.xml,
nasal:5:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Scripting/NasalSys.cxx:1195:  called from: /usr/share/flightgear/Aircraft/767-300/Nasal/systems.nas, line 6
nasal:5:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Scripting/NasalSys.cxx:467:767-300 hydraulic system: so far so good
general:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Main/options.cxx:2505:   option:aircraft-dir = /usr/share/flightgear/Aircraft/767-300
general:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Main/options.cxx:2505:   option:aircraft = 767-300
general:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Main/fg_init.cxx:267:Loading aircraft -set file from:Path "/usr/share/flightgear/Aircraft/767-300/767-300-set.xml"
sound:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Sound/fg_fx.cxx:122:Reading sound sound from Path "/usr/share/flightgear/Aircraft/767-300/Sounds/767-sound.xml"
systems:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Aircraft/flightrecorder.cxx:97:FlightRecorder: Using custom recorder configuration: 767-300 Flight Recorder
cockpit:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Instrumentation/instrument_mgr.cxx:76:Reading instruments from Path "/usr/share/flightgear/Aircraft/767-300/Systems/instrumentation.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-autopilot.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-autothrottle.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-autobrake.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-spoilers.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/pushback.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/767-flt-ctrls.xml"
autopilot:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Autopilot/autopilotgroup.cxx:201:Reading property-rule configuration from Path "/usr/share/flightgear/Aircraft/767-300/Systems/pressurization.xml"
cockpit:3:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Cockpit/cockpitDisplayManager.cxx:68:Reading cockpit displays from Path "/usr/share/flightgear/Aircraft/767-300/Systems/instrumentation.xml"
 at /usr/share/flightgear/Aircraft/767-300/Models/Liveries/AMX-skyteam.xml,
nasal:5:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Scripting/NasalSys.cxx:1195:  called from: /usr/share/flightgear/Aircraft/767-300/Nasal/systems.nas, line 6
nasal:5:/home/kwanza/rpmbuild/BUILD/flightgear-2018.2.2/src/Scripting/NasalSys.cxx:467:767-300 hydraulic system: so far so good
:
kwanza
 
Posts: 30
Joined: Tue Aug 12, 2008 7:07 am

Re: Autostarting the Boeing 767

Postby legoboyvdlp » Sun Nov 11, 2018 7:10 pm

Ok - if there is something wrong with that livery (nasal error at aircraft.livery.init("Aircraft/767-300/Models/Liveries");) then that would break the autostart.

Can you confirm it works without that livery?
User avatar
legoboyvdlp
 
Posts: 5701
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Autostarting the Boeing 767

Postby kwanza » Sun Nov 11, 2018 8:02 pm

Yes it works without the AMX-skyteam livery (at least so far). Why would a livery cause a problem, I wonder? Thanks.
kwanza
 
Posts: 30
Joined: Tue Aug 12, 2008 7:07 am

Re: Autostarting the Boeing 767

Postby legoboyvdlp » Sun Nov 11, 2018 8:24 pm

I see there is a "é" in the livery. Can you open AMX-skyteam.xml, remove the "é", and report if it works?
User avatar
legoboyvdlp
 
Posts: 5701
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Autostarting the Boeing 767

Postby kwanza » Sun Nov 11, 2018 9:18 pm

Well, you might have hit the nail right on the head. I managed to auto-start the plane with the patched AMX-skyteam.xml. Great catch! I would never have thought that a simple accent mark would cause so much grief. Many thanks.
kwanza
 
Posts: 30
Joined: Tue Aug 12, 2008 7:07 am

PreviousNext

Return to Flying

Who is online

Users browsing this forum: No registered users and 1 guest

cron