Board index FlightGear Support Installation Linux

Dead Aircraft when starting without fgrun?

Installing FlightGear, scenery, aircraft etc. on Linux systems like Ubuntu.

Dead Aircraft when starting without fgrun?

Postby bssmusic » Fri Aug 10, 2018 12:07 pm

Hello,
Since 2018.1.1 I experience the following Problem: When starting flightgear directly from the surface ( without fgrun), I get a "dead" airplane. At 172P everything stays dark ( Battery switch and avionics power on), no radio, no starter. :cry:

Options passed on the command line:
Code: Select all
--launcher
--download-dir=/home/peterb/fgfs
Options set in the launcher:
--aircraft-dir=/usr/share/games/flightgear/Aircraft/c172p
--aircraft=c172p
--fg-scenery=/home/peterb/fgfs/Scenery
--fg-scenery=/home/peterb/fgfs/Scenery/Terrasync
--fg-aircraft=/home/peterb/fgfs/Aircraft
--airport=PHNL
--disable-auto-coordination
--enable-freeze
--prop:/sim/multiplay/txhost=mpserver01.flightgear.org
--prop:/sim/multiplay/txport=5000
--callsign=D-ADA1
--enable-terrasync
--enable-fullscreen
--geometry=1920x1080
--prop:/sim/rendering/multi-sample-buffers=1
--prop:/sim/rendering/multi-samples=4
--disable-rembrandt
--disable-auto-coordination
--airport=EDFH
--timeofday=noon
--season=summer
--disable-real-weather-fetch
--prop:/nasal/local_weather/enabled=true
--metar=XXXX 012345Z 15003KT 19SM FEW072 FEW350 25/07 Q1028 NOSIG
--prop:/environment/weather-scenario=Core high pressure region


when choosing seneca II the following: Main switch and magnetos on, every circuit braker on, no avionics power, no vacuum pump, no radios except ADF radio!, which seems to have Power!
When I use Fgrun to start, everything seems normal.

Code: Select all
/usr/games/fgfs
  --fg-root=/usr/share/games/flightgear
  --fg-scenery=/usr/share/games/flightgear/Scenery:/home/peterb/fgfs/Scenery
  --terrasync-dir=/home/peterb/fgfs/Scenery/Terrasync
  --fg-aircraft=/home/peterb/fgfs:/home/peterb/fgfs/Aircraft
  --airport=EDFH
  --aircraft=SenecaII
  --console
  --enable-random-objects
  --enable-hud
  --enable-anti-alias-hud
  --disable-specular-highlight
  --enable-ai-models
  --enable-ai-traffic
  --turbulence=0.05
  --enable-real-weather-fetch
  --enable-clouds3d
  --enable-fullscreen
  --prop:/sim/frame-rate-throttle-hz=60
  --prop:/sim/menubar/autovisibility/enabled=1
  --geometry=1920x1080
  --bpp=32
  --texture-filtering=8
  --prop:/sim/rendering/multi-sample-buffers=1
  --prop:/sim/rendering/multi-samples=2
  --timeofday=noon
  --enable-terrasync
  --httpd=5500
  --props=5501
  --callsign=D-ADA1
  --multiplay=out,10,localhost,5001
  --multiplay=in,10,,5000
  --enable-fgcom
  --atlas=socket,out,5,localhost,5500,udp


Has anybody the same problem, or could explane it?

running 2018.1.1 on Ubuntu 18.04 x64, same on Suse Tumbleweed

Peter
btw, the log says

Code: Select all
lightGear:  Version 2018.1.1
FlightGear:  Build Type Dev
Built with GNU C++ version 7.3
Jenkins number/ID 0:none
Aircraft does not specify a minimum FG version: please add one at /sim/minimum-fg-version
StatsHandler::StatsHandler() Setting up GL2 compatible shaders
Starting automatic scenery download/synchronization to '/windoze/F/fgfs/Scenery/Terrasync'.

In file /windoze/F/fgfs/Aircraft/SenecaII/SenecaII-jsbsim.xml: line 534
      Property gear/serviceable is already defined.

In file /windoze/F/fgfs/Aircraft/SenecaII/SenecaII-jsbsim.xml: line 742
      Property ice/wing is already defined.
Multiplayer mode active!
Volcanic activity off.
Request detected to initialize Advanced Weather on startup...
Loading local weather routines...
Animated jetways ... initialized
KCS55 pictorial navigation system initialized
creating PitotIcingHandler for /systems/pitot[0]
warning: The VAD has been replaced by a hack pending a complete rewrite
KI266 dme indicator #0 initialized
Starting hard-coded terrain presampling
caught exception processing subsystem:traffic-manager
message:Bad arguments to findShortestRoute
caught exception processing subsystem:traffic-manager
message:Bad arguments to findShortestRoute
Last edited by bugman on Sun Aug 12, 2018 11:13 pm, edited 1 time in total.
Reason: Added [code] tags.
Airports: EDFH, LPMA, KOAK
Airplanes: SenecaII, Cessna 172P
bssmusic
 
Posts: 11
Joined: Wed Feb 17, 2016 10:53 am
Location: Gensingen, Germany
Callsign: D-ADA
Version: 217.1.2-21
OS: Linux 64

Re: Dead Aircraft when starting without fgrun?

Postby Thorsten » Sat Aug 11, 2018 7:18 am

Sorry - with FGRun you mean... FGRun or something else (as far as I know FGRun only ever was compiled under Windows, yet you seem to indicate you're under Linux).

If it's not FGRun but the Qt launcher, you're probably running into some state overlay issue. Since technically all the launcher does is assembling a commandline, by copy-pasting the options list from the launcher (when you really show everything) to the commandline, you should have identical results.
Thorsten
 
Posts: 9530
Joined: Mon Nov 02, 2009 8:33 am

Re: Dead Aircraft when starting without fgrun?

Postby wkitty42 » Sat Aug 11, 2018 9:13 am

i'm curious why one command line list has "--enable-freeze" and the other does not... that would cause the symptoms for the c172p, i think...

looking at the log output, it would appear the OP is talking about the new Qt launcher instead of FGRun... i say that because the log output has the thing about starting Advanced Weather automatically and FGRun doesn't/can't do that TTBOMK...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4535
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Dead Aircraft when starting without fgrun?

Postby WoodSTokk » Sat Aug 11, 2018 11:05 am

Thorsten wrote in Sat Aug 11, 2018 7:18 am:... as far as I know FGRun only ever was compiled under Windows, yet you seem to indicate you're under Linux.

Not true. I have previously (with older versions) also FGRun installed on my Debian.
It is in the repo for jessie --> https://packages.debian.org/jessie/fgrun.
But i think the OP use the build in launcher, because the parameter '--launcher' is in his/her command line.
WoodSTokk
 
Posts: 41
Joined: Tue Oct 17, 2017 2:30 pm
Location: Milky Way/Sol/Earth/Europe
Callsign: OE-WST
IRC name: WoodSTokk
Version: 2018.1.1
OS: Debian Buster/Sid

Re: Dead Aircraft when starting without fgrun?

Postby bssmusic » Sat Aug 11, 2018 1:20 pm

Thorsten wrote in Sat Aug 11, 2018 7:18 am:Sorry - with FGRun you mean... FGRun or something else (as far as I know FGRun only ever was compiled under Windows, yet you seem to indicate you're under Linux).

If it's not FGRun but the Qt launcher, you're probably running into some state overlay issue. Since technically all the launcher does is assembling a commandline, by copy-pasting the options list from the launcher (when you really show everything) to the commandline, you should have identical results.


According to Synaptic it's indeed
fgrun 2016.4.0-1
Is there a possibility to add screenshots? I think that could clarify?

Uh, Oh ...
when i was looking for fgrun, Synaptic proposed an update, which broke fgfs completely.

Code: Select all
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/flightgear-data-base_1%3a2018.3.0~8553+gitdb7a9b4c+dfsg-0ubuntu1~ppa1_all.deb (--unpack):
 Versuch, »/usr/share/games/flightgear/Aircraft/c172p/WebPanel/bootstrap/bootstrap.min.css« zu überschreiben, welches auch in Paket flightgear-phi 2016.4.2+dfsg1-1 ist
dpkg-deb: Fehler: Unterprozess einfügen wurde durch das Signal (Datenübergabe unterbrochen (broken pipe)) getötet
dpkg: Dekonfiguration von flightgear-data-base wird in Betracht gezogen, welches durch Installation von »flightgear-phi« beschädigt würde ...
dpkg: Ja, flightgear-data-base wird dekonfiguriert (beschädigt durch flightgear-phi)
Vorbereitung zum Entpacken von .../flightgear-phi_1%3a2018.2.2+dfsg-0ubuntu1~ppa7_all.deb ...
flightgear-data-base (1:2018.1.1+dfsg-1) wird de-konfiguriert ...
Entpacken von flightgear-phi (1:2018.2.2+dfsg-0ubuntu1~ppa7) über (2016.4.2+dfsg1-1) ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/flightgear-data-base_1%3a2018.3.0~8553+gitdb7a9b4c+dfsg-0ubuntu1~ppa1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Could flightgear-phi be the villain?

I'll try and deinstall it.
No, that was not the solution: When i try to start by fgrun or ffgo, i get in the log
"fgfs: symbol lookup error: fgfs: undefined symbol: _ZTIN7simgear12TarExtractorE"
Same if starting fgfs directly in Konsole, no further error messages.
No idea if this might be helpful
Last edited by bugman on Sun Aug 12, 2018 11:15 pm, edited 1 time in total.
Reason: Added [code] tags.
Airports: EDFH, LPMA, KOAK
Airplanes: SenecaII, Cessna 172P
bssmusic
 
Posts: 11
Joined: Wed Feb 17, 2016 10:53 am
Location: Gensingen, Germany
Callsign: D-ADA
Version: 217.1.2-21
OS: Linux 64

Re: Dead Aircraft when starting without fgrun?

Postby wkitty42 » Sat Aug 11, 2018 4:21 pm

that's the old FGRun that isn't really supported any more... forget that thing, please... use the new internal Qt launcher (eg: fgfs --launcher) which is supported...

with the error you show, it looks like things got out of sync and you have different libraries in place than what are expected...

it is extremely doubtful that phi will be causing your problems... it is only the web page code for watching FG ops via browser... in other words, it is pretty much only a watcher, not a setter...

the MAIN thing is that your dpkg output shows a mixing of the following... note the versions in the names... this will never work...

flightgear-data-base_1%3a2018.3.0~8553+gitdb7a9b4c+dfsg-0ubuntu1~ppa1_all.deb
flightgear-phi 2016.4.2+dfsg1-1
flightgear-phi_1%3a2018.2.2+dfsg-0ubuntu1~ppa7_all.deb

all of FG related installation archives must be of the same version... they cannot be mixed and matched... if you are using multiple PPAs, drop all of them except for one... you're probably better served to use only the stable PPA and not the edge... i would uninstall all of FG and then reinstall from only the stable PPA making sure that all of the proposed packages have the same version numbering...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4535
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Dead Aircraft when starting without fgrun?

Postby saiarcot895 » Sat Aug 11, 2018 4:24 pm

Basically what wkitty42 said. It looks like you have packages installed from the Stable PPA, the Edge/Development PPA, and the distro packages, which are three separate versions and cannot be used together. I recommend completely uninstalling flightgear-related packages (this includes flightgear, libsimgearcore*, libsimgearscene*, flightgear-data-*) and installing from only one source.
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 293
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: Dead Aircraft when starting without fgrun?

Postby bssmusic » Sat Aug 11, 2018 5:04 pm

Ah, OK! I had not understood that right before. I'll do so tomorrow and report, if successful.
Thank You
Peter
Last edited by bugman on Sun Aug 12, 2018 6:08 am, edited 1 time in total.
Reason: Please do not quote the entire previous post.
Airports: EDFH, LPMA, KOAK
Airplanes: SenecaII, Cessna 172P
bssmusic
 
Posts: 11
Joined: Wed Feb 17, 2016 10:53 am
Location: Gensingen, Germany
Callsign: D-ADA
Version: 217.1.2-21
OS: Linux 64

Re: Dead Aircraft when starting without fgrun?

Postby bssmusic » Sun Aug 12, 2018 12:29 pm

saiarcot895 wrote in Sat Aug 11, 2018 4:24 pm: I recommend completely uninstalling flightgear-related packages (this includes flightgear, libsimgearcore*, libsimgearscene*, flightgear-data-*) and installing from only one source.


OK, I have removed ("vollständig deinstallieren") everything I could find related to FlightGear, changed to "http://ppa.launchpad.net/saiarcot895/flightgear/ubuntu"
and made a fresh install. Same procedure as every year! The battery seems to be completely empty. I have added two links to my dropbox for two (small) screenshots, mains and avionic breakers are on, Battery gauge shows "Zero"

https://www.dropbox.com/s/3jqln3s9khj3i ... a.png?dl=0
and
https://www.dropbox.com/s/0otafiak2eise ... a.png?dl=0
The only devices which seem to have power are the green testbutton beside the overboost warnings and the ADF radio.
Fgfs was started with "fgfs --launcher" from terminal, here the complete error messages:

Code: Select all
peterb@blue:~$ fgfs --launcher
FlightGear:  Version 2018.2.2
FlightGear:  Build Type Dev
Built with GNU C++ version 7.3
Jenkins number/ID 0:none
inotify_add_watch("/home/peterb/.config/ibus/bus/6514eb0d5825478594e8873753b2b556-unix-0") failed: "No space left on device"    ## ???
platform default fg_root = Path "/usr/share/games/flightgear"
Reading global defaults
Finished Reading global defaults
Reading user settings from Path "/home/peterb/.fgfs/autosave_2018_2.xml"
NavCache at:Path "/home/peterb/.fgfs/navdata_2018_2.cache"
NavCache read-only flags is:0
NavCache: no main cache rebuild required
init package root at:Path "/home/peterb/.fgfs/Aircraft"
adding subsystem to group with name 'http', but name() returns ''
libpng warning: iCCP: known incorrect sRGB profile
reading groundnet data from Path "/windoze/F/fgfs/Scenery/Airports/P/H/N/PHNL.groundnet.xml"
parsing groundnet XML took 5
libpng warning: iCCP: known incorrect sRGB profile
launcher auto state selection, picked:
multiple values forbidden for option:airport, ignoring:PHNL   ## ???
aircraft = c172p
found aircraft in dir: /usr/share/games/flightgear/Aircraft/c172p
Aircraft does not specify a minimum FG version: please add one at /sim/minimum-fg-version
Found language resource for: de_DE
Reading localized strings for 'en' from Path "/usr/share/games/flightgear/Translations/default/sys.xml"
Reading localized strings for 'de' from Path "/usr/share/games/flightgear/Translations/de/sys.xml"
Reading localized strings for 'en' from Path "/usr/share/games/flightgear/Translations/default/atc.xml"
Reading localized strings for 'de' from Path "/usr/share/games/flightgear/Translations/default/atc.xml"
Reading localized strings for 'en' from Path "/usr/share/games/flightgear/Translations/default/tips.xml"
Reading localized strings for 'de' from Path "/usr/share/games/flightgear/Translations/de/tips.xml"
   option:disable-auto-coordination =
   option:airport = EDFH
   option:prop = /sim/rendering/multi-sample-buffers=1
   option:prop = /sim/rendering/multi-samples=4
   option:disable-rembrandt =
   option:enable-fullscreen =
Setting geometry to 1920x1080

   option:geometry = 1920x1080
   option:enable-terrasync =
   option:enable-freeze =
   option:prop = /nasal/local_weather/enabled=true
   option:metar = XXXX 012345Z 15003KT 19SM FEW072 FEW350 25/07 Q1028 NOSIG
   option:prop = /environment/weather-scenario=Core high pressure region
   option:timeofday = noon
   option:state =
   option:aircraft-dir = /usr/share/games/flightgear/Aircraft/c172p
   option:aircraft = c172p
   option:launcher =
Using default download dir: Path "/home/peterb/.fgfs"
read-allowed path not found:Path "/home/peterb/.fgfs/AI"
read-allowed path not found:Path "/home/peterb/.fgfs/Liveries"
Using TerraSync dir: Path "/home/peterb/.fgfs/TerraSync"
EmbeddedResourceManager: selected locale 'de_DE'
Using stock OSG implementation of GraphicsWindow
initializing cloud layers
Enabling ATI/AMD viewport hack
Configuration State
======= ==============
aircraft-dir = "/usr/share/games/flightgear/Aircraft/c172p"
fghome-dir = "Path "/home/peterb/.fgfs""
download-dir = "/home/peterb/.fgfs"
terrasync-dir = "/home/peterb/.fgfs/TerraSync"
aircraft-search-paths =
   
scenery-search-paths =
   /home/peterb/.fgfs/TerraSync
   /usr/share/games/flightgear/Scenery
Image loading failed:Warning: reading "/usr/share/games/flightgear/Aircraft/c172p" not supported.
NVIDIA Corporation
GeForce GTX 960/PCIe/SSE2
4.6.0 NVIDIA 396.51
4.60 NVIDIA
Splash screen progress loading-aircraft-list
adding subsystem to group with name 'terrasync', but name() returns ''
Starting automatic scenery download/synchronization to '/home/peterb/.fgfs/TerraSync'.
Splash screen progress loading-nav-dat
picking entry # 1, server is http://mpserver16.flightgear.org/scenery
terrasync scenery provider of the day is 'http://mpserver16.flightgear.org/scenery'
Splash screen progress init-scenery
sync of http://mpserver16.flightgear.org/scenery/Models started, queue size is 26
adding subsystem to group with name 'time', but name() returns ''
General Initialization
======= ==============
FG_ROOT = "Path "/usr/share/games/flightgear""

Attempting to set starting position from airport code EDFH heading 270
Reading timezone info from: Path "/usr/share/games/flightgear/Timezone/zone.tab"
adding subsystem to group with name 'scenery', but name() returns ''
Selected scenery is tilecache
FGStgTerrain::init - init tilemgr
Initializing Tile Manager subsystem.
Initializing the tile cache.
  max cache size = 100
  current cache size = 0
  done with init()
Splash screen progress finalize-position
Splash screen progress creating-subsystems
Creating Subsystems
========== ==========
adding subsystem to group with name 'sound', but name() returns ''
adding subsystem to group with name 'prop-interpolator', but name() returns ''
adding subsystem to group with name 'properties', but name() returns ''
adding subsystem to group with name 'airport-dynamics', but name() returns ''
adding subsystem to group with name 'performance-mon', but name() returns ''
Reading materials from /usr/share/games/flightgear/Materials/regions/materials.xml
Successfully synchronized directory 'Models'
sync of http://mpserver16.flightgear.org/scenery/Airports/L started, queue size is 25
Successfully synchronized directory 'Airports/L'
sync of http://mpserver16.flightgear.org/scenery/Airports/K started, queue size is 24
Successfully synchronized directory 'Airports/K'
sync of http://mpserver16.flightgear.org/scenery/Airports/J started, queue size is 23
Successfully synchronized directory 'Airports/J'
sync of http://mpserver16.flightgear.org/scenery/Airports/I started, queue size is 22
Successfully synchronized directory 'Airports/I'
sync of http://mpserver16.flightgear.org/scenery/Airports/H started, queue size is 21
Successfully synchronized directory 'Airports/H'
sync of http://mpserver16.flightgear.org/scenery/Airports/G started, queue size is 20
Successfully synchronized directory 'Airports/G'
sync of http://mpserver16.flightgear.org/scenery/Airports/F started, queue size is 19
Successfully synchronized directory 'Airports/F'
sync of http://mpserver16.flightgear.org/scenery/Airports/E started, queue size is 18
Successfully synchronized directory 'Airports/E'
sync of http://mpserver16.flightgear.org/scenery/Airports/D started, queue size is 17
Successfully synchronized directory 'Airports/D'
sync of http://mpserver16.flightgear.org/scenery/Airports/C started, queue size is 16
Successfully synchronized directory 'Airports/C'
sync of http://mpserver16.flightgear.org/scenery/Airports/B started, queue size is 15
Successfully synchronized directory 'Airports/B'
sync of http://mpserver16.flightgear.org/scenery/Airports/A started, queue size is 14
Successfully synchronized directory 'Airports/A'
sync of http://mpserver16.flightgear.org/scenery/Airports/Z started, queue size is 13
Successfully synchronized directory 'Airports/Z'
sync of http://mpserver16.flightgear.org/scenery/Airports/Y started, queue size is 12
adding subsystem to group with name 'dns', but name() returns ''
adding subsystem to group with name 'flight', but name() returns ''
adding subsystem to group with name 'controller', but name() returns ''
adding subsystem to group with name 'precipitation', but name() returns ''
adding subsystem to group with name 'realwx', but name() returns ''
adding subsystem to group with name 'terrainsampler', but name() returns ''
adding subsystem to group with name 'ridgelift', but name() returns ''
adding subsystem to group with name 'magvar', but name() returns ''
adding subsystem to group with name 'environment', but name() returns ''
adding subsystem to group with name 'ephemeris', but name() returns ''
Reading systems from Path "/usr/share/games/flightgear/Aircraft/c172p/Systems/systems.xml"
adding subsystem to group with name 'electrical0', but name() returns ''
adding subsystem to group with name 'system1', but name() returns ''
adding subsystem to group with name 'system2', but name() returns ''
adding subsystem to group with name 'system3', but name() returns ''
adding subsystem to group with name 'systems', but name() returns ''
adding subsystem to group with name 'instrumentation', but name() returns ''
Initializing HUD Instrument
adding subsystem to group with name 'hud', but name() returns ''
adding subsystem to group with name 'cockpit-displays', but name() returns ''
adding subsystem to group with name 'xml-autopilot', but name() returns ''
adding subsystem to group with name 'xml-proprules', but name() returns ''
adding subsystem to group with name 'route-manager', but name() returns ''
adding subsystem to group with name 'io', but name() returns ''
adding subsystem to group with name 'logger', but name() returns ''
adding subsystem to group with name 'gui', but name() returns ''
adding subsystem to group with name 'Canvas', but name() returns ''
adding subsystem to group with name 'CanvasGUI', but name() returns ''
adding subsystem to group with name 'aircraft-performance-db', but name() returns ''
adding subsystem to group with name 'ATC', but name() returns ''
adding subsystem to group with name 'mp', but name() returns ''
adding subsystem to group with name 'ai-model', but name() returns ''
adding subsystem to group with name 'submodel-mgr', but name() returns ''
adding subsystem to group with name 'traffic-manager', but name() returns ''
adding subsystem to group with name 'controls', but name() returns ''
adding subsystem to group with name 'input-mouse', but name() returns ''
adding subsystem to group with name 'input-keyboard', but name() returns ''
adding subsystem to group with name 'input-joystick', but name() returns ''
adding subsystem to group with name 'input-event', but name() returns ''
adding subsystem to group with name 'input', but name() returns ''
adding subsystem to group with name 'replay', but name() returns ''
adding subsystem to group with name 'history', but name() returns ''
adding subsystem to group with name 'voice', but name() returns ''
adding subsystem to group with name 'fgcom', but name() returns ''
adding subsystem to group with name 'lighting', but name() returns ''
adding subsystem to group with name 'events', but name() returns ''
Reading sound sound from Path "/usr/share/games/flightgear/Aircraft/c172p/c172-sound.xml"
adding subsystem to group with name 'aircraft-model', but name() returns ''
adding subsystem to group with name 'model-manager', but name() returns ''
adding subsystem to group with name 'view-manager', but name() returns ''
Creating subsystems took:2310
Splash screen progress binding-subsystems
FGPropertyManager::GetNode() No node found for hydro/active-norm
Volcanic activity off.
Request detected to initialize Advanced Weather on startup...
Loading local weather routines...
Animated jetways ... initialized
KMA20 audio panel initialized
Hobbs system stopped
Hobbs system stopped
Starter off
KI266 dme indicator #0 initialized
warning: The VAD has been replaced by a hack pending a complete rewrite
Primer reset to 0
Electrical system initialized
caught exception processing subsystem:traffic-manager
message:Bad arguments to findShortestRoute
caught exception processing subsystem:traffic-manager
message:Bad arguments to findShortestRoute
caught exception processing subsystem:traffic-manager
message:Bad arguments to findShortestRoute
caught exception processing subsystem:traffic-manager
message:Bad arguments to findShortestRoute
caught exception processing subsystem:traffic-manager
message:Bad arguments to findShortestRoute
(exceptionCount=5, suspending)


Could i have overseen any ".file" containing not matching advices?
Last edited by bugman on Sun Aug 12, 2018 11:09 pm, edited 3 times in total.
Reason: Added [code] tags.
Airports: EDFH, LPMA, KOAK
Airplanes: SenecaII, Cessna 172P
bssmusic
 
Posts: 11
Joined: Wed Feb 17, 2016 10:53 am
Location: Gensingen, Germany
Callsign: D-ADA
Version: 217.1.2-21
OS: Linux 64

Re: Dead Aircraft when starting without fgrun?

Postby Thorsten » Sun Aug 12, 2018 1:39 pm

Is the electric system failure box checked by any chance?
Thorsten
 
Posts: 9530
Joined: Mon Nov 02, 2009 8:33 am

Re: Dead Aircraft when starting without fgrun?

Postby wkitty42 » Sun Aug 12, 2018 3:50 pm

bssmusic wrote in Sun Aug 12, 2018 12:29 pm:and made a fresh install. Same procedure as every year! The battery seems to be completely empty.

use the F10 menu and go into the c172p section... click the [Repair] button and it should fix anything that is broken as well as recharging the battery... yes, battery drainage is modeled and sitting there idling without the engine running but with lights and etc on will drain the battery...

if that doesn't fix it, then go into your ~/.fgfs/aircraft-data folder and delete the xml file for the c172p in there... we have found that sometimes properties saved don't load properly when new versions of the craft are installed... deleting this one file fixes that... you will have to make your specific craft customization choices again (livery, engine, wheels, etc) and the flying time on the hobbs meter will be reset...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4535
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Dead Aircraft when starting without fgrun?

Postby bssmusic » Sun Aug 12, 2018 6:08 pm

Thorsten wrote in Sun Aug 12, 2018 1:39 pm:Is the electric system failure box checked by any chance?

Good idea, but no, it is unchecked in both cases
Airports: EDFH, LPMA, KOAK
Airplanes: SenecaII, Cessna 172P
bssmusic
 
Posts: 11
Joined: Wed Feb 17, 2016 10:53 am
Location: Gensingen, Germany
Callsign: D-ADA
Version: 217.1.2-21
OS: Linux 64

Re: Dead Aircraft when starting without fgrun?

Postby bssmusic » Sun Aug 12, 2018 6:31 pm

wkitty42 wrote in Sun Aug 12, 2018 3:50 pm:use the F10 menu and go into the c172p section... click the [Repair] button [/quote)

done

if that doesn't fix it, then go into your ~/.fgfs/aircraft-data folder and delete the xml file for the c172p in there... .


done, but no effect, on model 82 as well as model 81 no power - have i forgotten to pay my gasoline bills??
Airports: EDFH, LPMA, KOAK
Airplanes: SenecaII, Cessna 172P
bssmusic
 
Posts: 11
Joined: Wed Feb 17, 2016 10:53 am
Location: Gensingen, Germany
Callsign: D-ADA
Version: 217.1.2-21
OS: Linux 64

Re: Dead Aircraft when starting without fgrun?

Postby wkitty42 » Mon Aug 13, 2018 12:20 am

you did exit the sim, delete the file and then restart the sim, right? otherwise it is possible the bad settings got resaved again...

i don't know what "model 82" is and neither "model 81"... WHY do people shorthand what they are saying like this???
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4535
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Dead Aircraft when starting without fgrun?

Postby bssmusic » Mon Aug 13, 2018 7:47 am

wkitty42 wrote in Mon Aug 13, 2018 12:20 am:you did exit the sim, delete the file and then restart the sim, right? otherwise it is possible the bad settings got resaved again...

right, so i did - is there yet another place, where data could be stored?
i don't know what "model 82" is and neither "model 81"... WHY do people shorthand what they are saying like this???

c172p model 81 and c172p model 82, sorry, we spoke about Cessna 172P before and i did not want to repeat and quote all and everything :wink:
I tried to start fgfs without any launcher and expected to be on a c172p mod. 81 in San Francisco, but got a 172p Mod 82 in Honolulu. Anyway, I had Power on the Battery, so i think, the problem is around the launcher indeed, it produces log:
"Nasal runtime error: non numeric argument to pow()
at /windoze/F/fgfs/Aircraft/c172p/Nasal/engine.nas, line 100"
When starting with ffgo (http://frougon.net/projects/FFGo/), I get the Cessna running, but not the Piper Seneca - I will try to figure this out.
As I have a second (remaining :) ) working folder on an other partition, maybe I have to kill and rebuild it.
Airports: EDFH, LPMA, KOAK
Airplanes: SenecaII, Cessna 172P
bssmusic
 
Posts: 11
Joined: Wed Feb 17, 2016 10:53 am
Location: Gensingen, Germany
Callsign: D-ADA
Version: 217.1.2-21
OS: Linux 64

Next

Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest