Board index FlightGear Development

Problem with runway lights

FlightGear is opensource, so you can be the developer. In the need for help on anything? We are here to help you.
Forum rules
Core development is discussed on the official FlightGear-Devel development mailing list.

Bugs can be reported in the bug tracker.

Problem with runway lights

Postby Anarcho-pilot » Thu May 24, 2018 7:20 pm

Since I've upgraded to version 2018.1.1, I've got all approach lights visible from the both sides:
Image
Does someone else have the same problem or any ideas how to solve?
User avatar
Anarcho-pilot
 
Posts: 55
Joined: Mon Jul 17, 2017 7:45 pm
Location: Kharkiv, Ukraine
Callsign: Rogue1
Version: 2018.1.1
OS: Xubuntu 16.04 LTS

Re: Problem with runway lights

Postby RJ5576 » Fri May 25, 2018 6:44 pm

I think that's normal. It may be unrealistic, but as far as I know, FlightGear has always done that.
RJ5576
 
Posts: 85
Joined: Wed Feb 20, 2013 3:24 am
Location: Between KSEA and KPDX
Callsign: RJ5576
Version: 2018.1.1
OS: Linux Mint Sylvia

Re: Problem with runway lights

Postby Thorsten » Sat May 26, 2018 5:27 am

We do have directional lights supported, and last time I checked this did work.
Thorsten
 
Posts: 9435
Joined: Mon Nov 02, 2009 8:33 am

Re: Problem with runway lights

Postby Anarcho-pilot » Sat May 26, 2018 4:38 pm

Here is the same place at the same time in FlightGear 2017.3.1 on another computer:
Image
Before version 2018.1.1 everything was ok on both computers. RJ5576, do you use FG 2018.1.1 and have the same problem?
User avatar
Anarcho-pilot
 
Posts: 55
Joined: Mon Jul 17, 2017 7:45 pm
Location: Kharkiv, Ukraine
Callsign: Rogue1
Version: 2018.1.1
OS: Xubuntu 16.04 LTS

Re: Problem with runway lights

Postby wkitty42 » Sat May 26, 2018 5:19 pm

Anarcho-pilot wrote in Sat May 26, 2018 4:38 pm:Here is the same place at the same time in FlightGear 2017.3.1 on another computer:

these lights are different... these are little round balls whereas the others are points (aka point sprites)... check the F10->View-Rendering_Options on both systems and make sure they are the same...

please, also tell us which airport you are at so others can try to duplicate your situation...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4301
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Problem with runway lights

Postby Anarcho-pilot » Sun May 27, 2018 1:25 pm

wkitty42 wrote in Sat May 26, 2018 5:19 pm:please, also tell us which airport you are at so others can try to duplicate your situation...

In my case this problem spreads worldwide. My screenshots were taken at UKHH, runway 07.
wkitty42 wrote in Sat May 26, 2018 5:19 pm:these lights are different... these are little round balls whereas the others are points (aka point sprites)... check the F10->View-Rendering_Options on both systems and make sure they are the same...

Yes, on the first screenshot point sprites are enabled and on the second - disabled. This is because the second computer has low-power GPU which cannot display them correctly. But this option doesn't mention. Here is the same place on the first computer without point sprites:

Image

Also pay attention at 18 threshold lights on the very first screenshot. They are brown. This is because they must be red in the one direction, green - in the another, and now this colours are mixing. Same with 11 pink centerline lights, which must be red in the one direction and white - in the another.

I'm not the only one, who have this problem. I noticed it in the yesterday FGUK's stream.
Airports:
5:20 - LQSA
2:07:30 - EGKK

User avatar
Anarcho-pilot
 
Posts: 55
Joined: Mon Jul 17, 2017 7:45 pm
Location: Kharkiv, Ukraine
Callsign: Rogue1
Version: 2018.1.1
OS: Xubuntu 16.04 LTS

Re: Problem with runway lights

Postby Richard » Sun May 27, 2018 2:12 pm

Directional light points are currently not working correctly; I don't think it's specific to any given airport.

There are a number of 'changes that have affected this; most recently my fix to use points as geomety (to fix all light points on AMD 3d cards), but this may only have accentuated the problem; as directional lights have been turned off in the shader effect definition since 2015 due a problem with the definition of the direction (or something like that).

I had a brief attempt to restore the directionality by re-enabling this flag, and although it does restore a version of directional lighting the lights aren't pointing in the right direction. What I mean by this is that on approach the lights fade in and out; so it's a problem that might not be easily fixed.
Richard
 
Posts: 567
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: Problem with runway lights

Postby Anarcho-pilot » Mon May 28, 2018 11:18 am

So, core-developers know about this problem and trying to fix it?
User avatar
Anarcho-pilot
 
Posts: 55
Joined: Mon Jul 17, 2017 7:45 pm
Location: Kharkiv, Ukraine
Callsign: Rogue1
Version: 2018.1.1
OS: Xubuntu 16.04 LTS

Re: Problem with runway lights

Postby Richard » Mon May 28, 2018 7:02 pm

It's been discussed - but there a possibly quite a few wrong things with the directional lighting in general that need to be fixed properly. The last build didn't work properly on AMD cards, but I think that also it wasn't actually working properly on NVidia either; and that the directionality was merely because the lights faced away from the view point; i.e. the angles of visibility weren't being correctly calculated.

Hopefully it'll get fixed in the next release - but it is a tricky issue so it might take longer.
Richard
 
Posts: 567
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: Problem with runway lights

Postby Anarcho-pilot » Mon May 28, 2018 8:33 pm

I wish you luck with it. Hope, you'll manage to fix it till the next release. By the way, PAPI lights are displaying correctly.
User avatar
Anarcho-pilot
 
Posts: 55
Joined: Mon Jul 17, 2017 7:45 pm
Location: Kharkiv, Ukraine
Callsign: Rogue1
Version: 2018.1.1
OS: Xubuntu 16.04 LTS

Re: Problem with runway lights

Postby Lonsed » Wed Jun 06, 2018 2:54 pm

having pretty much the exact same problem and i was wondering if you have any updates? thanks for all your responses guys, that's pretty helpful, but i would really like to know what you've done OP? lots of thanks!
Lonsed
 
Posts: 1
Joined: Wed Jun 06, 2018 2:49 pm

Re: Problem with runway lights

Postby Anarcho-pilot » Wed Jun 06, 2018 5:03 pm

Lonsed, welcome to the FlightGear forum!
User avatar
Anarcho-pilot
 
Posts: 55
Joined: Mon Jul 17, 2017 7:45 pm
Location: Kharkiv, Ukraine
Callsign: Rogue1
Version: 2018.1.1
OS: Xubuntu 16.04 LTS


Return to Development

Who is online

Users browsing this forum: No registered users and 2 guests