Board index FlightGear Support Graphics

Very large coloured pixels, and fps drops

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Very large coloured pixels, and fps drops

Postby ImperiumCreed » Sat Feb 13, 2021 8:58 pm

Hello, I just installed FlightGear today and everytime I press "fly" the loading screen looks like this. Most of the time it does not respond and shuts down, but when I do load in I have massive fps drops when looking around. What could be the problem?

I have an AMD RX580 8GB, Ryzen 2600, and 16GB of RAM.

https://imgur.com/a/uDLxbO3
ImperiumCreed
 
Posts: 1
Joined: Sat Feb 13, 2021 9:58 am

Re: Very large coloured pixels, and fps drops

Postby Michat » Sat Feb 13, 2021 9:48 pm

Hello, you may need to update AMD drivers.

Not an specific AMD problem. Other Ryzen users are running FG without problems after updating.

Check it and report.
User avatar
Michat
 
Posts: 1110
Joined: Mon Jan 25, 2010 6:24 pm
Location: Spain
Version: 191b
OS: GNewSense

Re: Very large coloured pixels, and fps drops

Postby WoodSTokk » Sun Feb 14, 2021 1:04 am

Start FG with
Code: Select all
--prop:/sim/gui/current-style=0

or add it as additional settings in the launcher.
This should help against the fps drop and to see the menu.
WoodSTokk
 
Posts: 820
Joined: Tue Oct 17, 2017 2:30 pm
Location: Milky Way/Sol/Earth/Europe
Callsign: OE-WST
IRC name: WoodSTokk
Version: 2020.4.0
OS: Debian Buster

Re: Very large coloured pixels, and fps drops

Postby Husky Dynamics » Sun Feb 14, 2021 2:19 am

The GUI style change is a must for AMD users, otherwise the words on the menu will flicker constantly and be unreadable.

As far as the pixellated loading screen, mine does that as well until I hit the maximize button (I don't start in fullscreen). Then it flips back to normal.
Get my custom FG liveries here (check back often for new stuff): http://flightgearhusky.altervista.org/
User avatar
Husky Dynamics
 
Posts: 82
Joined: Mon Oct 12, 2020 9:33 pm
Callsign: HUSKY
Version: FG2020.3.6
OS: Win10 Home 64


Return to Graphics

Who is online

Users browsing this forum: No registered users and 0 guests