Board index FlightGear The FlightGear project

Why is the Ubuntu FlightGear package an older version?

Questions about the FlightGear organisation, website, wiki etc.

Re: METAR not working

Postby SurferTim » Sat Aug 10, 2019 9:58 am

Alant wrote in Sat Aug 10, 2019 9:52 am:Please read the wiki article. The script builds either the latest development or the release version. You can choose..

i have the Ubuntu "current stable version" 2018.3.1 from the saircot ppa.

The development version was full of bugs last I checked.

If this is all so easy (as I have said before), why is the "current stable version" not on the saircot ppa?
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 257
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: METAR not working

Postby SurferTim » Sat Aug 10, 2019 10:58 am

SWING AND A MISS!! STRIKE 2!!

The download_and_compile.sh script worked! It installed v2019.2.0. Then why the "STRIKE 2"? No data files are available for that version.

When I run the run_fgfs.sh, it pops up a window asking for data files, and a download button if you don't have them yet. Click on the download button and FAIL! A fancy version of error 404. No data files. :cry:
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 257
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: METAR not working

Postby Alant » Sat Aug 10, 2019 11:13 am

A git pull from https://git.code.sf.net/p/flightgear/fgdata will give you that version of fgdata.
Alant
 
Posts: 878
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Re: METAR not working

Postby legoboyvdlp » Sat Aug 10, 2019 11:55 am

SurferTim wrote in Sat Aug 10, 2019 9:58 am:The development version was full of bugs last I checked.

If this is all so easy (as I have said before), why is the "current stable version" not on the saircot ppa?


because you're talking to people here who have no control over saircot's ppa, not to saircot...?

And are these bugs linux-specific, because 2019.2 is rather stable right now.
User avatar
legoboyvdlp
 
Posts: 6872
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: METAR not working

Postby SurferTim » Sat Aug 10, 2019 12:32 pm

I tried communicating with saircot with only partial results. At one point he recommended I purge my copy of flightgear and reinstall. That didn't go well at first. Much swearing, wailing, and gnashing of teeth. :cry:

So far, this download_and_compile.sh script is about as close as I have come to upgrading. The data is all I have remaining to download, but have run into a bit of difficulty with that. I'll let you know how I did.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 257
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: METAR not working

Postby legoboyvdlp » Sat Aug 10, 2019 12:34 pm

was that his response when you asked him if he could upgrade to 2018.3.3...?
User avatar
legoboyvdlp
 
Posts: 6872
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: METAR not working

Postby SurferTim » Sat Aug 10, 2019 12:37 pm

legoboyvdlp wrote in Sat Aug 10, 2019 12:34 pm:was that his response when you asked him if he could upgrade to 2018.3.3...?

No. That was a while ago when the daily beta failed and I had to back up to a stable version (2018.3.1). No response since.

If this script works, that is the ticket. Once I had the beta version purged, the script worked, except the data.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 257
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: METAR not working

Postby legoboyvdlp » Sat Aug 10, 2019 12:40 pm

Ah ok. I still don't get why that means he can't upgrade his PPA to the newest version though. It might be worth asking him again.
User avatar
legoboyvdlp
 
Posts: 6872
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: METAR not working

Postby SurferTim » Sat Aug 10, 2019 1:06 pm

OK, I had to change to git call a bit to get it to work:
Code: Select all
git clone git://git.code.sf.net/p/flightgear/fgdata


The download_and_compile.sh script needs to be edited to use that call. Otherwise, it will fail.

I am now running 2019.2.0. I'll take a lap around the Caribbean to see how well it works.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 257
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: METAR not working

Postby wkitty42 » Sat Aug 10, 2019 8:55 pm

SurferTim wrote in Sat Aug 10, 2019 10:58 am:The download_and_compile.sh script worked! It installed v2019.2.0. Then why the "STRIKE 2"? No data files are available for that version.

what options have you told the dnc script to use?

i generally use these in my wrapper script to i build the same every time... the following is for a normal release type build...
Code: Select all
CFLAGS="-march=native" CPPFLAGS="-march=native" $MYFGBASEDIR/dnc.sh -a n -p n -j $(($(nproc)-1)) -b RelWithDebInfo -f Release PLIB OSG SIMGEAR FGFS DATA
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5510
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: METAR not working

Postby SurferTim » Sat Aug 10, 2019 9:18 pm

Eventually, this did it.
Code: Select all
./download_and_compile.sh --git-clone-default-proto=git SIMGEAR FGFS DATA


It worked on Ubuntu 18.04, but I still have trouble with Ubuntu 16.04. No big deal though.
Fly low, fly slow, land on a dime. Twin Otter.
SurferTim
 
Posts: 257
Joined: Sun Dec 09, 2018 5:49 pm
Location: Miramar Beach, FL
Callsign: Pirate
Version: 2019.2.0
OS: Ubuntu 18.04

Re: Why is the Ubuntu FlightGear package an older version?

Postby V12 » Tue Aug 13, 2019 3:47 pm

SurferTim ?
What is Your opinion from that new version ? Is there jittering, frame pausing and other glitches known from 2018.X.X. version ? Have You better fps ?
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1367
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Previous

Return to The FlightGear project

Who is online

Users browsing this forum: No registered users and 3 guests