Board index FlightGear Support Installation

Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Need help getting up and running? Installing FlightGear, add-on planes, sceneries etc.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?

Please, also see Requesting Technical Help.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby Parnikkapore » Tue Jan 08, 2019 11:16 pm

Huh. That should've been fixed...

Sidenote: It happens all the time on new releases. I had to send a PM to Saiarcot each time this happens...

But BTW, a .deb and an .rpm from Jenkins would be nice, as the PPA download servers are very slow. (FTR, ~200kb/s)
There are free alternatives to every program you encounter. You just have to find them.
Parnikkapore
 
Posts: 818
Joined: Thu Oct 29, 2015 10:16 am
Callsign: HS-FGS
Version: next [PPA]
OS: Mint 18

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby saiarcot895 » Wed Jan 09, 2019 3:21 am

alicea wrote in Tue Jan 08, 2019 10:23 pm:Tried to upgrade my FG from 2018.1 to 2018.3. DISASTER!
TOTAL MESS in the repo! Required e.g. flightgear-data-all >= 1:2018.2.2 but < 1:2018.2.3 LOL both not found, because don't exist!
I don't know WHAT THE HELL made me upgrade from 2018.1 to the newest version! Now deleted the RECOMMENDED on the website saiarcot895's repo and installing the 3.0 version from standard repos. IS IT NORMAL that the devs don't take care at all?? Dear devs! Simple .deb files needed, not the wrong path to non-working repo! Thanks in advance! BTW: the sources don't build.

A message to the people who have working FG: "DON't update, don't upgrade, just enjoy flying"


Which version of Ubuntu are you using?
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 305
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby V12 » Thu Jan 10, 2019 6:30 am

On LUbuntu 18.10 upgrade from 2018.2.2 to 2018.3.1 was absolutly smooth without any trouble. On LUbuntu 18.04 upgrade failed, I manualy removed 2018.2.2 and without problems installed 2018.3.1. Another LUbuntu 18.04 - after previous experience I manualy removed 2018.2.1 and manualy installed 2018.3.1 again without any glitch.

For all people - update, upgrade and enjoy with fps significant higher than in previous versions.
Fly high, fly fast - fly Concorde !
User avatar
V12
 
Posts: 1500
Joined: Thu Jan 12, 2017 4:27 pm
Location: LZIB
Callsign: BAWV12

Re: Upgrade from FG2018.2.1 to FG2018.3.1 Failed

Postby saiarcot895 » Thu Jan 10, 2019 6:43 am

There were issues with the 16.04 build, and unfortunately, apt/dpkg isn't smart enough to not try to upgrade the data package. There's a build now available for 16.04, but note that the Qt launcher is not available due to Qt version differences (trying to use Qt 5.4 and newer will require recompiling everything that uses Qt with the newer version, for some reason).
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 305
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Previous

Return to Installation

Who is online

Users browsing this forum: MSN [Bot] and 0 guests