Board index FlightGear Support Graphics

2018.2.1 - Bad performances.  Topic is solved

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

2018.2.1 - Bad performances.

Postby Dogers » Sat May 26, 2018 8:20 am

Greetings everyone !

Here we are again, indeed I am currently experiencing bad FPS on the last stable version of FlightGear (2018.2.1). In Fact, the bad performances started with the first of the 2018 releases. Last time I posted a similar problem, but it was all my fault, a library conflict due to open scene graph from Open Morrowind, but this time it seems not to be mine. Even with lower graphics settings my FPS are around 20. In the 2017 releases it was almost all the time at 60 FPS. This issue is present on all aircraft in all airports.

So here are my computer specs :

OS : Debian Testing 64 bits (in order to obtain the last open-source driver for my AMD card)
CPU : AMD FX 6300 3.5 GHz Hexa-Core
GPU : AMD R9 380 - Open-source Drivers (Mesa 18.0.3.1 - Kernel 4.16)
RAM : 16GB RAM DDR3
SPU : Focusrite Scarlet 2i2
MIC : MB-60 set Mic

I forgot to mention that I have compiled Simgear and FlightGear myself, from the last stable available at Sourceforge. So here are the option I use for cmake.

Simgear cnake config =
Code: Select all
cmake. -DENABLE_OPENMP=ON -DENABLE_SIMD=ON
then compiling with
Code: Select all
make -j6
and as superuser
Code: Select all
make install
.

Flightgear = Only using
Code: Select all
cmake.
then compiling with
Code: Select all
make -j6
and as superuser
Code: Select all
make install
.

And here are my launch option for the FGFS in the launcher :

Code: Select all
--prop:/sim/rendering/multithreading-mode=AutomaticSelection
#--prop:/sim/rendering/multithreading-mode=CullDrawThreadPerContext
#--prop:/sim/rendering/multithreading-mode=DrawThreadPerContext
#--prop:/sim/rendering/multithreading-mode=CullThreadPerCameraDrawThreadPerContext
--callsign=F-DGRS
--multiplay=out,10,mpserver01.flightgear.org,5000
--multiplay=in,10,,5005
--enable-horizon-effect
--fog-nicest
--shading-smooth
--enable-distance-attenuation
--enable-ai-models
--disable-ai-traffic
--httpd=7070
#--visibility=50000
--ai-scenario=foch_demo
--ai-scenario=nimitz_demo
--ai-scenario=clemenceau_demo
#--carrier=Eisenhower
#--prop:bool:/sim/multiplay/hot=true
#--console
#--prop:/sim/terrasync/svn-server=http://ns334561.ip-5-196-65.eu:8888/trunk/data/Scenery/
#--multiplay=out,10,54.165.96.98,5000
#--disable-random-objects
#--prop:/sim/rendering/texture-compression=off
#--prop:/sim/rendering/random-vegetation=0
#--prop:/sim/rendering/random-buildings=0
#--disable-specular-highlight
#--disable-clouds
#--disable-clouds3d
#--shading-flat
#--fog-fastest
#--disable-distance-attenuation
#--disable-enhanced-lighting
#--prop:/sim/rendering/particles=0
#--prop:/sim/rendering/multi-sample-buffers=1
#--prop:/sim/rendering/multi-samples=2
#--prop:/sim/rendering/quality-level=0
#--prop:/sim/rendering/shaders/quality-level=0
#--prop:/sim/sceneryloaded-override=1
#--prop:/sim/rendering/draw-mask/terrain=0
#--model-hz=500
#--addon=/home/dogers/flightgear-fgaddon/Addons/SpokenATC
#--addon=/home/dogers/flightgear-fgaddon/Addons/SpokenGCA


I also use ALS rendering and advanced weather modeling.

So it would be nice to know if anyone else is experiencing the same issue as myself and if there is a potential clue about what cause it.

If you need any other information, feel free to ask.

Thank you very much !
User avatar
Dogers
 
Posts: 28
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: Debian Testing 64

Re: 2018.2.1 - Bad performances.

Postby wkitty42 » Sat May 26, 2018 4:51 pm

F10->View->Rendering_options->Shader_Effects... on or off? if on, how do you have the sliders set under the [Shader Options] button? more specifically, the (grass) overlay, water and urban sliders...

also, are you flying with the F10 menu displayed or not?
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4956
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: 2018.2.1 - Bad performances.

Postby Dogers » Sat May 26, 2018 6:37 pm

Thank you for your response.
Currently all my shader effects are off and my F10 menu is set to auto-fade in 10s. So most of time the F10 menu is not showed.
User avatar
Dogers
 
Posts: 28
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: Debian Testing 64

Re: 2018.2.1 - Bad performances.

Postby legoboyvdlp » Sat May 26, 2018 8:17 pm

Are the random veg, buildings, pylons, detailed roads disabled? Just to check - if they are then this could be an actual problem.

If you are able to could you launch fgfs,exe from the command line without using the new launcher? I recall someone complaining in the list of bad performance since the launcher was updated. If you compare running without the launcher to the exact same settings aircraft and airport with the launcher is there a significant difference?
User avatar
legoboyvdlp
 
Posts: 6137
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: 2018.2.1 - Bad performances.

Postby Dogers » Sat May 26, 2018 8:34 pm

Everything is disabled, only ALS and advanced weather is on.

And, I just tried to launch only the simulator with the default command (fgfs) with no launcher. And I get a C172P at PHNL with 18 - 20 FPS, so, yes it is basically the same problem with and without the launcher.

If I disable ALS and Advanced weather modeling, I only get 5 - 10 fps more.
Last edited by Dogers on Sun May 27, 2018 8:00 am, edited 1 time in total.
User avatar
Dogers
 
Posts: 28
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: Debian Testing 64

Re: 2018.2.1 - Bad performances.

Postby Thorsten » Sun May 27, 2018 7:39 am

Is there any chance some odd default setting made you build a debug version instead of a release version?
Thorsten
 
Posts: 10157
Joined: Mon Nov 02, 2009 8:33 am

Re: 2018.2.1 - Bad performances.

Postby Dogers » Sun May 27, 2018 8:00 am

I do not think so. But is there any way I can be sure of that ? How to know if my FlightGear is a debug version ?

Also, I did further testing, and the only way I found to use FGFS with decent frame-rate is to disable ALS and AWM, but FGFS now looks kind of old school ! (But not that playable on big airport).
User avatar
Dogers
 
Posts: 28
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: Debian Testing 64

Re: 2018.2.1 - Bad performances.  

Postby wkitty42 » Sun May 27, 2018 9:53 am

Dogers wrote in Sun May 27, 2018 8:00 am:I do not think so. But is there any way I can be sure of that ? How to know if my FlightGear is a debug version ?

look at the log... you should find it in ~/.fgfs as fgfs.log...
here's the first five lines of mine...
Code: Select all
general:3:/home/myuser/flightgear-dev/next/flightgear/src/Main/main.cxx:493:FlightGear:  Version 2018.3.0
general:3:/home/myuser/flightgear-dev/next/flightgear/src/Main/main.cxx:494:FlightGear:  Build Type Dev
general:3:/home/myuser/flightgear-dev/next/flightgear/src/Main/main.cxx:495:Built with GNU C++ version 4.8
general:3:/home/myuser/flightgear-dev/next/flightgear/src/Main/main.cxx:497:Jenkins number/ID 0:none
general:3:/home/myuser/flightgear-dev/next/flightgear/src/Main/options.cxx:2881:set from command-line argument: fg_root = Path "/home/myuser/flightgear-dev/next/install/flightgear/bin/../fgdata"

note the second line...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4956
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: 2018.2.1 - Bad performances.

Postby Dogers » Sun May 27, 2018 12:30 pm

Here it is =

Code: Select all
general:3:/home/dogers/Documents/Jeux/FGFS/flightgear-2018.2.1/src/Main/main.cxx:493:FlightGear:  Version 2018.2.1
general:3:/home/dogers/Documents/Jeux/FGFS/flightgear-2018.2.1/src/Main/main.cxx:494:FlightGear:  Build Type Dev
general:3:/home/dogers/Documents/Jeux/FGFS/flightgear-2018.2.1/src/Main/main.cxx:495:Built with GNU C++ version 7.3
general:3:/home/dogers/Documents/Jeux/FGFS/flightgear-2018.2.1/src/Main/main.cxx:497:Jenkins number/ID 0:none
general:3:/home/dogers/Documents/Jeux/FGFS/flightgear-2018.2.1/src/Main/options.cxx:2898:Qt launcher set fg_root = Path "/home/dogers/Documents/Jeux/FGFS/fgdata"
general:3:/home/dogers/Documents/Jeux/FGFS/flightgear-2018.2.1/src/Main/fg_init.cxx:551:Reading global defaults
general:3:/home/dogers/Documents/Jeux/FGFS/flightgear-2018.2.1/src/Main/fg_init.cxx:561:Finished Reading global defaults


So, does it means that my version is a debug version ? If yes, how to build it like a regular one ?
User avatar
Dogers
 
Posts: 28
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: Debian Testing 64

Re: 2018.2.1 - Bad performances.

Postby wkitty42 » Sun May 27, 2018 2:57 pm

add these two defines to your configure and/or cmake lines...

Code: Select all
-DFG_BUILD_TYPE=Release -DCMAKE_BUILD_TYPE=RelWithDebInfo
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4956
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: 2018.2.1 - Bad performances.

Postby Dogers » Sun May 27, 2018 5:41 pm

I just compiled SimGear and FlightGear with the option you've specified and bingo you were right ! My FPS just skyrocketed ! Thank you very much, I can now start to fully enjoy flying with the last stable version of FlightGear !

That is to say, this is issue looks really strange to me. Indeed, I use FlightGear for more than 5 years now, and I never had to put these cmake options before to get it correctly work.

Well, I consider my problem : RESOLVED !

Thank you !
User avatar
Dogers
 
Posts: 28
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: Debian Testing 64

Re: 2018.2.1 - Bad performances.

Postby wkitty42 » Sun May 27, 2018 6:07 pm

if it is there, on my post above, click the "accepted solution" icon... it'll be on the right near the [QUOTE] and "!" buttons... that'll make the topic as solved...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4956
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: 2018.2.1 - Bad performances.

Postby Dogers » Sun May 27, 2018 8:06 pm

I've done this just as soon as my issue was fixed :) !
User avatar
Dogers
 
Posts: 28
Joined: Thu May 05, 2016 4:36 pm
Location: Marseille,France
Callsign: F-DGRS, Dogers
Version: 2018.3.2
OS: Debian Testing 64

Re: 2018.2.1 - Bad performances.

Postby wkitty42 » Mon May 28, 2018 1:53 am

excellent :) i couldn't really tell from here... i guess because i always use the "New posts" link instead of the "Unsolved Issues" link... thanks!
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4956
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5


Return to Graphics

Who is online

Users browsing this forum: No registered users and 0 guests