Board index FlightGear Support Graphics

Font problem

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

Font problem

Postby abcaster » Thu Mar 15, 2018 9:35 am

I seem to have a problem with missing font(s) on my MacBook Pro.
Can anybody point me where to go to sort this out?

Image
abcaster
 
Posts: 85
Joined: Sat Jun 28, 2014 10:08 am
Location: EKCH
Callsign: LNRCX
Version: 2018.2.0
OS: Sierra

Re: Font problem

Postby legoboyvdlp » Fri Mar 16, 2018 1:45 am

The fonts ought to be in FGDATA under Fonts/
Perhaps you should redownload FGDATA and copy and paste in the Fonts foldee?
User avatar
legoboyvdlp
 
Posts: 7003
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: Font problem

Postby abcaster » Fri Mar 16, 2018 8:30 am

Thanks, I'll try that.
abcaster
 
Posts: 85
Joined: Sat Jun 28, 2014 10:08 am
Location: EKCH
Callsign: LNRCX
Version: 2018.2.0
OS: Sierra

Re: Font problem

Postby abcaster » Fri Mar 16, 2018 9:10 am

Found this in my log:

Code (): Select all
opengl:5:/Users/jenkins/jenkins-root/workspace/Mac-nightly/flightgear/src/Canvas/FGCanvasSystemAdapter.cxx:61:canvas::Text: Failed to open font file Path "/Applications/FlightGear.app/Contents/Resources/data/Fonts/LiberationFonts/LiberationSans-Bold.ttf"
opengl:5:/Users/jenkins/jenkins-root/workspace/Mac-nightly/flightgear/src/Canvas/FGCanvasSystemAdapter.cxx:61:canvas::Text: Failed to open font file Path "/Applications/FlightGear.app/Contents/Resources/data/Fonts/LiberationFonts/LiberationSans-Regular.ttf"


The fonts seems to be in the right place.
abcaster
 
Posts: 85
Joined: Sat Jun 28, 2014 10:08 am
Location: EKCH
Callsign: LNRCX
Version: 2018.2.0
OS: Sierra


Return to Graphics

Who is online

Users browsing this forum: No registered users and 14 guests

cron