Board index FlightGear Support Hardware

Thrustmaster t.flight hotas 4

Joysticks, pedals, monitors.

Thrustmaster t.flight hotas 4

Postby eckhart » Sat Sep 09, 2017 1:55 pm


I am using Linux Mint 18.2 and I am a fan of FG.

I just bought a joystick Thrustmaster t.flight hotas 4.

Everything seems OK except throttle is not working - system does not recognize when I am moving axis 3 - 4. I run jstest-gtk - same problem. I read somewhere that in order to make it work I need to switch joystick from PS mode to PC. It should be done with PS button - the color of the light should change from red to green. It does not work for me. Can you help me configuring my joystick under Linux Mint?


Posts: 1
Joined: Sat Sep 09, 2017 1:47 pm

Re: Thrustmaster t.flight hotas 4

Postby dream_flyer » Sat Sep 09, 2017 9:16 pm

I don't know anything about this joystick. Just an obvious idea: did you try it under MS Windows? Install (optional) TM soft, and press the PS button under Windows?
Posts: 10
Joined: Fri Aug 18, 2017 11:19 pm

Re: Thrustmaster t.flight hotas 4

Postby poinu » Sat Sep 30, 2017 4:06 pm


I'm on the Linux kernel 4.12 and I face the exactly same issue with the Thrustmaster hotas 4.

I've tried using 'jstest' and 'evtest' utilities and I haven't find any response on both programs when using the rudder or the throttle.

I don't have a Windows installed myself to test it with the original driver, but the hotas works perfectly on the PS4.

Is there anything that can be done to be able to detect those events?

Thank you!
Posts: 8
Joined: Sat Sep 30, 2017 3:57 pm
Version: 2017.3.1
OS: Linux

Re: Thrustmaster t.flight hotas 4

Postby nerunja » Sun May 13, 2018 12:38 pm

Got a new Thrustmaster T.Flight Hotas 4 joystick today and tried using with FlightGear 2018.1.1 — Released April 11, 2018 on MintLinux 18.3 Slyvia (kernel 4.13.0-41-generic). Throttle is still NOT working, though was able to control to wings.
Posts: 2
Joined: Sun May 13, 2018 12:29 pm

Re: Thrustmaster t.flight hotas 4

Postby hwanzike » Thu Aug 16, 2018 6:52 pm

Still having this problem with Ubuntu 18.04, any ideas?
Posts: 1
Joined: Thu Aug 16, 2018 6:51 pm

Re: Thrustmaster t.flight hotas 4

Postby gfunk » Sat Feb 23, 2019 12:39 am

hi guys GOOD NEWS

had the same problem and found this thread..

you are going to love or hate this fix..

1. install virtualbox and windows 7 or 10 VM (I already had this setup)
2. had to add local user to vmguestuser group
3. install tflight driver on the virtualbox
4. in virtualbox connect tflight to the windows vm
5. press the PS button ITS GREEN NOW
6. shutdown VM and go back to killing space pirates in ED (or flying choppers..)
Posts: 1
Joined: Sat Feb 23, 2019 12:35 am

Re: Thrustmaster t.flight hotas 4

Postby Paplepel » Tue Jul 09, 2019 5:45 pm

Hi Guys

Hold the PS, Share and Options button down when you plug it into the usb.

No need for a windows vm. Works on mac 2.
Posts: 1
Joined: Tue Jul 09, 2019 5:43 pm

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests