Board index FlightGear Development AI Traffic

EPWA Taxidraw  Topic is solved

Intelligent, computer controlled vehicles that drive/fly over the planet!

Re: EPWA Taxidraw  

Postby BecOzIcan » Sat Jun 10, 2017 12:51 am

gooneybird wrote in Fri Jun 09, 2017 9:59 am:Definitely something strange going on here?

Try this one: http://www.mediafire.com/file/qp3labch1mpb170/EPWA.groundnet.xml and let us know how you get on with it.

@ Ian, I assume this was updated from an auto generated groundnet?


Nope, this one was built from scratch. Not sure if something changed in terms of route following recently has I am still testing on 2.12.

I already had added extra gates as requested by SP so I am implementing your main change (single access route to military parking gates) and will run some extra testing in both 2.12 and most recent 2017 version before I push another one here :-)

Thanks a lot for your help on this one
Cheers
Ian
Current Projects: AI Traffic, Models & Liveries
User avatar
BecOzIcan
 
Posts: 1040
Joined: Tue Oct 04, 2011 10:43 pm
Location: Sydney, NSW, Australia
Version: 2.12
OS: Win10

Re: EPWA Taxidraw

Postby gooneybird » Sat Jun 10, 2017 10:33 am

You're welcome, I'm using 2017.1.2

Strange thing is your groundnet looked fine to me and checked out ok in Taxi draw but when I filled it with traffic I got aircraft meandering off into the distance:
Image

I've been testing and watching AI traffic while doing the Channel Islands groundnets and have noticed a few things.

If there are several nodes from different routes in close proximity to pushback nodes or multi node junctions the AI sometimes circle them as if it can't make up it's mind where to go.

Very short pushback routes from the pushback hold point to the main taxi route tend to throw the AI off course, this seems to vary so trial and error with each pushback is really needed.

Pushback routes that turn more than approximately 100% from one node can cause all the pushbacks to fail, for me this has also been the cause for aircraft stopping at the runway and not taking off, why this would be I have no idea but correcting the offending pushback usually corrects the problem.

"Onrunway" nodes, I've found that the traffic works better with only the last "onrunway" node on a taxi route set as true. I know taxi draw will flag this as an error by they can easily be reset after testing.

The usual problems of gate allocation and random stoppages are still there.
gooneybird
 
Posts: 2971
Joined: Sat May 31, 2008 1:57 pm

Re: EPWA Taxidraw

Postby SP-KOK » Fri Jun 30, 2017 12:01 pm

guys

I have to you request. Or, you can add to the parking position Groudnet EPWA that I mentioned: 01, 02, 03, 04, 31, 32, 34, 92, 93, 94, 44A, 95, 96, 97.


I would be very grateful.Gooneybird, Your groudnet is working correctly. I tested it many times only the lack of these spaces. It's your link to the correct:



http://www.mediafire.com/file/qp3labch1 ... undnet.xml



Underneath you have a link groudnet from Ian. that contains these items but is there a parking error because of the position of the aircraft shall not taxi to the parking spaces and the belt.
http://www.mediafire.com/file/7taowue1a ... undnet.xml
SP-KOK
 
Posts: 578
Joined: Tue Feb 02, 2016 5:04 pm

Re: EPWA Taxidraw

Postby SP-KOK » Fri Jun 30, 2017 6:16 pm

I selected the picture errors.
Trying to fix them yourself but I do not go to me:((((((((((((((((((((((((((((((
9, 10, 11, pushed planes are outside the airport item
8, no pushback


http://www.mediafire.com/file/7taowue1a ... undnet.xml



Image



Other parking spaces and taxi works perfectly
SP-KOK
 
Posts: 578
Joined: Tue Feb 02, 2016 5:04 pm

Re: EPWA Taxidraw

Postby BecOzIcan » Sat Jul 01, 2017 4:15 am

SP-KOK wrote in Fri Jun 30, 2017 6:16 pm:I selected the picture errors.
Trying to fix them yourself but I do not go to me:((((((((((((((((((((((((((((((
9, 10, 11, pushed planes are outside the airport item
8, no pushback
Other parking spaces and taxi works perfectly


1. Fixed Pushback of ParkPos 8
2. ParkPos 9 10 11 pushback normally for me but couldn't check roll forward after that (They are awaiting for incoming traffic)
3. Simplified flow along Gooneybirds recommendations
4. Removed Parkpos 91 > 94, not enough space for functional pushback
5. Please explain which part of running taxidraw you are not able to do yourself

Download HERE


Image


Cheers
Ian
Current Projects: AI Traffic, Models & Liveries
User avatar
BecOzIcan
 
Posts: 1040
Joined: Tue Oct 04, 2011 10:43 pm
Location: Sydney, NSW, Australia
Version: 2.12
OS: Win10

Re: EPWA Taxidraw

Postby SP-KOK » Sat Jul 01, 2017 6:02 am

Thank you for your help.


I checked this and noticed one small mistake. Position number 11 does not work.
I think the pushback from position 11 should be backwards like the gooneybird did
Either remove the pretty items 11 because the rest works very well.



All other items work perfectly.

Very, very, very, please how can you improve 11.
Topic will be closed :)
SP-KOK
 
Posts: 578
Joined: Tue Feb 02, 2016 5:04 pm

Re: EPWA Taxidraw

Postby gooneybird » Sat Jul 01, 2017 10:24 am

The best way to test a groundnet is to flood it with test traffic and watch it while advancing the simulation rate in the time settings, this way it's easier to see where the problems are. I can supply a couple of test files if you want them.

gooneybird
 
Posts: 2971
Joined: Sat May 31, 2008 1:57 pm

Re: EPWA Taxidraw

Postby SP-KOK » Sat Jul 01, 2017 10:55 am

I did a test. everything is working very well beyond the position 11.

On your video you can see that wizzair on number 11 is not working as it should. leaving during the pushback s outside the airport.
SP-KOK
 
Posts: 578
Joined: Tue Feb 02, 2016 5:04 pm

Re: EPWA Taxidraw

Postby gooneybird » Sat Jul 01, 2017 12:25 pm

SP-KOK wrote in Sat Jul 01, 2017 10:55 am:I did a test. everything is working very well beyond the position 11.


You can probably cure that yourself just by adjusting the pushback route for that parking position.
gooneybird
 
Posts: 2971
Joined: Sat May 31, 2008 1:57 pm

Re: EPWA Taxidraw

Postby BecOzIcan » Sat Jul 01, 2017 12:48 pm

SP-KOK wrote in Sat Jul 01, 2017 10:55 am:I did a test. everything is working very well beyond the position 11.

On your video you can see that wizzair on number 11 is not working as it should. leaving during the pushback s outside the airport.


Thanks for that G.

I updated the access routes to ParkPos 37 38 39 and 814-817 so they don't need to dance around when rolling forward our of parking

The behavioru of ParkPos 11 is most puzzling to me (1:08 to 1:45 on your video). I am not even sure where this pushback finishes (out of screen) . I ll have a look at the xml see if there isn't something weird not shown in the Taxidraw UI.
Current Projects: AI Traffic, Models & Liveries
User avatar
BecOzIcan
 
Posts: 1040
Joined: Tue Oct 04, 2011 10:43 pm
Location: Sydney, NSW, Australia
Version: 2.12
OS: Win10

Re: EPWA Taxidraw

Postby gooneybird » Sat Jul 01, 2017 2:06 pm

This really is a strange one, I can not see anything obvious wrong with it.

I've been playing around with various pushbacks on 11 but can not get it to work properly, even with a simple pushback route.
Either all pushbacks stop working or if they do work pos. 11 will only go forward, I've not yet got it to pushback without it taxiing off across country.

I'm beginning to think there's another problem elsewhere in the AI system causing these groundnet problems.
gooneybird
 
Posts: 2971
Joined: Sat May 31, 2008 1:57 pm

Re: EPWA Taxidraw

Postby BecOzIcan » Sat Jul 01, 2017 2:17 pm

gooneybird wrote in Sat Jul 01, 2017 2:06 pm:This really is a strange one, I can not see anything obvious wrong with it.

I've been playing around with various pushbacks on 11 but can not get it to work properly, even with a simple pushback route.
Either all pushbacks stop working or if they do work pos. 11 will only go forward, I've not yet got it to pushback without it taxiing off across country.

I'm beginning to think there's another problem elsewhere in the AI system causing these groundnet problems.


Same here. Obvious next step would be to totally remove 11 and then re-add it back at later stage to clear any broken code but I am frankly over this one. SP-KOK can take it from here (and/or remove 11).

Given we never experienced something like that it should naturally become known as the EPWA11 bug. My XML review only showed one issue with an unconnected node in ParkPos 47 (nothing around 11) which I corrected

Final EPWA groundnet as far as I am concerned available for download from HERE

Back to TAM traffic and LFPG terrain now.

Cheers
Ian
Current Projects: AI Traffic, Models & Liveries
User avatar
BecOzIcan
 
Posts: 1040
Joined: Tue Oct 04, 2011 10:43 pm
Location: Sydney, NSW, Australia
Version: 2.12
OS: Win10

Re: EPWA Taxidraw

Postby SP-KOK » Sun Jul 02, 2017 12:13 pm

Big thank you guys
I tested today
everything works:))))))))))))
SP-KOK
 
Posts: 578
Joined: Tue Feb 02, 2016 5:04 pm

Re: EPWA Taxidraw

Postby SP-KOK » Fri Jun 07, 2019 6:19 pm

hi, I have a question, are you able to add the remaining parking positions at EPWA airport. There are not many parking spaces, they would be useful because many planes are not showing up and LOT Polish Airlines has doubled the number of planes. I would be grateful, I marked places in the screnn that can be added to the current groudnet for EPWA. You can also add positions for Cargo traffic as soon UPS traffic will appear


I have marked missing items in black. I will be grateful for adding them.


The current groudnet for EPWA

https://drive.google.com/open?id=1wtg0- ... T1vjpcj2Xx


Image

Image

Image

Image

Image
SP-KOK
 
Posts: 578
Joined: Tue Feb 02, 2016 5:04 pm

Re: EPWA Taxidraw

Postby BecOzIcan » Sat Jun 08, 2019 2:29 am

Will look into it
Current Projects: AI Traffic, Models & Liveries
User avatar
BecOzIcan
 
Posts: 1040
Joined: Tue Oct 04, 2011 10:43 pm
Location: Sydney, NSW, Australia
Version: 2.12
OS: Win10

PreviousNext

Return to AI Traffic

Who is online

Users browsing this forum: No registered users and 9 guests