Board index FlightGear Support Compiling

segmentation fault

Building FlightGear from source, and in the need for help?

segmentation fault

Postby neb-toi » Tue Jan 10, 2017 10:42 pm

hello everybody,

I'm on debian testing, kernel 4.8.0-2-686-pae, with I5-3470S cpu @ 2.90GHz x 4, 8 Go memory, and a ATI Radeon HD7750 with gallium drivers.
I've installed flightgear with "download and compil", stable version, it works. I've tried to install development one, compilation worked, but when i run fgfs, i get a segmentation fault. I try to redo compilation lots of time, but nothing to do. I launch fgfs with gdb, and i have this:
Code: Select all
Program received signal SIGSEGV, Segmentation fault.
SGTranslateTransform::SGTranslateTransform (this=0x81588538)
    at /home/neb-toi/bin/Flightgear/simgear/simgear/scene/model/SGTranslateTransform.cxx:36
36     _value(0)


I've posted on the french forum, and they recommend me to post here. So... Is there someone who can help me?
neb-toi
 
Posts: 4
Joined: Tue Jan 10, 2017 10:15 pm

Re: segmentation fault

Postby zakalawe » Wed Jan 11, 2017 11:14 am

This doesn't look like a known crash, there have been some crashes on the development build in the past few weeks due to us incorporating SSE2/3 extensions. I don't know if your crash is an example of that, but the code has been changing quite rapidly (every few days). And of course that's exactly why we have stable vs development builds, the development build may not always work. if the crash persists after updating from Git over the next few days, I'd suggest to post here again; not the full backtrace ('bt' in GDB) is more useful than just the crashing frame itself.
zakalawe
 
Posts: 1149
Joined: Sat Jul 19, 2008 4:48 pm
Location: Edinburgh, Scotland
Callsign: G-ZKLW
Version: next
OS: Mac

Re: segmentation fault

Postby neb-toi » Wed Jan 11, 2017 7:58 pm

Ok, i will test any more, i'll be back.
neb-toi
 
Posts: 4
Joined: Tue Jan 10, 2017 10:15 pm

Re: segmentation fault

Postby erik » Thu Jan 19, 2017 10:21 pm

I've pushed a fix that hopefully fixes this.

Erik
erik
 
Posts: 1499
Joined: Thu Nov 01, 2007 1:41 pm

Re: segmentation fault

Postby neb-toi » Tue Jan 24, 2017 10:37 am

It ok for me! Nice...
And thank you for advices, and work!
neb-toi
 
Posts: 4
Joined: Tue Jan 10, 2017 10:15 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 2 guests