Board index FlightGear Support Installation

FG 2016,1.1

Need help getting up and running? Installing FlightGear, add-on planes, sceneries etc.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?

Please, also see Requesting Technical Help.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

FG 2016,1.1

Postby StuartC » Thu Feb 18, 2016 9:11 pm

Questions.

For the Windows version.

1:- how do I get the black console box back.

2:- How can I set it to automatically connect online when I launch it.

3:- How do I set the advance visibility range now ? Its not and never has been in the in game menu options but always the "Advanced" tab of the old ( and better, more useful ) launcher.
StuartC
 
Posts: 2737
Joined: Fri Jun 18, 2010 8:18 pm
Location: Arse end of the Universe
Callsign: WF01
Version: 2018.3.2
OS: W10 64 bit

Re: FG 2016,1.1

Postby Necolatis » Thu Feb 18, 2016 9:13 pm

1 - Right click the shortcut, select properties, in target add : " --console"
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1984
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2019.1.2
OS: Windows 10

Re: FG 2016,1.1

Postby elgaton » Thu Feb 18, 2016 10:25 pm

The old launcher should still be available in C:\Program Files\FlightGear 2016.1.1\bin\fgrun.exe.

If you want to use the new one, specify the following parameters in the box at the bottom of the Settings tab:
Code: Select all
--console --multiplay=out,10,mpserver01.flightgear.org, --multiplay=in,10,, --callsign=WF01 --visibility=75

(replace the name of the multiplayer server, the callsign and the visibility - in meters - as appropriate).
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: FG 2016,1.1

Postby StuartC » Fri Feb 19, 2016 9:09 am

Thanks for the replies.
as the old launcher is still available, I have started using that. It suits my needs much better.
StuartC
 
Posts: 2737
Joined: Fri Jun 18, 2010 8:18 pm
Location: Arse end of the Universe
Callsign: WF01
Version: 2018.3.2
OS: W10 64 bit

Re: FG 2016,1.1

Postby MIG29pilot » Fri Feb 19, 2016 1:44 pm

Three cheers for FGRun!!!
User avatar
MIG29pilot
 
Posts: 1454
Joined: Tue May 19, 2015 4:03 pm
Location: 6 feet under Snow
Callsign: MIG29pilot
Version: 3.7nightly
OS: Windows 10

Re: FG 2016,1.1

Postby Hooray » Fri Feb 19, 2016 1:51 pm

StuartC wrote in Fri Feb 19, 2016 9:09 am:Thanks for the replies.
as the old launcher is still available, I have started using that. It suits my needs much better.


if there are any actual bugs related to the Qt5 launcher, please report them - otherwise, Zakalawe keeps encouraging feature requests for the Qt5 launcher - so if you think anything is missing/broken etc, please also get in touch via the devel list, and/or, the issue tracker - some recently posted feedback was very much appreciated IIRC, and got implemented within a few days.

It seems increasingly likely that the Qt5 launcher will continue to developed, and it may even make built-in features obsolete, so it is a good idea to be proactive whenever you notice anything missing/broken or incomplete, because all the ongoing Qt5 work is likely to be the foundation for what FG is going to look like a few years from now - to see that that's the case, you only need to look at new developments that are solely integrated with the Qt5 front-end - thus, sooner or later, certain desirable functionality will be tied to Qt5, and you should not expect fgrun to support all features that the Qt5 launcher does/will support.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11336
Joined: Tue Mar 25, 2008 8:40 am

Re: FG 2016,1.1

Postby StuartC » Sat Feb 20, 2016 12:39 pm

Due to a family bereavement lately Im not getting much FG time to do anything.
Today I have noticed that nether the new launcher or classic are able to retrieve terrasync data. Is that a known issue or something new, or something just related to the terrasync server ??

Plus, While I remember, the Windows installer prompts users to use existing or download FGdata before use even though the data is present and installes. The installer routing still requires you to point at the data folder.
StuartC
 
Posts: 2737
Joined: Fri Jun 18, 2010 8:18 pm
Location: Arse end of the Universe
Callsign: WF01
Version: 2018.3.2
OS: W10 64 bit

Re: FG 2016,1.1

Postby elgaton » Sat Feb 20, 2016 3:22 pm

StuartC wrote in Sat Feb 20, 2016 12:39 pm:Due to a family bereavement lately Im not getting much FG time to do anything.
Today I have noticed that nether the new launcher or classic are able to retrieve terrasync data. Is that a known issue or something new, or something just related to the terrasync server ??

Could you please post the contents of fgfs.log? I've seen another similar post in the last days where the error was due to some network problems (if I'm not mistaken, we have just a few scenery servers available, and they have some hiccups from time to time). As a workaround, you might want to use the TerraMaster utility instead of TerraSync.

StuartC wrote in Sat Feb 20, 2016 12:39 pm:Plus, While I remember, the Windows installer prompts users to use existing or download FGdata before use even though the data is present and installes. The installer routing still requires you to point at the data folder.

Please file a bug report about that (I'm quite busy right now as I'm finishing my Master's thesis, but another developer - or me in the coming months - will be able to take a look at that).
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: FG 2016,1.1

Postby Hooray » Sat Feb 20, 2016 3:35 pm

yes, please do file bug reports for these issues - especially anything related to Windows/TerraSync issues, as there seems to be an actual bug and we're lacking people who can reproduce the bug, while also being able to do some troubleshooting - this kind of stuff is basically impossible to troubleshoot on a Linux or Mac OSX system unfortunately.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11336
Joined: Tue Mar 25, 2008 8:40 am

Re: FG 2016,1.1

Postby StuartC » Sat Feb 20, 2016 4:14 pm

Tried FG again just now, just in the door from work. Terrasync appears to be working again, so that one must be a server issue.
StuartC
 
Posts: 2737
Joined: Fri Jun 18, 2010 8:18 pm
Location: Arse end of the Universe
Callsign: WF01
Version: 2018.3.2
OS: W10 64 bit

Re: FG 2016,1.1

Postby PINTO » Sat Feb 20, 2016 6:00 pm

There's a server issue with terra sync. Yesrev and I both had it, scenery.flightgear.org (or whatever) was unable to resolve the svn trunk.
Actively developing the MiG-21bis (github repo) (forum thread) (dev discord) (fg wiki)

http://opredflag.com is an active flightgear dogfighting community (using a system that isn’t bombable)
User avatar
PINTO
 
Posts: 945
Joined: Wed Oct 21, 2015 6:28 pm
Callsign: pinto
Version: 2016.3.0
OS: Win10

Re: FG 2016,1.1

Postby StuartC » Sat Feb 20, 2016 8:08 pm

Not a member of source forge so the bug tracker is useless to me.

Heres one, again Windows versions ( same thing happening to me and other Windows FGUK users with the new version. )
If your on Multiplayer, and someone spawns near by, FG dies after completely locking up. No errors generated by the crash in the console.
Deal breaker for me. I will have to go back to 3.4 when I get time. Not related to any specific aircraft ether.

The exact error message that flashes up in Windows:-

An Internal error has occurred: Cryptic error message AD3875-D: Access violation at address 74C8FB44 in miodule KERNELBASE.dll. Read of address 03C08000
( you have not done anything wrong )
Last edited by StuartC on Sat Feb 20, 2016 8:10 pm, edited 1 time in total.
StuartC
 
Posts: 2737
Joined: Fri Jun 18, 2010 8:18 pm
Location: Arse end of the Universe
Callsign: WF01
Version: 2018.3.2
OS: W10 64 bit

Re: FG 2016,1.1

Postby Hooray » Sat Feb 20, 2016 8:10 pm

that sounds like you can reproduce this easily ?
If so, would you mind raising your log-level to debug/bulk and post the last 50 lines of fgfs.log file here for inspection ?

Alternatively, a gdb backtrace would be even better :D
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11336
Joined: Tue Mar 25, 2008 8:40 am

Re: FG 2016,1.1

Postby StuartC » Sat Feb 20, 2016 8:14 pm

where can I find fgfs.log?
StuartC
 
Posts: 2737
Joined: Fri Jun 18, 2010 8:18 pm
Location: Arse end of the Universe
Callsign: WF01
Version: 2018.3.2
OS: W10 64 bit

Re: FG 2016,1.1

Postby StuartC » Sat Feb 20, 2016 8:57 pm

PS, is this supposed to be an official public release ???
StuartC
 
Posts: 2737
Joined: Fri Jun 18, 2010 8:18 pm
Location: Arse end of the Universe
Callsign: WF01
Version: 2018.3.2
OS: W10 64 bit

Next

Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests