Board index FlightGear Release candidates

FlightGear 3.6 authorization problems

Release candidate testers are encouraged to post their feedback here. Please read the introduction topic for details.
Forum rules
Please read the introduction topic for details.

FlightGear 3.6 authorization problems

Postby D-ECHO » Wed Jul 29, 2015 6:21 pm

While starting flightgear 3.6 (via ppa:saiarcot895/flightgear-edge) on LinuxMint 17 Rebecca, there are always messages like this (example with Tecnam P2010):
Code: Select all
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/home/delta/.fgfs/TerraSync'.
default catalog not found, installing 'org.flightgear.default' from 'http://fgfs.goneabitbursar.com/pkg/3.6.0/default-catalog.xml'.
Loading local weather routines...
open(): reading/writing '/usr/share/games/flightgear/Aircraft/Generic/Systems/compat_failure_modes.nas' denied (unauthorized di:
 at /usr/share/games/flightgear/Nasal/io.nas, line 406
  called from: /usr/share/games/flightgear/Nasal/io.nas, line 7
  called from: /usr/share/games/flightgear/Nasal/io.nas, line 84
  called from: /usr/share/games/flightgear/Nasal/FailureMgr/private.nas, line 7
  called from: /usr/share/games/flightgear/Nasal/globals.nas, line 84
loadxml: reading '/usr/share/games/flightgear/Aircraft/Tecnam-P92/Dialogs/immat.xml' denied (unauthorized directory - authorization no longer follows symlinks; to authorize reading additional directories, add them to --fg-aircraft)
Nasal runtime error: Dialog class: XML dialog must have <name>
  at /usr/share/games/flightgear/Nasal/gui.nas, line 335
  called from: /usr/share/games/flightgear/Nasal/gui.nas, line 315
  called from: /usr/share/games/flightgear/Nasal/globals.nas, line 119
Nasal runtime error: container index not scalar
  at /usr/share/games/flightgear/Nasal/gui.nas, line 317
  called from: /usr/share/games/flightgear/Aircraft/Tecnam-P2010/Nasal/immat.nas, line 23
loadxml: reading '/usr/share/games/flightgear/Aircraft/Tecnam-P2010/Models/Liveries/default.xml' denied (unauthorized directory - authorization no longer follows symlinks; to authorize reading additional directories, add them to --fg-aircraft)
Nasal runtime error: non-objects have no members
  at /usr/share/games/flightgear/Nasal/gui.nas, line 460
  called from: /usr/share/games/flightgear/Nasal/gui.nas, line 441
  called from: /usr/share/games/flightgear/Nasal/gui.nas, line 431
  called from: /usr/share/games/flightgear/Nasal/aircraft.nas, line 519
  called from: /usr/share/games/flightgear/Aircraft/Tecnam-P2010/Nasal/liveries.nas, line 1
Cannot find Nasal script 'Aircraft/Tecnam-P2010/Models/Interior/Panel/Instruments/zkv1000/zkv1000.nas' for module 'zkv1000'.
getting flightplan: Cruise-1
AIShip: Cruise-1 initializing waypoints
AIShip: Cruise-1 done initialising waypoints 0
catalog download failure:http://fgfs.goneabitbursar.com/pkg/3.6.0/default-catalog.xml
Nasal Instrument System Initialized
LOAD Vinson /ai/models/carrier[2]
Nasal runtime error: No such member: dialog
  at /sim/bindings/menu/binding[108], line 1
Nasal runtime error: No such member: dialog
  at /sim/bindings/menu/binding[108], line 1

The last runtime errors appear when clicking "Select Livery" in the GUI menu, the livery dialog doesn't open.
Can anyone tell me what's the problem?
Regards
User avatar
D-ECHO
 
Posts: 1427
Joined: Sat May 09, 2015 12:31 pm

Re: FlightGear 3.6 authorization problems

Postby elgaton » Wed Jul 29, 2015 7:04 pm

Before 3.6, there was a security bug where any Nasal script could read an arbitrary file on the filesystem via symlinks; now symbolic links are disabled by default (and I guess the PPA package uses them).

To enable them again, use this command line switch (solution courtesy of Rebecca N. Palmer on the -devel mailing list):
Use --fg-aircraft=/home/<username>/fgfs/<project> to allow this directory (requires the full path, not ~; if you have more than one, --fg-aircraft=/home/<username>/fgfs/<project1>:/home/<username>/fgfs/<project2>).


(Make sure to use this switch only for aircraft packages you trust!)

See this thread on the mailing list for more information.
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: FlightGear 3.6 authorization problems

Postby android » Sat Aug 01, 2015 3:50 pm

May I know whether the 3.6 test release version is ready for download? Thanks
android
 
Posts: 30
Joined: Fri Sep 20, 2013 3:28 am
Version: 3.0
OS: Windows 8

Re: FlightGear 3.6 authorization problems

Postby legoboyvdlp » Sat Aug 01, 2015 9:43 pm

Uh, 3.7 can be got for Windows here: http://www.download.flightgear.org/builds/nightly/ get 3.7.0 full .exe
If linux or windows cant help
User avatar
legoboyvdlp
 
Posts: 6487
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP

Re: FlightGear 3.6 authorization problems

Postby android » Sun Aug 02, 2015 3:32 am

legoboyvdlp wrote in Sat Aug 01, 2015 9:43 pm:Uh, 3.7 can be got for Windows here: http://www.download.flightgear.org/builds/nightly/ get 3.7.0 full .exe
If linux or windows cant help


I am using Windows so it should work but I thought the newest release will be 3.6... Why is there version 3.7? Thanks for replying,
android
 
Posts: 30
Joined: Fri Sep 20, 2013 3:28 am
Version: 3.0
OS: Windows 8

Re: FlightGear 3.6 authorization problems

Postby elgaton » Sun Aug 02, 2015 8:04 am

From January/July 7th we keep two versions in parallel, the next/newest release (in this case, 3.6) and the development release (3.7).
  • The next release receives only bug fixes until the release date (around February/August 18th).
  • The development release, on the contrary, will receive new features (and will eventually become FlightGear 3.8 ).
This way, no potentially "breaking" bugs are introduced in the next release, but we won't lose a month of development time.

See the Release plan article on the wiki for more details.

If possible, please download the 3.6 nightly version from http://download.flightgear.org/builds/nightly/ and report bugs on the bug tracker - since the 3.6 release date is in two weeks, we are definitely in need of testers!
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: FlightGear 3.6 authorization problems

Postby ThommiTechnik » Sun Aug 02, 2015 8:55 am

Hoi elgaton,

is there also a next release on the download-server for Mac OS? Because I only see the latest nightly, what's a 3.7?

Thanks, Thomas
ThommiTechnik
 
Posts: 26
Joined: Wed Jul 01, 2015 5:06 am
Location: Bern, Switzerland
Callsign: HB-IHQ
Version: 3.5
OS: OS X 10.11

Re: FlightGear 3.6 authorization problems

Postby elgaton » Sun Aug 02, 2015 8:18 pm

No (I think the configuration of the Macs on which FlightGear is built automatically still needs to be adjusted).
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: FlightGear 3.6 authorization problems

Postby android » Mon Aug 03, 2015 7:15 am

elgaton wrote in Sun Aug 02, 2015 8:04 am:If possible, please download the 3.6 nightly version from http://download.flightgear.org/builds/nightly/ and report bugs on the bug tracker - since the 3.6 release date is in two weeks, we are definitely in need of testers!


I have downloaded and installed but only got 2 aircrafts. May I know where can the download link/site for the updated list of aircrafts?
android
 
Posts: 30
Joined: Fri Sep 20, 2013 3:28 am
Version: 3.0
OS: Windows 8

Re: FlightGear 3.6 authorization problems

Postby legoboyvdlp » Mon Aug 03, 2015 4:36 pm

android - that is normal as far as I know - back a while only those two (c172p) and (ufo) were left in the Aircraft folder and the rest are available via GIT or SVN - see these two wiki pages
I prefer FGMEMBERS of the two
http://wiki.flightgear.org/FGAddon
http://wiki.flightgear.org/FGMEMBERS
User avatar
legoboyvdlp
 
Posts: 6487
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: 2018.3.1
OS: Windows 10 HP


Return to Release candidates

Who is online

Users browsing this forum: No registered users and 1 guest