Board index FlightGear Release candidates

Mac FG 3.6 will not launch

Release candidate testers are encouraged to post their feedback here. Please read the introduction topic for details.
Forum rules
Please read the introduction topic for details.

Mac FG 3.6 will not launch

Postby someguy » Thu Jul 23, 2015 9:17 pm

I thought this was fixed in 3.4?

Code: Select all
Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: libosgDB.100.dylib
  Referenced from: /Applications/FlightGear.app/Contents/Frameworks/libosgText.100.dylib
  Reason: image not found

OS X 10.10.4. FG 3.6 dated 7/23/15.
User avatar
someguy
 
Posts: 1653
Joined: Tue Nov 25, 2008 5:54 am
Location: USA
Version: 2016.2.1
OS: Mac OS X 10.11

Re: Mac FG 3.6 will not launch

Postby 689 » Sat Jul 25, 2015 8:59 am

Same error message for me! +1
I mostly do Air Traffic Control in EDDS Stuttgart Airport (hkEDDS). hkATC on mumble@allfex
EDDS Air Traffic Controller Hub
http://techmastary.net/fg/edds.html
689
 
Posts: 26
Joined: Wed Jul 08, 2015 4:12 pm
Location: Hong Kong
Callsign: hkATC/D689
Version: 3.4
OS: Mac OSX

Re: Mac FG 3.6 will not launch

Postby ThommiTechnik » Sun Jul 26, 2015 9:14 am

Yepp, the last three versions are corrupt. Up to the last nightly of 3.5, which is working here very well, all was good.

Bug is reported on the Bug tracker, and on the level-list. Jenkins is also giving errors during compilation.

Cheers Thomas
ThommiTechnik
 
Posts: 26
Joined: Wed Jul 01, 2015 5:06 am
Location: Bern, Switzerland
Callsign: HB-IHQ
Version: 3.5
OS: OS X 10.11

Re: Mac FG 3.6 will not launch

Postby ThommiTechnik » Wed Aug 05, 2015 4:35 pm

Still the same problem... Can I help somehow?
ThommiTechnik
 
Posts: 26
Joined: Wed Jul 01, 2015 5:06 am
Location: Bern, Switzerland
Callsign: HB-IHQ
Version: 3.5
OS: OS X 10.11

Re: Mac FG 3.6 will not launch

Postby Thorsten » Wed Aug 05, 2015 5:19 pm

I dunno. Seems like the few Mac people are on holiday - it's the time of the year... It's one of the things we Linux folks can't attempt to tackle.
Thorsten
 
Posts: 10961
Joined: Mon Nov 02, 2009 8:33 am

Re: Mac FG 3.6 will not launch

Postby ThommiTechnik » Wed Aug 05, 2015 5:55 pm

Oh yes, the well known holidays :) For me as a German in the Suisse it's every time great to see, that there's a country, which seems to have more holidays then my old home-country ;) But it isn't so, just a feeling ;)

Thanks for the reply, now I'm quit, and no more complaining ;) Just a last question: is the official release also build in Jenkins?

Cheers, Thomas
ThommiTechnik
 
Posts: 26
Joined: Wed Jul 01, 2015 5:06 am
Location: Bern, Switzerland
Callsign: HB-IHQ
Version: 3.5
OS: OS X 10.11

Re: Mac FG 3.6 will not launch

Postby AA_1881 » Sun Aug 16, 2015 4:11 am

Guys I'm on mac too, but where do i download in nightly flight gear 3.6.0 for mac?
My favorite Aircraft:
Boeing 767 https://db.tt/OhYzdLRK (you must have the 757-200 installed too)
Boeing 707 https://github.com/FGMEMBERS/707
Boeing 787 https://github.com/omega95-aircraft/fg-boeing-787-8
A320neo https://github.com/artix75/A320neo
AA_1881
 
Posts: 101
Joined: Thu Jun 25, 2015 3:01 pm
Location: Stockton Dorm, 211 Indian Mountain Road, Lakeville, CT 06039
Callsign: AA1881
Version: 3.4.0
OS: Mac OS X 10.9

Re: Mac FG 3.6 will not launch

Postby elgaton » Sun Aug 16, 2015 9:28 am

See here. Note that nightly builds are "experimental" and might contain bugs (in fact, I think the Mac version still has the bug described in this thread) - if you decide to use them, be prepared for possible breakage and update frequently.

(Also, assuming the Mac bug gets fixed, the 3.6 stable version will be released in a few days, so you might want to wait a bit).
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: Mac FG 3.6 will not launch

Postby someguy » Sun Aug 16, 2015 1:49 pm

As of right now, only 3.7 nightly is available for Mac on that server, and it's broken (will not launch).
User avatar
someguy
 
Posts: 1653
Joined: Tue Nov 25, 2008 5:54 am
Location: USA
Version: 2016.2.1
OS: Mac OS X 10.11


Return to Release candidates

Who is online

Users browsing this forum: No registered users and 4 guests