Board index FlightGear Support Installation Mac

FG cannot be opened on new iMac

Installing FlightGear, scenery, aircraft etc. on Mac.

FG cannot be opened on new iMac

Postby NACE » Sun Jan 04, 2015 11:18 am

FG suggest check with developer that FG works with this OS!?

Code: Select all
Process:               FlightGear [1677]
Path:                  /Volumes/VOLUME/FlightGear.app/Contents/MacOS/FlightGear
Identifier:            org.flightgear.FlightGear
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           FlightGear [1677]
User ID:               502

Date/Time:             2015-01-04 11:55:55.263 +0100
OS Version:            Mac OS X 10.10.1 (14B25)
Report Version:        11

Time Awake Since Boot: 15000 seconds

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /System/Library/Frameworks/RubyCocoa.framework/Versions/A/RubyCocoa
  Referenced from: /Volumes/VOLUME/FlightGear.app/Contents/MacOS/FlightGear
  Reason: image not found

Binary Images:
    0x7fff6becf000 -     0x7fff6bf05837  dyld (353.2.1) <4696A982-1500-34EC-9777-1EF7A03E2659> /usr/lib/dyld
    0x7fff957fb000 -     0x7fff957fbfff  com.apple.Cocoa (6.8 - 21) <EAC0EA1E-3C62-3B28-A941-5D8B1E085FF8> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

Model: iMac15,1, BootROM IM151.0207.B00, 4 processors, Intel Core i5, 3.5 GHz, 8 GB, SMC 2.22f16
Graphics: AMD Radeon R9 M290X, AMD Radeon R9 M290X, PCIe, 2048 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343531533641465238412D50422020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343531533641465238412D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x142), Broadcom BCM43xx 1.0 (7.15.124.12.10)
Bluetooth: Version 4.3.1f2 15015, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: APPLE SSD SD0128F, 121,33 GB
Serial ATA Device: APPLE HDD ST1000DM003, 1 TB
USB Device: FaceTime HD Camera (Built-in)
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Keyboard Hub
USB Device: Apple Keyboard
USB Device: Logitech Extreme 3D
USB Device: Microsoft® Nano Transceiver v1.0
Thunderbolt Bus: iMac, Apple Inc., 26.1
Last edited by Johan G on Sun Jan 04, 2015 11:22 am, edited 1 time in total.
Reason: Please use [code] tags for long listings. They can be added manually or with the [>_ ] button.
NACE
 
Posts: 1
Joined: Sun Jan 04, 2015 11:09 am

Re: FG cannot be opened on new iMac

Postby Thorsten » Sun Jan 04, 2015 11:20 am

Look for a thread called Alternative Yosemite launcher, probably it's the same thing.
Thorsten
 
Posts: 11616
Joined: Mon Nov 02, 2009 8:33 am

Re: FG cannot be opened on new iMac

Postby Hooray » Sun Jan 04, 2015 11:44 am

Thorsten wrote in Sun Jan 04, 2015 11:20 am:Look for a thread called Alternative Yosemite launcher, probably it's the same thing.


Note that the upcoming FlightGear release is likely to contain an integrated, hard-coded, launcher based on Qt5 to work around this issue: https://gitorious.org/fg/flightgear/com ... n/main.cxx

Unfortunately, this is -once again- overlapping with other efforts (think Canvas GUI/Aircraft Center), and it's going to be Mac specific, too - while also adding a rather significant external dependency (Qt5).
If it wasn't for the recent mongoose/Canvas efforts, and had this been done/accepted a few years ago, many recent developments would be made obsolete by allowing Qt5 - but back then, Qt5 was a "no-go"...


http://wiki.flightgear.org/Aircraft_Center
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11786
Joined: Tue Mar 25, 2008 8:40 am

Re: FG cannot be opened on new iMac

Postby efel » Tue Jun 02, 2015 9:12 am

Hello
With Yosemite and the new Mac Qt5 Launcher, I can start fine FG 3.4. Setting and Location are OK. But with Aircraft, it's impossible to get another plane but 777. However, the path is OK to my file Aircraft. I tried to use the external Launcher of (our Japanese friend) -easily installed and programed with aircraft datas- but unfortunatly launching is failed Thanks for answering
efel
 
Posts: 50
Joined: Wed Sep 26, 2012 12:30 pm
Location: France
Version: v 2020.1
OS: macOS 10.15.5

Re: FG cannot be opened on new iMac

Postby efel » Tue Jun 02, 2015 1:46 pm

I found a solution for my problem: I ejected the 777 file from Aircraft datas, and all planes appears on the window: Setting, Location an Aircraft are OK
efel
 
Posts: 50
Joined: Wed Sep 26, 2012 12:30 pm
Location: France
Version: v 2020.1
OS: macOS 10.15.5


Return to Mac

Who is online

Users browsing this forum: No registered users and 0 guests