Board index FlightGear Support Graphics

VERY LOW frame rates on osx

Graphics issues like: bad framerates, weird colors, OpenGL errors etc. Bad graphics ar usually the result of bad graphics cards or drivers.
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- what graphics card do you have?
- does the problem occur with any aircraft, at any airport?
- is there any output printed to the console (black window)?
- copy&paste your commandline (tick the "Show commandline box on the last page of FGRun or the "Others" section on the Mac launcher).
- please upload a screenshot of the problem.

If you experience FlightGear crashes, please report a bug using the issue tracker (can be also used for feature requests).
To run FlightGear on old computers with bad OpenGL support, please take a look at this wiki article. If you are seeing corrupted/broken textures, please see this article.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

VERY LOW frame rates on osx

Postby adi96 » Wed Jul 09, 2014 12:54 pm

I guys,
i have a serious problem in flight gear since i've downloaded it for the first time.
i have VERY SLOW frame rates in this game in some places (about 4/5 fps). i tried to change aircraft using a simple f14b tomcat but nothing changed. here is my specs.

Apple iMac 27" late 2012

3,2 GHz Intel Core i5
16 GB 1600 MHz DDR3
NVIDIA GeForce GTX 675MX 1024 MB
OS X 10.9.3 (13D65)

I'm running a future version of flightgear (3.0.1), but there is the same problem with older versions. Also please tell me where can i find the log in order to past here.

also i want to ask everyone why the ils system in 777 seattle doesn't control altitude, but only heading.
adi96
 
Posts: 13
Joined: Sun Jun 15, 2014 2:22 pm
Callsign: adi96
Version: 3.0.1
OS: Mac OS X Mavericks

Re: VERY LOW frame rates on osx

Postby Hooray » Wed Jul 09, 2014 3:45 pm

Hi & Welcome!
please see the red/pink box at the top of the forum and provide the information, follow the advice, requested and provided there.
You may also want to post a screen shot showing your HELP/ABOUT dialog.
Besides, are you sure that OpenGL works in other applications, and does your hardware have Optimus support ?
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11349
Joined: Tue Mar 25, 2008 8:40 am

Re: VERY LOW frame rates on osx

Postby Jabberwocky » Wed Jul 09, 2014 4:02 pm

@adi96:

Please try and start FG with any plane, then go to view/rendering options and set the options for the scenery and particles down. Do the fps go up (takes about 30 seconds to work fully). Can you report back how that worked out?

J.
Jabberwocky
Retired
 
Posts: 1319
Joined: Sat Mar 22, 2014 7:36 pm
Callsign: JWOCKY
Version: 3.0.0
OS: Ubuntu 14.04

Re: VERY LOW frame rates on osx

Postby adi96 » Wed Jul 09, 2014 7:17 pm

Jabberwocky wrote in Wed Jul 09, 2014 4:02 pm:@adi96:

Please try and start FG with any plane, then go to view/rendering options and set the options for the scenery and particles down. Do the fps go up (takes about 30 seconds to work fully). Can you report back how that worked out?

J.


Hi, thanks for the reply.

i've taken two photos, the first one show how the scene was (with old settings), and the second one show how is now with low settings... i've also included the graphic's windows.
Image


Image

i can't find the log file...
adi96
 
Posts: 13
Joined: Sun Jun 15, 2014 2:22 pm
Callsign: adi96
Version: 3.0.1
OS: Mac OS X Mavericks

Re: VERY LOW frame rates on osx

Postby Jabberwocky » Thu Jul 10, 2014 7:20 pm

Yeah, but how were the fps? And that is a 777 Seattle cockpit. Awesome, but still somewhat heavy with Rembrandt. Polanes that are lighter on the graphic side are:

- Tikibar's 747-8i (has another flu at the moment tho)
- Omega's E-jets
- the good old C172p of course
- even the Saab Viggen and the F-14B ;-)
Jabberwocky
Retired
 
Posts: 1319
Joined: Sat Mar 22, 2014 7:36 pm
Callsign: JWOCKY
Version: 3.0.0
OS: Ubuntu 14.04

Re: VERY LOW frame rates on osx

Postby adi96 » Thu Jul 10, 2014 9:05 pm

yeah but as you can see in the photos frame rate is higher in the second one. (if you click the photo you can see it with more resolution in the hosting site), so i don't think that the problem is there... is my GPU so bad?
adi96
 
Posts: 13
Joined: Sun Jun 15, 2014 2:22 pm
Callsign: adi96
Version: 3.0.1
OS: Mac OS X Mavericks

Re: VERY LOW frame rates on osx

Postby Gijs » Thu Jul 10, 2014 9:13 pm

Hi,

you're looking at the number in the bottom left of your screen. That's not your frame rate. It's your frame spacing in milliseconds. A lower frame spacing is better, while for frame rates it's the other way around: a higher frame rate is better. In the second screenshot your frames are spaced by 179 milliseconds (0.179 seconds), so per second you get 1/0.179=6 frames, which is the 6 you see in the bottom right corner of the screen.

Anyhow, looking at these numbers tells you FlightGear or your computer is not performing well, but not what's causing that. Looking at the log file might give an insight. You can find it in your $FG_HOME directory, see http://wiki.flightgear.org/$FG_HOME As mentioned before, please do try a variety of aircraft, airports, screen sizes and settings. We cannot look into your computer, so you'll have to do the testing for us.

Cheers,
Gijs
Airports: EHAM, EHLE, KSFO
Aircraft: 747-400
User avatar
Gijs
Moderator
 
Posts: 9380
Joined: Tue Jul 03, 2007 2:55 pm
Location: Amsterdam/Delft, the Netherlands
Callsign: PH-GYS
Version: Git
OS: Windows 10

Re: VERY LOW frame rates on osx

Postby Hooray » Thu Jul 10, 2014 9:54 pm

please see my earlier postings and provide the requested information there.

Otherwise, given the factors (777, rembrandt, airport) - this could very well be "normal" performance for your hardware. Hard to tell without knowing the details I asked for
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11349
Joined: Tue Mar 25, 2008 8:40 am

Re: VERY LOW frame rates on osx

Postby hvengel » Thu Jul 10, 2014 11:46 pm

His hardware should give decent performance even with heavier content. His video card, a GeForce GTX 675MX, is pretty high end and has a kepler based GPU. This should be only a little slower than my kepler based GTX 770 GPU although he is a little VRAM constrained and under some conditions may be running low on VRAM. His CPU is more than enough and he has lots of memory.

He does need to test with a lighter aircraft like the C172 and with out Rembrandt to see what happens. Under those conditions he should be seeing frame rates that are at or above vsync (IE. 60 FPS) even with the eye candy turned way up. If not then there is something wrong that needs to be corrected. But if he does see 60FPS with the C172 and no Rembrandt then it is the combo of the 777 and Rembrandt that is causing the slow down. These are both known to be very heavy and very hardware demanding.
hvengel
Retired
 
Posts: 1128
Joined: Sun Dec 24, 2006 4:35 am
Location: Minden Nevada

Re: VERY LOW frame rates on osx

Postby Jabberwocky » Fri Jul 11, 2014 12:00 am

MacOS is Debian based and there I am not at home, but wasn't there something with Nouveau drivers a while back? And if so, was that also valid for Debians? The card per se should be good enough, I get 9 out of a 777 Seattle even on the runway with a HD 5450, that is the benchmark of weak under Ubuntu. So I think, drivers or maybe something else that is graphic heavy and runs at the same time. like active desktops or something.

@Hooray, he wrote most of his hardware information in the first post ...
Jabberwocky
Retired
 
Posts: 1319
Joined: Sat Mar 22, 2014 7:36 pm
Callsign: JWOCKY
Version: 3.0.0
OS: Ubuntu 14.04

Re: VERY LOW frame rates on osx

Postby Philosopher » Fri Jul 11, 2014 12:35 am

Mac is not Debian based, it's Unix-based.
Thanks,
Philosopher
(inactive but lurking occasionally...)
Philosopher
 
Posts: 1590
Joined: Sun Aug 12, 2012 6:29 pm
Location: Stuck in my head...
Callsign: AFTI
Version: Git
OS: Mac OS X 10.7.5

Re: VERY LOW frame rates on

Postby punkepanda » Fri Jul 11, 2014 1:07 am

If the framerate is constant low its bad hardware..but if the framerate jumps up and down its probably because FG has not found a way to render the scene giving a constraint optimization result.
And that some crazy (unknown shit) is eating up TOO MUCH ressources for what it delivers. Most likely its your settings that mess things up. Set all settings to lowest then see if your fps goes up. An examle is I almost tripled my fps by setting water setting to middle. You could also try to turn of ALS (Athmospheric Light Scattering which is still rather new and experimental state. Its a checkbox under "rendering" options.
punkepanda
 
Posts: 237
Joined: Mon Nov 04, 2013 9:11 pm
Callsign: LostFlight
Version: 2.12
OS: Arch Linux

Re: VERY LOW frame rates on osx

Postby Hooray » Fri Jul 11, 2014 1:21 am

And that some crazy (unknown shit) is eating up TOO MUCH ressources for what it delivers.


ok, that one just made my day - you should get involved more often in the support forum and provide such highly-technical analyses :mrgreen:
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11349
Joined: Tue Mar 25, 2008 8:40 am

Re: VERY LOW frame rates on osx

Postby bigstones » Fri Jul 11, 2014 2:03 am

The screenshots the OP posted show that he's not using rembrandt and that he tried to disable als too. Could it be useful to see also the about dialogwith opengl info?
bigstones
 
Posts: 95
Joined: Sat Apr 05, 2014 11:09 pm
Location: Italy
Callsign: I-NOOB
OS: Debian testing

Re: VERY LOW frame rates on osx

Postby Jabberwocky » Fri Jul 11, 2014 4:00 am

@Philosopher: And what drivers are used for his GPU then on his Unix-based MacOS?
@bigstones: Try fgfs with the Seattle 777 and Re4mbrandt explicit off, now isn't that interesting?
@adi96: Can you please start with the C172p and tell what is on the right and on the left side in orange numbers?
Jabberwocky
Retired
 
Posts: 1319
Joined: Sat Mar 22, 2014 7:36 pm
Callsign: JWOCKY
Version: 3.0.0
OS: Ubuntu 14.04

Next

Return to Graphics

Who is online

Users browsing this forum: No registered users and 2 guests