Board index FlightGear Support Compiling

Ubuntu building error  Topic is solved

Building FlightGear from source, and in the need for help?

Re: Ubuntu building error

Postby F-JJTH » Thu Apr 12, 2012 6:16 pm

XMaN771 wrote in Thu Apr 12, 2012 5:47 pm:So what paramet do I use?

Code: Select all
sh download_and_compile.sh -j 12 ALL
But you have already done this.

With my computer, I run "sh download_and_compile.sh -j 12 ALL" then I wait 5 hours then I run "sh run_fgfs.sh" and I play with GIT version. If your computer done other things, I can't help you anymore :?

Before installing Flightgear with download_and_compile script you use FG from Synaptic ?
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: Ubuntu building error

Postby XMaN771 » Thu Apr 12, 2012 7:41 pm

F-JJTH wrote in Thu Apr 12, 2012 6:16 pm:
XMaN771 wrote in Thu Apr 12, 2012 5:47 pm:So what paramet do I use?

Code: Select all
sh download_and_compile.sh -j 12 ALL
But you have already done this.

With my computer, I run "sh download_and_compile.sh -j 12 ALL" then I wait 5 hours then I run "sh run_fgfs.sh" and I play with GIT version. If your computer done other things, I can't help you anymore :?

Before installing Flightgear with download_and_compile script you use FG from Synaptic ?


For some reason when I do that it just gives me 2.4 :s

I think I did the wrong command.
XMaN771
 
Posts: 28
Joined: Wed Apr 11, 2012 2:03 pm
OS: Ubuntu 11.04, Window

Re: Ubuntu building error

Postby F-JJTH » Thu Apr 12, 2012 7:50 pm

I suggest you to uninstall FG from Synaptic if you have it.
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: Ubuntu building error

Postby brisa » Thu Apr 12, 2012 11:33 pm

just a question, are you sure you are using 11.10 (oneric) version ? it looks to me that you are using the 11.04 (natty) one.

if so, the original script won't work, the packages are for the the last ubuntu distro (the 11.10 as today).

Cheers
Francesco
User avatar
brisa
 
Posts: 269
Joined: Fri May 16, 2008 7:32 pm
Location: Olgiate Comasco (CO) Italy
Callsign: brisa

Re: Ubuntu building error

Postby XMaN771 » Fri Apr 13, 2012 12:28 am

F-JJTH wrote in Thu Apr 12, 2012 7:50 pm:I suggest you to uninstall FG from Synaptic if you have it.

OKay I got it to work but when i type "sh run_fgrun.sh" it gives me this error
cd: 3: can't cd to install/fgrun/bin
run_fgrun.sh: 5: ./fgrun: Permission denied

Arrg!
XMaN771
 
Posts: 28
Joined: Wed Apr 11, 2012 2:03 pm
OS: Ubuntu 11.04, Window

Re: Ubuntu building error

Postby brisa » Fri Apr 13, 2012 4:41 am

fgrun has passed to cmake. you need the latest script version to compile it. or you can always use yhw -s switch.
User avatar
brisa
 
Posts: 269
Joined: Fri May 16, 2008 7:32 pm
Location: Olgiate Comasco (CO) Italy
Callsign: brisa

Re: Ubuntu building error

Postby F-JJTH » Fri Apr 13, 2012 6:18 am

Hi brisa,

Why don't you remplace "libboost1.46-dev" by "libboost-dev" at https://gitorious.org/fg/fgmeta/blobs/m ... sh#line262 ? in order to install the last libboost version in development (1.42) available by default in Ubuntu package.
I use your script on many Ubuntu distro (Linux Mint 11, Linux Mint 12, Ubuntu 10.04, Ubuntu 11.04) and I haven't libboost1.46-dev in my packages.

I hope my feedback help you to improve this parts of your script.

Cheers,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: Ubuntu building error

Postby brisa » Fri Apr 13, 2012 6:31 am

ops, thanks F-JJTH I didn't know it :-)

just done, it will be in next release.
User avatar
brisa
 
Posts: 269
Joined: Fri May 16, 2008 7:32 pm
Location: Olgiate Comasco (CO) Italy
Callsign: brisa

Re: Ubuntu building error

Postby XMaN771 » Fri Apr 13, 2012 12:29 pm

brisa wrote in Fri Apr 13, 2012 4:41 am:fgrun has passed to cmake. you need the latest script version to compile it. or you can always use yhw -s switch.


Were you talking to me??
XMaN771
 
Posts: 28
Joined: Wed Apr 11, 2012 2:03 pm
OS: Ubuntu 11.04, Window

Re: Ubuntu building error

Postby brisa » Fri Apr 13, 2012 12:34 pm

yes, the error you wrote suggests that fgrun was not compiled and the cause is probably the fact that you are using an "old" version of the script.

cheers
francesco
User avatar
brisa
 
Posts: 269
Joined: Fri May 16, 2008 7:32 pm
Location: Olgiate Comasco (CO) Italy
Callsign: brisa

Re: Ubuntu building error

Postby XMaN771 » Fri Apr 13, 2012 12:55 pm

brisa wrote in Fri Apr 13, 2012 12:34 pm:yes, the error you wrote suggests that fgrun was not compiled and the cause is probably the fact that you are using an "old" version of the script.

cheers
francesco


I got the script from F-JJTH
How do I update the script?
XMaN771
 
Posts: 28
Joined: Wed Apr 11, 2012 2:03 pm
OS: Ubuntu 11.04, Window

Re: Ubuntu building error

Postby F-JJTH » Fri Apr 13, 2012 1:17 pm

Now I have updated my script for Ubuntu distro (without libboost1.46-dev).

XMaN771 now you can re-download my script and run : sh download_and_compile.sh -j 12 -a n FGRUN

@brisa: when your script will be updated I'll stop to share my adapted script ;)
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: Ubuntu building error

Postby XMaN771 » Fri Apr 13, 2012 1:20 pm

F-JJTH wrote in Fri Apr 13, 2012 1:17 pm:Now I have updated my script for Ubuntu distro (without libboost1.46-dev).

XMaN771 now you can re-download my script and run : sh download_and_compile.sh -j 12 -a n FGRUN

@brisa: when your script will be updated I'll stop to share my adapted script ;)


Where do I download your script?
XMaN771
 
Posts: 28
Joined: Wed Apr 11, 2012 2:03 pm
OS: Ubuntu 11.04, Window

Re: Ubuntu building error  

Postby F-JJTH » Fri Apr 13, 2012 1:23 pm

As usual : http://clemaez.fr/flightgear/download_and_compile.sh
it's the same link than my first answer in fact.
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: Ubuntu building error

Postby XMaN771 » Fri Apr 13, 2012 1:41 pm

F-JJTH wrote in Fri Apr 13, 2012 1:23 pm:As usual : http://clemaez.fr/flightgear/download_and_compile.sh
it's the same link than my first answer in fact.


Alright running it now i will tell you if it works. :)
XMaN771
 
Posts: 28
Joined: Wed Apr 11, 2012 2:03 pm
OS: Ubuntu 11.04, Window

PreviousNext

Return to Compiling

Who is online

Users browsing this forum: No registered users and 6 guests