Board index FlightGear Support Multiplayer

mpserver08 drops all packages with same message  Topic is solved

Trouble getting online, setting up a server?
Forum rules
In order to help you, we need to know a lot of information. Make sure to include answers to at least the following questions in your initial post.

- what OS (Windows Xp/Vista, Mac etc.) are you running?
- what FlightGear version do you use?
- copy&paste your commandline.

Please, also see Requesting Technical Help.

Note: If you did not get a reponse, even after 7 days, you may want to check out the FlightGear mailing lists to ask your question there.

mpserver08 drops all packages with same message  

Postby Quix0r » Wed Mar 02, 2011 10:26 am

My mp-server does currently drop all incoming packages, all with the same message:
Code: Select all
02.03.2011 11:07:46 fgms: Sending player not found in m_PlayerList in HandlePacket()!

I use latest GIT code and have an out-of-source-tree build. Please check this link for all configuration:

I have also included two dump files which has been generated with "netcat -u -p 5000 -l -o fgms00x.dump":
- fgms001.dump.bz2: Generated on server to test if UDP packages can reach my box -> works!
- fgms001.dump.bz2: Generated on a second computer in my network if fgfs does send UDP packages to it -> works!

Please help here, I would like to help the FG community with my (fast ping!) server. :)

Edit: The bug is found and a fix will be available soon! Solved.
Admin of mpserver08: running latest GIT version: v0.13.3 - User:Quix0r
Posts: 112
Joined: Tue Sep 22, 2009 8:49 pm
Location: Krefeld
Callsign: D-Quix0r
Version: next
OS: Debian

Return to Multiplayer

Who is online

Users browsing this forum: No registered users and 0 guests