Board index FlightGear Support Tools ATC-pie

Help mayday! Can't start ATC-pie

ATC-pie is a radar air traffic control simulation program for the FlightGear multi-player network.

Help mayday! Can't start ATC-pie

Postby flight001 » Mon Jan 08, 2018 2:08 pm

I need help with the starting up of ATC-pie which failed multiple times even when I x-check a few times and looked at other posts in the forums. Anyone that can help me thank you very much.

Last login: Mon Jan 8 20:50:23 on ttys000
Aeroflot-Vive-Russkij:~ kevinnugraha$ brew locate pyqt5
Error: Unknown command: locate
Aeroflot-Vive-Russkij:~ kevinnugraha$ brew pyqt5
Error: Unknown command: pyqt5
Aeroflot-Vive-Russkij:~ kevinnugraha$ brew link pyqt5 ATC-pie
Error: No such keg: /usr/local/Cellar/atc-pie
Aeroflot-Vive-Russkij:~ kevinnugraha$ cd /Applications/ATC-pie
Aeroflot-Vive-Russkij:ATC-pie kevinnugraha$
Aeroflot-Vive-Russkij:ATC-pie kevinnugraha$ ./ATC-pie.py KSFO
Traceback (most recent call last):
File "./ATC-pie.py", line 28, in <module>
from PyQt5.QtWidgets import QApplication
ModuleNotFoundError: No module named 'PyQt5'
Aeroflot-Vive-Russkij:ATC-pie kevinnugraha$
flight001
 
Posts: 8
Joined: Fri Jan 05, 2018 5:17 am

Re: Help mayday! Can't start ATC-pie

Postby wkitty42 » Mon Jan 08, 2018 3:27 pm

as a pure eWAG, based on the "unknown command" lines, you need to properly install the "locate" and "pyqt5" packages for your distribution...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5518
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Help mayday! Can't start ATC-pie

Postby flight001 » Tue Jan 09, 2018 10:34 am

wkitty42 wrote in Mon Jan 08, 2018 3:27 pm:as a pure eWAG, based on the "unknown command" lines, you need to properly install the "locate" and "pyqt5" packages for your distribution...
Umm, i still dont get this, i already installed pyqt5 like in the tutorial in another post but that same error message at the last part kept on showing, idk what i did wrong
flight001
 
Posts: 8
Joined: Fri Jan 05, 2018 5:17 am

Re: Help mayday! Can't start ATC-pie

Postby wkitty42 » Tue Jan 09, 2018 11:17 am

i don't know anything about "brew" (i don't use it) but the very first of the log you posted says that it cannot find the locate command... without that one working, pyqt5 cannot be found so get that first error fixed and the others may fix themselves...

something else to think about is to make sure you are using the proper version of python... my system has both, python2 and python3... if i don't pay attention, it is too easy to try to use the wrong package with the wrong python version... if python3 is required, you need to do everything with python3...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5518
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Help mayday! Can't start ATC-pie

Postby flight001 » Tue Jan 09, 2018 1:05 pm

wkitty42 wrote in Tue Jan 09, 2018 11:17 am:i don't know anything about "brew" (i don't use it) but the very first of the log you posted says that it cannot find the locate command... without that one working, pyqt5 cannot be found so get that first error fixed and the others may fix themselves...

something else to think about is to make sure you are using the proper version of python... my system has both, python2 and python3... if i don't pay attention, it is too easy to try to use the wrong package with the wrong python version... if python3 is required, you need to do everything with python3...


about this, I only have python3 installed, so what's going on...?
flight001
 
Posts: 8
Joined: Fri Jan 05, 2018 5:17 am

Re: Help mayday! Can't start ATC-pie

Postby wkitty42 » Tue Jan 09, 2018 4:53 pm

if you only have python3, then i guess the proper libraries have been installed for it... that would eliminate my last part but the first part about getting the locate command to work properly still remains...

i've only ever used pip and then only once or twice...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5518
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Help mayday! Can't start ATC-pie

Postby Progman » Wed Jan 10, 2018 9:13 pm

Check https://github.com/Linuxbrew/brew/blob/ ... Manpage.md for the manual of how to use the "brew" command. It looks like there is a "search" command. You can use it to search for available python packages. Try commands like:
Code: Select all
brew search qt
brew search qt5
brew search python
brew search py
brew search pyqt5


When you have found such a package you can install it with the "install" command:
Code: Select all
brew install pyqt5             (assuming thats the package)

Also check the support forum of your linux distribution for how to install the PyQt5 package.
Progman
 
Posts: 11
Joined: Sun Dec 17, 2017 7:12 pm


Return to ATC-pie

Who is online

Users browsing this forum: No registered users and 2 guests