Board index FlightGear Support Tools ATC-pie

ATC-Pie don't start "no module named settings

ATC-pie is a radar air traffic control simulation program for the FlightGear multi-player network.

ATC-Pie don't start "no module named settings

Postby Sarith » Fri Jun 30, 2017 2:38 pm

I have problems to open atc pie on my second laptop:

here the message i got


Code: Select all
Traceback (most recent call last):
  File "C:\Users\Medion\Downloads\WinPython-64bit-3.6.1.0Qt5\python-3.6.1.amd64\lib\runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "C:\Users\Medion\Downloads\WinPython-64bit-3.6.1.0Qt5\python-3.6.1.amd64\lib\runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "C:\Users\Medion\Downloads\WinPython-64bit-3.6.1.0Qt5\python-3.6.1.amd64\scripts\ptpython.exe\__main__.py", line 9, in <module>
  File "C:\Users\Medion\Downloads\WinPython-64bit-3.6.1.0Qt5\python-3.6.1.amd64\lib\site-packages\ptpython\entry_points\run_ptpython.py", line 55, in run
    six.exec_(compile(open(a['<arg>'][0], "rb").read(), a['<arg>'][0], 'exec'))
  File "C:\Users\Medion\Desktop\ATC-pie-1.3.0\ATC-pie.py", line 31, in <module>
    from settings import settings, app_icon_path
ModuleNotFoundError: No module named 'settings'
Sarith
 
Posts: 39
Joined: Thu Jun 22, 2017 6:32 pm

Re: ATC-Pie don't start "no module named settings

Postby Sarith » Sat Jul 01, 2017 9:17 am

If you need more infos about my System just tell. i ll give it to you
Sarith
 
Posts: 39
Joined: Thu Jun 22, 2017 6:32 pm

Re: ATC-Pie don't start "no module named settings

Postby mickybadia » Sun Jul 02, 2017 6:47 pm

It just looks like you have deleted the "settings.py" in the root directory, which was required. You should download it again and restore it.
NB: To limits the odds of this happening, for the next version I have moved all source files into folders so that only the top-level executable scripts appear in the root dir.
mickybadia
 
Posts: 394
Joined: Tue Sep 24, 2013 9:12 am

Re: ATC-Pie don't start "no module named settings

Postby Sarith » Mon Jul 03, 2017 8:19 pm

it strange on my one laptop window 7 it is workin and my other laptop win 10 not both are 64bit . both start from extern harddrive. and the setting file is not deletet
Sarith
 
Posts: 39
Joined: Thu Jun 22, 2017 6:32 pm

Re: ATC-Pie don't start "no module named settings

Postby it0uchpods » Mon Jul 03, 2017 8:29 pm

Make sure you start ATC-Pie from the ATC-Pie folder, not from the python folder.
it0uchpods/WTF411

FGFS Aircraft Developer
Lead Programmer at it0uchpods Design Group
Download High Quality Aircraft from it0uchpods Hangar
User avatar
it0uchpods
 
Posts: 3463
Joined: Tue Oct 06, 2015 12:51 pm
Version: 2018.2.1
OS: Windows 10 x64


Return to ATC-pie

Who is online

Users browsing this forum: No registered users and 1 guest