Board index FlightGear Release candidates

FG git error

Release candidate testers are encouraged to post their feedback here. Please read the introduction topic for details.
Forum rules
Please read the introduction topic for details.

FG git error

Postby dtlan201 » Wed Jan 06, 2016 9:31 am

I just did a "git pull" to update my FG3.7, in the 2 last times , it work but now, I got this and couldn't fix it.
Image
dtlan201
 
Posts: 187
Joined: Sun Sep 29, 2013 3:49 am
Callsign: MIA0774
Version: 3.7
OS: Windows 7

Re: FG git error

Postby sanhozay » Wed Jan 06, 2016 9:41 am

It looks like you have updated FGDATA without updating Flightgear. Your pull on FGDATA has given you 2016.1.0 but your Flightgear is still at 3.7. You need to download and compile Flightgear 2016.1.0 and associated dependencies, e.g. Simgear.

EDIT: I think you also need to investigate why your FGDATA is under an Audacity directory. It would be easy to delete it accidentally, thinking that you were just deleting Audacity.
sanhozay
 
Posts: 1207
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ
Version: Git
OS: Ubuntu 16.04

Re: FG git error

Postby dtlan201 » Wed Jan 06, 2016 10:12 am

So how can I update simgear in windows?
dtlan201
 
Posts: 187
Joined: Sun Sep 29, 2013 3:49 am
Callsign: MIA0774
Version: 3.7
OS: Windows 7

Re: FG git error

Postby sanhozay » Wed Jan 06, 2016 10:20 am

I'm going to assume you are using a Windows nightly build?

The deal is that the update to 2016.1.0 went in yesterday evening (Jan 5 19:44 UTC). The last Windows nightly looks like it built at Jan 5 01:14 UTC, so it will still be 3.7 but, as I write, it is currently building. If that build is successful, that should give you Flightgear 2016.1.0, including Simgear and dependencies.

http://build.flightgear.org:8080/job/Windows-nightly/

It's possible that this build will fail, in which case you are stuck until someone fixes it.

Your best solution might be to go back to a 3.7 version of FGDATA, e.g. commit b640f6 and wait a few days until things stabilise with 2016.1.0.

EDIT: For anyone using nightly builds, don't pull FGDATA until you are able to get a nightly build from Jan 6 onwards.
Last edited by sanhozay on Wed Jan 06, 2016 10:22 am, edited 1 time in total.
sanhozay
 
Posts: 1207
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ
Version: Git
OS: Ubuntu 16.04

Re: FG git error

Postby dtlan201 » Wed Jan 06, 2016 10:22 am

ok
dtlan201
 
Posts: 187
Joined: Sun Sep 29, 2013 3:49 am
Callsign: MIA0774
Version: 3.7
OS: Windows 7

Re: FG git error

Postby sanhozay » Wed Jan 06, 2016 10:23 am

Do you know how to use git to revert FGDATA to an old commit?

EDIT: No need, the Windows nightly looks like it built OK:

http://download.flightgear.org/builds/nightly/
sanhozay
 
Posts: 1207
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ
Version: Git
OS: Ubuntu 16.04


Return to Release candidates

Who is online

Users browsing this forum: No registered users and 5 guests