Board index FlightGear Release candidates

Install 3.6 RC on Linux, old flightgear-data  Topic is solved

Release candidate testers are encouraged to post their feedback here. Please read the introduction topic for details.
Forum rules
Please read the introduction topic for details.

Install 3.6 RC on Linux, old flightgear-data

Postby superlou » Mon Sep 28, 2015 12:35 am

I'm trying to install the 3.6 RC on Linux Mint 17.2 x64, an Ubuntu Trusty derivative. I added the pre-release PPA and did an apt-get update. While Ubuntu sees version 3.6 of the flightgear package, it's falling back to the Mint source for flightgear-data:

Code: Select all
The following packages have unmet dependencies:
 flightgear : Depends: flightgear-data-all (>= 3.6.0~) but 3.0.0-1 is to be installed
E: Unable to correct problems, you have held broken packages.


On the PPA, the flightgear-data version doesn't show any acceptable distributions: 3.6.0~7518+gitd01b9bb-0ubuntu1~ppa2. Is there an issue with the build, or is it possible to force Mint/Ubuntu to see the package without the explicit "Trusty" identifier?
superlou
 
Posts: 20
Joined: Wed Sep 16, 2015 8:33 pm

Re: Install 3.6 RC on Linux, old flightgear-data

Postby Thorsten » Mon Sep 28, 2015 5:18 am

I don't know the specific package manager, but usually packet managers come with a 'force' option which tells them to ignore dependencies and just install the package, so I'd look into the man page and use that.
Thorsten
 
Posts: 10434
Joined: Mon Nov 02, 2009 8:33 am

Re: Install 3.6 RC on Linux, old flightgear-data

Postby massima » Mon Sep 28, 2015 10:01 am

That package isn't avalaible in the repo (http://ppa.launchpad.net/saiarcot895/flightgear-prerel/ubuntu/pool/main/f/flightgear-data/), probably a compiling issue. Try to contact the mantainer "saiarcot895".
If you want to use "force option", launch:

Code: Select all
dpkg --force-help


to check available options.
User avatar
massima
 
Posts: 214
Joined: Sat Jan 03, 2015 6:48 pm
Location: Italy
Callsign: M-AXX
Version: 2018.3.2
OS: debian testing

Re: Install 3.6 RC on Linux, old flightgear-data  

Postby saiarcot895 » Mon Sep 28, 2015 3:47 pm

It is indeed a build issue. I'm working on fixing it.
Saikrishna Arcot

My FlightGear PPAs: FlightGear Stable, FlightGear Development (Edge)
saiarcot895
 
Posts: 302
Joined: Sat Feb 02, 2013 4:26 pm
Callsign: flyhigh
Version: 2018.3.0
OS: Ubuntu 18.04

Re: Install 3.6 RC on Linux, old flightgear-data

Postby superlou » Mon Sep 28, 2015 9:53 pm

Looks like whatever you did fixed it. I was able to install normally. Thanks!
superlou
 
Posts: 20
Joined: Wed Sep 16, 2015 8:33 pm


Return to Release candidates

Who is online

Users browsing this forum: No registered users and 1 guest