Board index FlightGear Release candidates

Please test the 3.6 RC

Release candidate testers are encouraged to post their feedback here. Please read the introduction topic for details.
Forum rules
Please read the introduction topic for details.

Re: Please test the 3.6 RC

Postby VelAir » Sun Sep 27, 2015 4:50 pm

I launched 3.6 RC using Mac OSX Maverics and it was flawless. Everything initiated perfectly and installation took half the time than previous versions. Tested the launcher first flight from Macau to Hong kong the scenery as well as the frame rate is so enthralling. Then i did test the launcher to check the frame rate level in Europe sector (Controlled flying EDDK-EDDF (Jomo ATC) to my joy it was 15-17 Frame rate per second. ( Previous versions always between 2 and 5 FPS)
I from the base of my heart Thank everyone who has worked tirelessly hard to get this version. 5 STARS.
VelAir
 
Posts: 19
Joined: Fri Sep 21, 2012 6:19 pm
Callsign: D-IVEL
IRC name: VelAir
Version: 3.6 RC
OS: Mac OS X

Re: Please test the 3.6 RC

Postby rafa_elds » Mon Sep 28, 2015 9:46 pm

I checked the console and noticed that there were error messages saying that the F-15 (not a typo) exhaust flame effects could not be found. Hardly surprising, since I did not have it installed.
After installing the latest F-15 from github the problem is solved. So, just to sum it up: the F-14 that is bundled with 3.6 RC references a file from the F-15, which is not part of the base aircraft pack - at least for now.

Thorsten wrote in Sat Sep 26, 2015 5:04 pm:
I have the very same problem in Windows 10, Nvidia GT 630. But commenting out the mentioned lines did not change anything.


That would indicate that it is in fact a different problem ;-)

What plane (i.e. is it the F-14 bug Richard already identified)? Any errors related to shader compilation to the log file (something with 'fragment' or 'vertex' in it)?
Rafael dos Santos
rafa_elds
 
Posts: 14
Joined: Thu Feb 20, 2014 11:29 pm
Location: SBSJ
Version: 3.7nightly
OS: Win 10 x64

Re: Please test the 3.6 RC

Postby superlou » Mon Sep 28, 2015 9:54 pm

From the conversation at viewtopic.php?f=68&t=27554, 3.6 pre-release is now installable via PPA.
superlou
 
Posts: 20
Joined: Wed Sep 16, 2015 8:33 pm

Re: Please test the 3.6 RC

Postby Thorsten » Tue Sep 29, 2015 5:03 am

I checked the console and noticed that there were error messages saying that the F-15 (not a typo) exhaust flame effects could not be found.


Yes, that's the bug Richard already identified (and hopefully fixed...)
Thorsten
 
Posts: 10638
Joined: Mon Nov 02, 2009 8:33 am

Re: Please test the 3.6 RC

Postby clrCoda » Wed Sep 30, 2015 6:23 am

Was reminded in another thread. Point Sprites seems to still not be fixed.
Windows 32 bit 4gbRam ATI RadeonX300

Can not turn on the feature ( rembrandt and als both not engaged ) and see runway and airport lights. Have to switch it off.

This has been previously reported in the bug tracker for earlier versions of FlightGear.

Thanks
Ray
Ray St. Marie
clrCoda
 
Posts: 1228
Joined: Wed Apr 07, 2010 11:04 am

Re: Please test the 3.6 RC

Postby gsagostinho » Wed Sep 30, 2015 8:47 pm

Ludomotico has found the solution for the lack of street lights, but it requires some small changes in the source code and recompilation. Is there any chance of having this fix done before the release of 3.6? This is the post where he describes the solution: viewtopic.php?f=37&t=27495&start=15#p259184

Cheers,
Gilberto
User avatar
gsagostinho
 
Posts: 1800
Joined: Thu Jan 15, 2015 6:27 pm
Location: London, UK

Re: Please test the 3.6 RC

Postby elgaton » Wed Sep 30, 2015 8:49 pm

Regarding the libintl.dll bug, I think I'll be able to download the RC tomorrow morning and test (the "Launch FG" checkbox was not present in the 3.7 nightly I downloaded). I'll report the results.
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: Please test the 3.6 RC

Postby Richard » Wed Sep 30, 2015 10:59 pm

Thorsten wrote in Tue Sep 29, 2015 5:03 am:Yes, that's the bug Richard already identified (and hopefully fixed...)


Indeed it is fixed as mentioned
Richard wrote in Sat Sep 26, 2015 12:24 am:fixed in r923 of the FGAddon 3.6 release branch r923;.
Richard
 
Posts: 690
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: Please test the 3.6 RC -launcher

Postby FlugHund » Sun Oct 04, 2015 2:42 pm

Ahoy, before I start ranting about the qt5launcher, is Qt5 5.3.2 sufficient? Or would there be a newer version required? Also, cmake finds any qt5 packages it's looking for but are there any more requirements? And if so, how to find out? fgfs builds fine, though.
User avatar
FlugHund
 
Posts: 515
Joined: Thu Mar 01, 2007 3:27 pm
Callsign: D-HUND
IRC name: D-HUND / debdog
Version: next
OS: Devuan

Re: Please test the 3.6 RC

Postby clrCoda » Mon Oct 05, 2015 6:42 am

elgaton wrote in Wed Sep 30, 2015 8:49 pm:Regarding the libintl.dll bug, I think I'll be able to download the RC tomorrow morning and test (the "Launch FG" checkbox was not present in the 3.7 nightly I downloaded). I'll report the results.



I believe it tries to launch automatically at the end of set up without asking a preference.

If I had to hazard a guess I might suggest this run at end of set up is desired to build/re-build the navdata_(VersionNumber).cache.

Were you able to make any headway?

Best regards,
Ray
Ray St. Marie
clrCoda
 
Posts: 1228
Joined: Wed Apr 07, 2010 11:04 am

Re: Please test the 3.6 RC

Postby clrCoda » Mon Oct 05, 2015 8:48 am

clrCoda wrote in Mon Oct 05, 2015 6:42 am:I believe it tries to launch automatically at the end of set up without asking a preference.


It just now occurs to me: is this intentional? I really don't know how it's "supposed" to set up and install. I only have what I download as a reference, so I don't know if the set up skips a dialog asking for permission to start the program after install or not, or if there are other dialogs or options that are not being served to me in the startup routine.

A description or a youTube or something in that nature would go a long way to make sure everyone is testing correct code. Seeing the same thing. Looking for the same things...

:)
Ray
Ray St. Marie
clrCoda
 
Posts: 1228
Joined: Wed Apr 07, 2010 11:04 am

Re: Please test the 3.6 RC

Postby elgaton » Mon Oct 05, 2015 9:27 am

FlugHund wrote in Sun Oct 04, 2015 2:42 pm:Ahoy, before I start ranting about the qt5launcher, is Qt5 5.3.2 sufficient? Or would there be a newer version required? Also, cmake finds any qt5 packages it's looking for but are there any more requirements? And if so, how to find out?

If you have a look at CMakeLists.txt, line 303, you will see that 5.1 is the minimum required version. The same file shows that there are no further requirements.

clrCoda wrote in Mon Oct 05, 2015 6:42 am:I believe it tries to launch automatically at the end of set up without asking a preference.

If I had to hazard a guess I might suggest this run at end of set up is desired to build/re-build the navdata_(VersionNumber).cache.

Were you able to make any headway?

Unfortunately not - I was able to download the release candidate and to test it, but I was unable to reproduce the error. Here's what I have been able to find so far:
  • I have analyzed the runtime dependencies of each executable with Dependency Walker (the Windows version of ldd), as well as the build scripts. libintl-8.dll seems to be required only by FGRun and the Setup script seems to copy it correctly.
  • FGRun and FGAdmin are automatically launched (in a special "quiet" mode) during Setup to set the default preferences - that's the only way the error can be triggered. There is no option to launch the full interface at the end of the installation process, nor is FlightGear launched automatically in the end. (See the Setup script, especially the "Run" section, as well as the official Inno Setup documentation on it.)
  • In the Setup script, the FGRun/FGAdmin working directory is correctly set to {app}\bin - the directory the libintl-8.dll file is in - so the operating system should be able to find it.

Since I'm unable to reproduce the issue, could someone who has experienced this problem:
  1. download Dependency Walker, open <FlightGear installation directory>\bin\FGRun.exe with it and check if a yellow/black question mark appears next to libintl-8.dll;
  2. uninstall FlightGear completely;
  3. press Win+R to open the Run window, browse for the FlightGear installation file, append /LOG="C:\FGSetup.log" at the end (note the initial space), click OK, run the Setup program to completion and paste the contents of C:\FGSetup.log as a reply?
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: Please test the 3.6 RC

Postby FlugHund » Tue Oct 06, 2015 8:49 am

Thanks elgaton for your reply! After some more testing I decided to concentrate on git/next and report my findings to the devel ML.
User avatar
FlugHund
 
Posts: 515
Joined: Thu Mar 01, 2007 3:27 pm
Callsign: D-HUND
IRC name: D-HUND / debdog
Version: next
OS: Devuan

Re: Please test the 3.6 RC

Postby clrCoda » Tue Oct 06, 2015 4:07 pm

I was not able to find a single reference to a dll called libintl-8.dll but I did get flags and warnings.

IESHIMS.DLL Error opening file. The system cannot find the file specified (2)

The warnings are associated with IEFRAME.DLL and MFPLAT.DLL
Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

Give me a bit to collect my custom hacks from my data folder and I'll do the re-install and post with-in a few hours.

--Ray
Ray St. Marie
clrCoda
 
Posts: 1228
Joined: Wed Apr 07, 2010 11:04 am

Re: Please test the 3.6 RC

Postby elgaton » Tue Oct 06, 2015 5:12 pm

Such warnings are normal (they are spurious, in fact) - what matters is that no error message box saying that "at least one module has problems" appears when you open the file.

The reference to libintl-8.dll should be found in the top left tree view when you open FGRun.exe in Dependency Walker, however - could you double check you opened the correct file?

Thank you very much for your help!
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

PreviousNext

Return to Release candidates

Who is online

Users browsing this forum: No registered users and 1 guest