Board index FlightGear Release candidates

FG3.7 TerraSync Issue

Release candidate testers are encouraged to post their feedback here. Please read the introduction topic for details.
Forum rules
Please read the introduction topic for details.

Re: FG3.7 TerraSync Issue

Postby Lydiot » Wed Dec 09, 2015 4:22 am

I tried what you wrote and I still have problems.

For new airports 3.7 get stuck cycling the scenery download.

For tonight's flight from PANC to KSFO it ceased loading again. The error I get is "sync taking a long time: Terrain" and then followed by the tile, "HTTP status 0".

Incredibly frustrating.
Lydiot
 
Posts: 985
Joined: Tue Oct 22, 2013 10:50 pm

Re: FG3.7 TerraSync Issue

Postby vector » Wed Dec 09, 2015 1:51 pm

Got the same problem, for several weeks now and the same lines in the logs:

sync of http://foxtrot.mgras.net:8080/terrascen ... 40/e006n46 started, queue size is 7
sync taking a long time:Models taken 20001
HTTP status:1
sync taking a long time:Objects/e000n40/e006n46 taken 20001
HTTP status:1
sync taking a long time:Models taken 30001
HTTP status:1
sync taking a long time:Objects/e000n40/e006n46 taken 30001
HTTP status:0
sync taking a long time:Models taken 40016
HTTP status:0
sync taking a long time:Objects/e000n40/e006n46 taken 40018
HTTP status:0
sync taking a long time:Models taken 50050
HTTP status:0
sync taking a long time:Objects/e000n40/e006n46 taken 50050
HTTP status:0
sync taking a long time:Models taken 60073
HTTP status:0
sync taking a long time:Objects/e000n40/e006n46 taken 60072
HTTP status:0
sync taking a long time:Models taken 70100
HTTP status:0
sync taking a long time:Objects/e000n40/e006n46 taken 70099
HTTP status:0
sync taking a long time:Models taken 80016
HTTP status:0
sync taking a long time:Objects/e000n40/e006n46 taken 80016
HTTP status:0
sync taking a long time:Models taken 90041
HTTP status:0
sync taking a long time:Objects/e000n40/e006n46 taken 90041
HTTP status:0

Occasionnaly it works like a charm and the scenery gets downloaded, but most of the time, it failed.
V.
vector
 
Posts: 24
Joined: Wed Apr 17, 2013 7:40 am
Location: FR
Version: git
OS: Archlinux

Re: FG3.7 TerraSync Issue

Postby wkitty42 » Wed Dec 09, 2015 7:30 pm

yes, these showing "HTTP Status: 0" are what i've mentioned several times in the last year in a few different places...

IF you are building your own FGFS from the repo, you can try adding -DENABLE_CURL=1 to your SimGear cmake line... if you are using the download_and_compile.sh script, you can add it to the $SG_CMAKEARGS variable at the top (about line 50) of the script... what this does is switch the simgear code from using the built-in http client to using the external curl library... this is highly experimental and, AFAIK, only available in 3.7 when you build your own from the repo... you won't find this in the nightlies...

when compiling, you should see something like this in the output... specifically lines 47 and 48 at the bottom of this log snippet...

Code: Select all
git://git.code.sf.net/p/flightgear/simgear exists already
Already on 'next'
Your branch is up-to-date with 'origin/next'.
Current branch next is up to date.
-- version is 3 dot 7 dot 0
-- ignoring: ^/home/myuser/flightgear-dev/next/simgear/.git;\\.gitignore;Makefile.am;~$;
-- Library installation directory: lib/x86_64-linux-gnu
-- additional library directories: /usr/local/lib/x86_64-linux-gnu;/usr/lib/x86_64-linux-gnu;/lib/x86_64-linux-gnu
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Boost version: 1.54.0
-- SimGear mode: NORMAL
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so 
-- Found OpenAL: /usr/lib/x86_64-linux-gnu/libopenal.so 
-- Sound support: ENABLED
-- Found osgText: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgText.so 
-- Found osgSim: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgSim.so 
-- Found osgDB: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgDB.so 
-- Found osgParticle: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgParticle.so 
-- Found osgGA: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgGA.so 
-- Found osgViewer: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgViewer.so 
-- Found osgUtil: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgUtil.so 
-- Found osg: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosg.so 
-- Found OpenThreads: /home/myuser/flightgear-dev/next/install/openscenegraph/lib/libOpenThreads.so 
-- Found OpenSceneGraph: optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgText.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgTextd.so;optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgSim.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgSimd.so;optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgDB.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgDBd.so;optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgParticle.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgParticled.so;optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgGA.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgGAd.so;optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgViewer.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgViewerd.so;optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgUtil.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgUtild.so;optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosg.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libosgd.so;optimized;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libOpenThreads.so;debug;/home/myuser/flightgear-dev/next/install/openscenegraph/lib/libOpenThreadsd.so (found suitable version "3.2.3", minimum required is "3.2.0")
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8")
-- Found CURL: /usr/lib/x86_64-linux-gnu/libcurl.so (found version "7.35.0")
-- Curl HTTP client: ENABLED
-- Using built-in expat code


to disable using curl and switch back to the internal http client, set -DENABLE_CURL=0 and recompile...

PS: sharp eyes will note that i'm also using the repo version of OSG and that i have both optimized and debug builds in place ;)
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5641
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: FG3.7 TerraSync Issue

Postby Lydiot » Wed Dec 09, 2015 8:31 pm

Is there a solution for the rest of us mortals?

Right now I'm thinking that somehow downloading the scenery not using TerraSync is the way to go, and then turn it off when flying. Is that correct? I mean, the weird thing that I've noticed with this, since forever, is that if I'm flying for example across the US and have scenery already downloaded on the east/west coasts, if it starts fine and then drops out in the middle of the continent, it never reverts back to saved scenery on the other coast.
Lydiot
 
Posts: 985
Joined: Tue Oct 22, 2013 10:50 pm

Re: FG3.7 TerraSync Issue

Postby sanhozay » Wed Dec 09, 2015 8:47 pm

When tiles that you don't have don't load, tiles that you do have stop loading as well. But if you disable Terrasync (uncheck the box in the scenery download dialog), the tiles that you do have will load. If you have enough memory to load a second instance of Flightgear with the UFO, you can start the UFO at your destination so that you can at least land. Or plan ahead and fire up the UFO at your destination before a long flight.

We tend to call this a Terrasync bug, but it's a scenery loading bug. A frustratingly elusive one at that. Nobody seems to have succeeded in making it happen at will, which means it's virtually impossible to track down.

EDIT: another option is to use Terramaster to pre-download tiles. If you can get it to work. I only managed to get it to show the tiles I have.
sanhozay
 
Posts: 1207
Joined: Thu Dec 26, 2013 11:57 am
Location: EGNM
Callsign: G-SHOZ
Version: Git
OS: Ubuntu 16.04

Re: FG3.7 TerraSync Issue

Postby Lydiot » Wed Dec 09, 2015 10:09 pm

Your UFO-suggestion is a good one. Thanks.
Lydiot
 
Posts: 985
Joined: Tue Oct 22, 2013 10:50 pm

Re: FG3.7 TerraSync Issue

Postby someguy » Thu Dec 10, 2015 3:35 am

Yesterday I found a missing scenery tile in Alaska. I had last flown there several months ago, when Terrasync was still reliable, and it had been cached for several years. I disabled TS from the menu and clicked Apply, but it still wouldn't load. I tried again today, and TS loaded the tile normally before I got within visual range. It seems to fail randomly, and at the server end.

FWIW, the tile across the Bay north of KNUQ hasn't loaded in a year or more. I assume the reason is different for that.
User avatar
someguy
 
Posts: 1653
Joined: Tue Nov 25, 2008 5:54 am
Location: USA
Version: 2016.2.1
OS: Mac OS X 10.11

Re: FG3.7 TerraSync Issue

Postby vector » Thu Dec 10, 2015 12:06 pm

I tried a direct svn pull from the terrascenery server and it timeouts at each update. I also tried terrasync and this one behaves the same way FG does i.e. works occasionaly to poll the data but fails most of the time. It looks like this is a server issue on foxtrot.mgras.net.

@wlbragg, thanks for pointing the CURL option for simgear, I'll give it a try. BTW, flightgear needs to be recompiled too to include James commit to handle libCurl if simgear is compiled to use it.

V.
vector
 
Posts: 24
Joined: Wed Apr 17, 2013 7:40 am
Location: FR
Version: git
OS: Archlinux

Re: FG3.7 TerraSync Issue

Postby wkitty42 » Thu Dec 10, 2015 4:31 pm

vector wrote in Thu Dec 10, 2015 12:06 pm:@wlbragg, thanks for pointing the CURL option for simgear, I'll give it a try.

i think that was me, actually ;)

vector wrote in Thu Dec 10, 2015 12:06 pm:BTW, flightgear needs to be recompiled too to include James commit to handle libCurl if simgear is compiled to use it.

yes, if you rebuild simgear, you have to rebuild flightgear, too... i use a script so it is all the same to me... eg: ~/flightgear-dev/updatenext which is my personal script...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5641
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Previous

Return to Release candidates

Who is online

Users browsing this forum: No registered users and 7 guests