Board index FlightGear Development Scenery

Cannot Build Scenery Using HGT Elevation Data

Questions and discussion about enhancing and populating the FlightGear world.

Cannot Build Scenery Using HGT Elevation Data

Postby b2356218 » Fri Jun 28, 2019 2:30 pm

Hi,
I installed flightgear, simgear and terragear successfully. I am trying to build scenery using hgt file. I selected coordinates using map and downloaded hgt files. Then since hgt files downloaded by terragui is broken I downloaded and replaced corresponding hgt files from https://dds.cr.usgs.gov/srtm/version2_1/SRTM3/Eurasia/ and converted hgt file to fit and arr files using terragui. However after I generate scenery output folder is empty. I tried commands generated by terragui on terminal, although it says finished successfully output folder is still empty. What else I need to do to generate scenery succesfully?
b2356218
 
Posts: 1
Joined: Fri Jun 28, 2019 2:18 pm

Re: Cannot Build Scenery Using HGT Elevation Data

Postby xDraconian » Fri Jun 28, 2019 3:22 pm

Hi b2356218,

There is a reference scenery project that could help you compare your steps with a known working example.

https://sourceforge.net/p/flightgear/fgmeta/ci/next/tree/fg-from-scratch/CustomSceneryProjects/Test/
xDraconian
 
Posts: 240
Joined: Sun Jan 21, 2018 5:53 am
Version: Git
OS: Linux Mint

Re: Cannot Build Scenery Using HGT Elevation Data

Postby legoboyvdlp » Fri Jun 28, 2019 5:19 pm

Did you also add land classe shape files - I'm not quite sure, you don't mention them, but if you didn't use any land class (even the OSM landmass polygons as the Default) no scenery would be produced - it would all be water!
User avatar
legoboyvdlp
 
Posts: 7186
Joined: Sat Jul 26, 2014 1:28 am
Callsign: YV-LEGO
Version: next
OS: Windows 10 HP

Re: Cannot Build Scenery Using HGT Elevation Data

Postby frtps » Sat Jun 29, 2019 12:11 am

In my experience, tg-construct (the final step) will often appear to finish successfully in terragui when it has in fact encountered a problem with the input files generated by genapts/ogr-decode. If the output directory is empty, this is what has happened. If you look at the logfile output (a text file named "tg-construct.log" in the same directory that you run terragui, I think) it may have some information. If it doesn't say "Finished successfully" at the end, it has failed. The best way I've found to locate the problem in this case is to reduce the number of types of landclass that you feed to the tg-construct step until it works, then gradually add them back in. You could try to construct scenery using just the Default, Airport, AirportObj, and SRTM3 landclasses, and let us know how that goes.

It is possible that the landclass stored in one of the files generated by ogr-decode does not match anything found by tg-construct in "default_priorities.txt". This should leave a message in the log. I have gone wrong on that one a few times, but it is easy to fix.
frtps
 
Posts: 51
Joined: Sun Aug 05, 2018 9:58 am


Return to Scenery

Who is online

Users browsing this forum: MSN [Bot], YandexBot [Bot] and 2 guests