Board index FlightGear Development Scenery

Pittsburg Development

Questions and discussion about enhancing and populating the FlightGear world.

Re: Pittsburg Development

Postby penta » Fri Jun 14, 2013 7:49 pm

Rick Ace wrote in Fri Jun 14, 2013 7:19 pm:That clears up a lot of confusion penta. :) I like how you explain everything in a simple way.

Thanks for the comment! I also went through the learning curve of blender and I'm trying to synthesize the most useful tricks I've learned.

Rick Ace wrote in Fri Jun 14, 2013 7:19 pm:I'm using the exporter but the textures don't come along. I'm not sure what I'm doing wrong here. I see the textures in edit mode with texture selected.

I don't really know what could be the problem; for exporting to ac, it should be enough to associate a texture in the UV viewer to the model...would you mind to share the blend file so that I can further investigate?
penta
 
Posts: 238
Joined: Mon Dec 29, 2008 11:05 am
Location: Parma-Italy
Version: Git
OS: Ubuntu Linux

Re: Pittsburg Development

Postby gooneybird » Fri Jun 14, 2013 7:59 pm

There's a peculiarity in the exporter in that you have to assign a UV Map to each object http://www.flightgear.org/forums/viewtopic.php?f=18&t=13442&hilit=blender+exporter&start=240#p174099

I've never worked out how I did it but here's my final settings:

Material window
Image

Textures window
Image

To add to penta's comments you can constrain the movement to horizontal or vertical in the UV Mapping window by pressing "G" followed by "X" or "Y" and rotation "R" can be followed by a number ie. R90 will rotate 90 degrees.
gooneybird
 
Posts: 2971
Joined: Sat May 31, 2008 1:57 pm

Re: Pittsburg Development

Postby Rick Ace » Fri Jun 14, 2013 8:22 pm

Gooney, thank you for the screenshots! It solved the puzzle. :D

I didn't know about "Mapping" under the texture tab. I selected Coordinates: UV, and UVMap for map and it worked.

Thanks again penta. :)

Edit: The texture is exporting. But it's not behaving to my UVMap though, which is weird. Was setting the coordinates the wrong thing to do?
Rick Ace
 
Posts: 1023
Joined: Fri May 14, 2010 6:02 pm
Location: New York City
Callsign: rickace
Version: 2.6.0
OS: Vista

Re: Pittsburg Development

Postby penta » Sat Jun 15, 2013 7:25 am

Rick Ace wrote in Fri Jun 14, 2013 8:22 pm:Edit: The texture is exporting. But it's not behaving to my UVMap though, which is weird. Was setting the coordinates the wrong thing to do?


The "texture" view in 3dview shows you the model with the associated UVMap image
The render view shows the material

This is probably why you see the texture correctly in 3dview but not when exported. To really preview the exported model, you should do a render: just add a sunlight, enable ambient occlusion in the "world" menu and add a camera. Then press F12 to render (the camera should point to the model or you will see an empty render)

Here is my model rendered for reference. If you change the Coordinates Mapping and render again strange things happens! What you see in the render is how the texture will appear in the exported ac model.
Image
penta
 
Posts: 238
Joined: Mon Dec 29, 2008 11:05 am
Location: Parma-Italy
Version: Git
OS: Ubuntu Linux

Previous

Return to Scenery

Who is online

Users browsing this forum: No registered users and 6 guests