Board index FlightGear Development Scenery

Taxiway marking flickering

Questions and discussion about enhancing and populating the FlightGear world.

Taxiway marking flickering

Postby Soitanen » Wed Feb 13, 2013 7:28 am

Why markings are flickering on taxiways? Especially it is very annoying, when you are moving. Markings start to disappear near to you.

Here yellow solid line must be near runway hold line. But it disappears.
Image

Again solid yellow line looks very thin.
Image

Almost the same, as previus, but it's white line disappear.
Image

Is it renderer problem or problem in generating scenery?
Boeing 737-300. Reworked cockpit, FDM, autopilot and much more. WIP.
Boeing 737-800. WIP. Canvas PFD and ND.
Antonov An-24B. Made from scratch. Very good FDM. 3D model by Adrian. WIP.
Project Russia (some cities, based on OSM with custom objects).
Soitanen
 
Posts: 486
Joined: Sat Jun 16, 2012 6:50 am
Location: Saint-Petersburg, Russia
Version: git
OS: Linux Mint 17

Re: Taxiway marking flickering

Postby chris_blues » Wed Feb 13, 2013 7:39 am

These things happen to me, when I got Rembrandt enabled. Without Rembrandt, all works fine...
I guess some child-sickness, since Rembrandt is very new :)
Don't hesitate to let me know if I'm incorrect or just annoying! As long as you do it gently! :)
Debian testing 64bit - Athlon II 2x2.6GHz - 8GB RAM - GeForce GTS 450
Citation II
User avatar
chris_blues
 
Posts: 1526
Joined: Mon May 03, 2010 1:30 pm
Location: claws of real life
Callsign: chris_blues
Version: GIT
OS: Debian 8 64

Re: Taxiway marking flickering

Postby Soitanen » Wed Feb 13, 2013 7:59 am

In my case Rembrandt is turned off. Enabling or disabling Atmospheric light scattering doesn't make any effect.
Boeing 737-300. Reworked cockpit, FDM, autopilot and much more. WIP.
Boeing 737-800. WIP. Canvas PFD and ND.
Antonov An-24B. Made from scratch. Very good FDM. 3D model by Adrian. WIP.
Project Russia (some cities, based on OSM with custom objects).
Soitanen
 
Posts: 486
Joined: Sat Jun 16, 2012 6:50 am
Location: Saint-Petersburg, Russia
Version: git
OS: Linux Mint 17

Re: Taxiway marking flickering

Postby Thorsten » Wed Feb 13, 2013 8:11 am

z-fighting? The markings are at the same depth as the runway, and so the renderer picks up one or the other while you would want the markings at a lower depth so they're picked always? No idea how the markings are done technically...
Thorsten
 
Posts: 9548
Joined: Mon Nov 02, 2009 8:33 am

Re: Taxiway marking flickering

Postby i4dnf » Wed Feb 13, 2013 8:16 am

Your z-buffer precision is probably too low. Have you messed with the near-camera clip values, or are you using "huge" visibility distances?

See if increasing the factor or units value in Effects/lfeat.eff solves the problem, right at the end of the file (line 81)

Code: Select all
     <polygon-offset>
      <factor>-1.0</factor>
      <units>-1.0</units>
     </polygon-offset>


One other thing is that polygon-offset might not work properly on your gpu.

In Rembrandt this is caused by the fact that there's only one camera used to render the scene (as opposed to the default rendering where there are two cameras near/far), then, with increased view distance, the z-buffer precision decays leading to z-fighting.
i4dnf
Retired
 
Posts: 745
Joined: Wed Sep 09, 2009 7:17 am
Location: LRBS
Callsign: YR-I4D
Version: GIT
OS: Gentoo Linux ~amd64

Re: Taxiway marking flickering

Postby Michat » Wed Feb 13, 2013 8:40 am

Last version I used in FG was 2.6....RC. was with ATI full32AA 24 Z buffer, testing with all the filters, I had similar Z effects, not so marked as yours, but only in the RWY lateral limitation lines.
No Rembrant, no taxiways marking installed. :roll:
User avatar
Michat
 
Posts: 923
Joined: Mon Jan 25, 2010 6:24 pm
Location: Spain
Version: 191b
OS: GNewSense

Re: Taxiway marking flickering

Postby i4dnf » Wed Feb 13, 2013 8:48 am

@Michat: Runway markings are "embedded" in the runway textures, so your issue is likely due to some other causes.
i4dnf
Retired
 
Posts: 745
Joined: Wed Sep 09, 2009 7:17 am
Location: LRBS
Callsign: YR-I4D
Version: GIT
OS: Gentoo Linux ~amd64

Re: Taxiway marking flickering

Postby Soitanen » Wed Feb 13, 2013 9:12 am

i4dnf wrote in Wed Feb 13, 2013 8:16 am:See if increasing the factor or units value in Effects/lfeat.eff solves the problem, right at the end of the file (line 81)
Code: Select all
     <polygon-offset>
      <factor>-1.0</factor>
      <units>-1.0</units>
     </polygon-offset>


Setting factor to something around -100 gradually reduced filckering. But thin lines has not been fixed.
Boeing 737-300. Reworked cockpit, FDM, autopilot and much more. WIP.
Boeing 737-800. WIP. Canvas PFD and ND.
Antonov An-24B. Made from scratch. Very good FDM. 3D model by Adrian. WIP.
Project Russia (some cities, based on OSM with custom objects).
Soitanen
 
Posts: 486
Joined: Sat Jun 16, 2012 6:50 am
Location: Saint-Petersburg, Russia
Version: git
OS: Linux Mint 17

Re: Taxiway marking flickering

Postby psadro_gm » Wed Feb 13, 2013 3:03 pm

This is an issue I'm working on now - draping.

currently, the height of each vertex (underlying pavement or taxiway marking) is calculated by the smoothing function. problems occur because the taxiway lines do not get extra vertices when crossing a triangle boundary of the terrain.

So, the taxiway lines are not really coplanar with the underlying pavement. playing with the polygon offset parameters can help, but the will most likely cause issues elsewhere.

Here's the wiki page describing how this should be done:

http://wiki.flightgear.org/TerraGear_support_for_Draping

On that page, genapts850 partially implements up to step 3. step 4 would make most of these issues go away, I think.
8.50 airport parser, textured roads and streams...
psadro_gm
 
Posts: 750
Joined: Thu Aug 25, 2011 2:23 am
Location: Atlanta, GA USA
IRC name: psadro_*
Version: git
OS: Fedora 21


Return to Scenery

Who is online

Users browsing this forum: No registered users and 4 guests