Board index FlightGear Support Compiling

download_and_compile.sh on Debian on WSL  Topic is solved

Building FlightGear from source, and in the need for help?

Re: download_and_compile.sh on Debian on WSL

Postby pb321 » Tue Jun 16, 2020 3:11 pm

I tried to install the suffix "a" package:
Code: Select all
pb321@Lenovo:~$ sudo apt-get install libqt5core5a
[sudo] password for pb321:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libqt5core5a is already the newest version (5.11.3+dfsg1-1+deb10u3).
libqt5core5a set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
pb321
 
Posts: 238
Joined: Sun Nov 27, 2016 4:08 pm
Version: 2019.2.0
OS: Windows 10 Pro

Re: download_and_compile.sh on Debian on WSL

Postby rominet » Tue Jun 16, 2020 3:24 pm

Please give us the output of:
Code: Select all
dpkg -s libqt5core5a | grep Status

Code: Select all
dpkg -L libqt5core5a

Code: Select all
ls -l /usr/lib/x86_64-linux-gnu/libQt5Core.so.5

and 'ls -l' of the target of this file (which, again, should be a symlink).
rominet
 
Posts: 577
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: download_and_compile.sh on Debian on WSL

Postby pb321 » Tue Jun 16, 2020 3:29 pm

Here is a link (from June 2018) that describes trying to resolve the missing libqt5core.so.5:
http://forums.debian.net/viewtopic.php?f=10&t=137888
I tried the apt-file commands suggested in the thread but it could not find the command.
pb321
 
Posts: 238
Joined: Sun Nov 27, 2016 4:08 pm
Version: 2019.2.0
OS: Windows 10 Pro

Re: download_and_compile.sh on Debian on WSL

Postby rominet » Tue Jun 16, 2020 3:37 pm

Well, feel free to read whatever you want, but if you don't give the output of the commands I asked I can't help you. Sorry.
rominet
 
Posts: 577
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: download_and_compile.sh on Debian on WSL

Postby pb321 » Tue Jun 16, 2020 3:49 pm

Sorry, I think our replies were sent at approximately the same time. I very much appreciate your help! Here's the output:
Code: Select all
pb321@Lenovo:~$ dpkg -s libqt5core5a | grep Status
Status: install ok installed
pb321@Lenovo:~$ ls -l /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
lrwxrwxrwx 1 root root 20 Jan 30 07:42 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 -> libQt5Core.so.5.11.3
pb321
 
Posts: 238
Joined: Sun Nov 27, 2016 4:08 pm
Version: 2019.2.0
OS: Windows 10 Pro

Re: download_and_compile.sh on Debian on WSL

Postby rominet » Tue Jun 16, 2020 3:55 pm

I asked for the output of four commands. We have only two here...
rominet
 
Posts: 577
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: download_and_compile.sh on Debian on WSL

Postby pb321 » Tue Jun 16, 2020 4:04 pm

Code: Select all
pb321@Lenovo:~$ dpkg -L libqt5core5a
/.
/usr
/usr/lib
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5.11.3
/usr/share
/usr/share/doc
/usr/share/doc/libqt5core5a
/usr/share/doc/libqt5core5a/changelog.Debian.gz
/usr/share/doc/libqt5core5a/copyright
/usr/share/lintian
/usr/share/lintian/overrides
/usr/share/lintian/overrides/libqt5core5a
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5.11


I'm sorry, but I'm not understanding the last command. How do I find the "target" (libQt5Core.so.5?) and is it ls -1 or ls -l ? It looks like "l" as in link. Is that correct?
pb321
 
Posts: 238
Joined: Sun Nov 27, 2016 4:08 pm
Version: 2019.2.0
OS: Windows 10 Pro

Re: download_and_compile.sh on Debian on WSL

Postby pb321 » Tue Jun 16, 2020 4:20 pm

Is this it?
Code: Select all
pb321@Lenovo:~$ ls -l /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
lrwxrwxrwx 1 root root 20 Jan 30 07:42 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 -> libQt5Core.so.5.11.3
pb321
 
Posts: 238
Joined: Sun Nov 27, 2016 4:08 pm
Version: 2019.2.0
OS: Windows 10 Pro

Re: download_and_compile.sh on Debian on WSL

Postby rominet » Tue Jun 16, 2020 4:24 pm

'l' stands for 'long', so it is the letter. Your:
Code: Select all
pb321@Lenovo:~$ ls -l /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
lrwxrwxrwx 1 root root 20 Jan 30 07:42 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 -> libQt5Core.so.5.11.3

shows that /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 is a symbolic link to /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.11.3. What follows the arrow (->) is the symlink target. So, the last command I asked for is:
Code: Select all
ls -l /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.11.3

('l' being the lowercase letter).
rominet
 
Posts: 577
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: download_and_compile.sh on Debian on WSL

Postby pb321 » Tue Jun 16, 2020 4:32 pm

OK. Thanks for the explanation. Here is the output:
Code: Select all
pb321@Lenovo:~$ ls -l /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.11.3
-rw-r--r-- 1 root root 5200168 Jan 30 07:42 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.11.3
pb321
 
Posts: 238
Joined: Sun Nov 27, 2016 4:08 pm
Version: 2019.2.0
OS: Windows 10 Pro

Re: download_and_compile.sh on Debian on WSL

Postby rominet » Tue Jun 16, 2020 5:04 pm

This looks normal. No idea what the problem is so far. What about
Code: Select all
ldd /usr/lib/qt5/bin/lrelease | grep -F libQt5Core.so.5

This ought to point to a file you have. Also useful would be:
Code: Select all
echo "X${LD_LIBRARY_PATH}X"

Code: Select all
qtchooser -print-env

(you have the qtchooser package, right?)

If things work normally,
Code: Select all
qtchooser -run-tool=lrelease

should show the help text for the lrelease tool you had a problem with (so, I'd expect it to fail the same way you saw until the problem is fixed).
rominet
 
Posts: 577
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: download_and_compile.sh on Debian on WSL

Postby pb321 » Tue Jun 16, 2020 5:17 pm

Here are the results:
Code: Select all
pb321@Lenovo:~$ ldd /usr/lib/qt5/bin/lrelease | grep -F libQt5Core.so.5
        libQt5Core.so.5 => not found
        libQt5Core.so.5 => not found
pb321@Lenovo:~$ echo "X${LD_LIBRARY_PATH}X"
XX
pb321@Lenovo:~$ qtchooser -print-env
QT_SELECT="default"
QTTOOLDIR="/usr/lib/qt5/bin"
QTLIBDIR="/usr/lib/x86_64-linux-gnu"
pb321@Lenovo:~$ qtchooser -run-tool=lrelease
/usr/lib/qt5/bin/lrelease: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory
pb321
 
Posts: 238
Joined: Sun Nov 27, 2016 4:08 pm
Version: 2019.2.0
OS: Windows 10 Pro

Re: download_and_compile.sh on Debian on WSL

Postby rominet » Tue Jun 16, 2020 5:38 pm

The output of
Code: Select all
ldd /usr/lib/qt5/bin/lrelease | grep -F libQt5Core.so.5

is not normal. Why is it so is yet to be discovered, though. I'm on smartphone now, so it'll be a bit harder to help.

Are all your packages up-to-date (ISTR they aren't). Maybe some of those not yet upgraded are needed to match other ones already installed?

After verifying this, you may want to run 'ldconfig' as root (e.g., with sudo) then rerun the above ldd command as a normal user. You can also inspect /etc/ld.so.conf and files in /etc/ld.so.conf.d. They should tell where shared libraries such as libQt5Core.so.5 are looked for after the runtime linker has tried higher priority sources like LD_PRELOAD and LD_LIBRARY_PATH (both env vars).
rominet
 
Posts: 577
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

Re: download_and_compile.sh on Debian on WSL

Postby pb321 » Tue Jun 16, 2020 6:12 pm

Results of apt-get update and apt-get upgrade (and ldconfig):
Code: Select all
pb321@Lenovo:~$ sudo apt-get update
[sudo] password for pb321:
Hit:1 http://deb.debian.org/debian buster InRelease
Get:2 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]
Hit:3 http://security.debian.org/debian-security buster/updates InRelease
Get:4 http://ftp.debian.org/debian buster-backports InRelease [46.7 kB]
Get:5 http://ftp.debian.org/debian buster-backports/main amd64 Packages.diff/Index [27.8 kB]
Get:6 http://ftp.debian.org/debian buster-backports/main Translation-en.diff/Index [27.8 kB]
Get:7 http://ftp.debian.org/debian buster-backports/main amd64 Packages 2020-06-16-0206.36.pdiff [1,876 B]
Get:8 http://ftp.debian.org/debian buster-backports/main Translation-en 2020-06-15-2002.49.pdiff [1,150 B]
Get:7 http://ftp.debian.org/debian buster-backports/main amd64 Packages 2020-06-16-0206.36.pdiff [1,876 B]
Get:8 http://ftp.debian.org/debian buster-backports/main Translation-en 2020-06-15-2002.49.pdiff [1,150 B]
Fetched 157 kB in 1min 10s (2,258 B/s)
Reading package lists... Done
pb321@Lenovo:~$ sudo ldconfig
pb321@Lenovo:~$ ldd /usr/lib/qt5/bin/lrelease | grep -F libQt5Core.so.5
        libQt5Core.so.5 => not found
        libQt5Core.so.5 => not found
pb321@Lenovo:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  apt apt-utils base-files cron e2fsprogs iputils-ping libapt-inst2.0
  libapt-pkg5.0 libcom-err2 libcryptsetup12 libdns-export1104
  libext2fs2 libisc-export1100 libncurses6 libncursesw6 libss2
  libssl1.1 libtinfo6 ncurses-base ncurses-bin sudo systemd-sysv
  tzdata
23 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.1 MB of archives.
After this operation, 3,072 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://security.debian.org/debian-security buster/updates/main amd64 libapt-pkg5.0 amd64 1.8.2.1 [966 kB]
Get:2 http://deb.debian.org/debian buster/main amd64 base-files amd64 10.3+deb10u4 [69.8 kB]
Get:3 http://deb.debian.org/debian buster/main amd64 ncurses-bin amd64 6.1+20181013-2+deb10u2 [406 kB]
Get:4 http://deb.debian.org/debian buster/main amd64 ncurses-base all 6.1+20181013-2+deb10u2 [258 kB]
Get:5 http://deb.debian.org/debian buster/main amd64 libext2fs2 amd64 1.44.5-1+deb10u3 [221 kB]
Get:6 http://security.debian.org/debian-security buster/updates/main amd64 libapt-inst2.0 amd64 1.8.2.1 [203 kB]
Get:7 http://deb.debian.org/debian buster/main amd64 e2fsprogs amd64 1.44.5-1+deb10u3 [576 kB]
Get:8 http://security.debian.org/debian-security buster/updates/main amd64 apt amd64 1.8.2.1 [1,418 kB]
Get:9 http://deb.debian.org/debian buster/main amd64 cron amd64 3.0pl1-134+deb10u1 [99.0 kB]
Get:10 http://deb.debian.org/debian buster/main amd64 systemd-sysv amd64 241-7~deb10u4 [99.9 kB]
Get:11 http://deb.debian.org/debian buster/main amd64 libncurses6 amd64 6.1+20181013-2+deb10u2 [102 kB]
Get:12 http://deb.debian.org/debian buster/main amd64 libtinfo6 amd64 6.1+20181013-2+deb10u2 [325 kB]
Get:13 http://deb.debian.org/debian buster/main amd64 libncursesw6 amd64 6.1+20181013-2+deb10u2 [132 kB]
Get:14 http://deb.debian.org/debian buster/main amd64 tzdata all 2020a-0+deb10u1 [263 kB]
Get:15 http://deb.debian.org/debian buster/main amd64 iputils-ping amd64 3:20180629-2+deb10u1 [43.3 kB]
Get:16 http://deb.debian.org/debian buster/main amd64 libcom-err2 amd64 1.44.5-1+deb10u3 [68.4 kB]
Get:17 http://deb.debian.org/debian buster/main amd64 libssl1.1 amd64 1.1.1d-0+deb10u3 [1,538 kB]
Get:18 http://security.debian.org/debian-security buster/updates/main amd64 apt-utils amd64 1.8.2.1 [421 kB]
Get:19 http://security.debian.org/debian-security buster/updates/main amd64 libisc-export1100 amd64 1:9.11.5.P4+dfsg-5.1+deb10u1 [380 kB]
Get:20 http://security.debian.org/debian-security buster/updates/main amd64 libdns-export1104 amd64 1:9.11.5.P4+dfsg-5.1+deb10u1 [972 kB]
Get:21 http://deb.debian.org/debian buster/main amd64 libcryptsetup12 amd64 2:2.1.0-5+deb10u2 [193 kB]
Get:22 http://deb.debian.org/debian buster/main amd64 libss2 amd64 1.44.5-1+deb10u3 [72.9 kB]
Get:23 http://deb.debian.org/debian buster/main amd64 sudo amd64 1.8.27-1+deb10u2 [1,245 kB]
Fetched 10.1 MB in 40s (254 kB/s)
Preconfiguring packages ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../base-files_10.3+deb10u4_amd64.deb ...
Unpacking base-files (10.3+deb10u4) over (10.3) ...
Setting up base-files (10.3+deb10u4) ...
Installing new version of config file /etc/debian_version ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../ncurses-bin_6.1+20181013-2+deb10u2_amd64.deb ...
Unpacking ncurses-bin (6.1+20181013-2+deb10u2) over (6.1+20181013-2) ...
Setting up ncurses-bin (6.1+20181013-2+deb10u2) ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../ncurses-base_6.1+20181013-2+deb10u2_all.deb ...
Unpacking ncurses-base (6.1+20181013-2+deb10u2) over (6.1+20181013-2) ...
Setting up ncurses-base (6.1+20181013-2+deb10u2) ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../libapt-pkg5.0_1.8.2.1_amd64.deb ...
Unpacking libapt-pkg5.0:amd64 (1.8.2.1) over (1.8.2) ...
Setting up libapt-pkg5.0:amd64 (1.8.2.1) ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../libapt-inst2.0_1.8.2.1_amd64.deb ...
Unpacking libapt-inst2.0:amd64 (1.8.2.1) over (1.8.2) ...
Preparing to unpack .../archives/apt_1.8.2.1_amd64.deb ...
Unpacking apt (1.8.2.1) over (1.8.2) ...
Setting up apt (1.8.2.1) ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../apt-utils_1.8.2.1_amd64.deb ...
Unpacking apt-utils (1.8.2.1) over (1.8.2) ...
Preparing to unpack .../libext2fs2_1.44.5-1+deb10u3_amd64.deb ...
Unpacking libext2fs2:amd64 (1.44.5-1+deb10u3) over (1.44.5-1) ...
Setting up libext2fs2:amd64 (1.44.5-1+deb10u3) ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../e2fsprogs_1.44.5-1+deb10u3_amd64.deb ...
Unpacking e2fsprogs (1.44.5-1+deb10u3) over (1.44.5-1) ...
Preparing to unpack .../cron_3.0pl1-134+deb10u1_amd64.deb ...
Unpacking cron (3.0pl1-134+deb10u1) over (3.0pl1-134) ...
Preparing to unpack .../systemd-sysv_241-7~deb10u4_amd64.deb ...
Unpacking systemd-sysv (241-7~deb10u4) over (241-5) ...
Preparing to unpack .../libncurses6_6.1+20181013-2+deb10u2_amd64.deb ...
Unpacking libncurses6:amd64 (6.1+20181013-2+deb10u2) over (6.1+20181013-2) ...
Preparing to unpack .../libtinfo6_6.1+20181013-2+deb10u2_amd64.deb ...
Unpacking libtinfo6:amd64 (6.1+20181013-2+deb10u2) over (6.1+20181013-2) ...
Setting up libtinfo6:amd64 (6.1+20181013-2+deb10u2) ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../libncursesw6_6.1+20181013-2+deb10u2_amd64.deb ...
Unpacking libncursesw6:amd64 (6.1+20181013-2+deb10u2) over (6.1+20181013-2) ...
Setting up libncursesw6:amd64 (6.1+20181013-2+deb10u2) ...
(Reading database ... 75717 files and directories currently installed.)
Preparing to unpack .../0-tzdata_2020a-0+deb10u1_all.deb ...
Unpacking tzdata (2020a-0+deb10u1) over (2019a-1) ...
Preparing to unpack .../1-iputils-ping_3%3a20180629-2+deb10u1_amd64.deb ...
Unpacking iputils-ping (3:20180629-2+deb10u1) over (3:20180629-2) ...
Preparing to unpack .../2-libcom-err2_1.44.5-1+deb10u3_amd64.deb ...
Unpacking libcom-err2:amd64 (1.44.5-1+deb10u3) over (1.44.5-1) ...
Preparing to unpack .../3-libssl1.1_1.1.1d-0+deb10u3_amd64.deb ...
Unpacking libssl1.1:amd64 (1.1.1d-0+deb10u3) over (1.1.1c-1) ...
Preparing to unpack .../4-libcryptsetup12_2%3a2.1.0-5+deb10u2_amd64.deb ...
Unpacking libcryptsetup12:amd64 (2:2.1.0-5+deb10u2) over (2:2.1.0-5) ...
Preparing to unpack .../5-libisc-export1100_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Unpacking libisc-export1100:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) over (1:9.11.5.P4+dfsg-5.1) ...
Preparing to unpack .../6-libdns-export1104_1%3a9.11.5.P4+dfsg-5.1+deb10u1_amd64.deb ...
Unpacking libdns-export1104 (1:9.11.5.P4+dfsg-5.1+deb10u1) over (1:9.11.5.P4+dfsg-5.1) ...
Preparing to unpack .../7-libss2_1.44.5-1+deb10u3_amd64.deb ...
Unpacking libss2:amd64 (1.44.5-1+deb10u3) over (1.44.5-1) ...
Preparing to unpack .../8-sudo_1.8.27-1+deb10u2_amd64.deb ...
Unpacking sudo (1.8.27-1+deb10u2) over (1.8.27-1) ...
Setting up systemd-sysv (241-7~deb10u4) ...
Setting up libssl1.1:amd64 (1.1.1d-0+deb10u3) ...
Setting up cron (3.0pl1-134+deb10u1) ...
invoke-rc.d: could not determine current runlevel
Setting up libcom-err2:amd64 (1.44.5-1+deb10u3) ...
Setting up libapt-inst2.0:amd64 (1.8.2.1) ...
Setting up tzdata (2020a-0+deb10u1) ...

Current default time zone: 'America/Chicago'
Local time is now:      Tue Jun 16 13:03:29 CDT 2020.
Universal Time is now:  Tue Jun 16 18:03:29 UTC 2020.
Run 'dpkg-reconfigure tzdata' if you wish to change it.

Setting up libncurses6:amd64 (6.1+20181013-2+deb10u2) ...
Setting up libss2:amd64 (1.44.5-1+deb10u3) ...
Setting up sudo (1.8.27-1+deb10u2) ...
invoke-rc.d: could not determine current runlevel
Setting up libisc-export1100:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Setting up libcryptsetup12:amd64 (2:2.1.0-5+deb10u2) ...
Setting up libdns-export1104 (1:9.11.5.P4+dfsg-5.1+deb10u1) ...
Setting up iputils-ping (3:20180629-2+deb10u1) ...
Setting up apt-utils (1.8.2.1) ...
Setting up e2fsprogs (1.44.5-1+deb10u3) ...
Processing triggers for libc-bin (2.28-10) ...
Processing triggers for systemd (241-7~deb10u4) ...
pb321@Lenovo:~$ ldd /usr/lib/qt5/bin/lrelease | grep -F libQt5Core.so.5
        libQt5Core.so.5 => not found
        libQt5Core.so.5 => not found
pb321@Lenovo:~$ ldconfig
ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Permission denied


I hope the "upgrade" was OK to do, as I didn't see much happening with the "update". I'll be sending the other results, too. It might take a little longer.
pb321
 
Posts: 238
Joined: Sun Nov 27, 2016 4:08 pm
Version: 2019.2.0
OS: Windows 10 Pro

Re: download_and_compile.sh on Debian on WSL

Postby rominet » Tue Jun 16, 2020 6:23 pm

The error:
Code: Select all
ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Permission denied

Is normal, I think, because ldconfig must be run as root to do its work. The upgrade seems to have gone fine, except for the
Code: Select all
invoke-rc.d: could not determine current runlevel

which might be due to WSL (?). However, I don't think any of the upgraded packages is related to the problem.
rominet
 
Posts: 577
Joined: Sat Nov 01, 2014 1:33 pm
Callsign: F-KATS
Version: Git next
OS: Debian GNU/Linux

PreviousNext

Return to Compiling

Who is online

Users browsing this forum: No registered users and 2 guests