Board index FlightGear Support Compiling

New windows build crashes on startup.

Building FlightGear from source, and in the need for help?

New windows build crashes on startup.

Postby chriscalef » Sat Jan 18, 2020 7:22 pm

After some effort I have at last succeeded in creating an fgfs executable in Windows, using VS2017 and the instructions located here:

http://wiki.flightgear.org/Building_usi ... _-_Windows

I know I took a risk by using VS2017, when it said it was only tested with VS2015, but I had heard reports that others had done it with 2017 so I went for it.

But in any event, I have a build, and it crashes immediately on startup. It sometimes gets as far as making a flightgear-sized window frame before it crashes, but that's about it.

I have tried looking at the log, which ends on the following warning, but I'm suspicious that this is not my actual problem since there are a lot of previous warnings, and I don't see anything labeled ERROR in there:

20.97 [WARN]:io f:\flightgear\fgmeta\simgear\simgear\scene\model\modelregistry.cxx:657:Image loading failed:

I have tried to run it in debug mode, and I get a bad memory allocation crash off in SimGear at osgDB::RegisterDotOsgWrapperProxy effectGeodeProxy, but it lacks debug information to go any higher than that in the stack trace.

And now, whoops, I just noticed that since I tried upgrading my 2017 build to a later version of the same year (for probably bad reasons) I now can't build any of it, and probably have to go back to CMake.

I guess I will try going back and installing VS2015 and doing the whole thing again. But any advice re: debugging would be very helpful. For instance, is there anything like pdb files that I need to move around in order to get a full stack trace across the FlightGear and SimGear/OSG projects? I'm an long time VS user but have gaps in my knowledge (to say the least) when it comes to the finer points of debugging.

Cheers,
Chris
chriscalef
 
Posts: 279
Joined: Wed Feb 20, 2013 9:28 pm

Re: New windows build crashes on startup.

Postby chriscalef » Sat Jan 18, 2020 7:23 pm

Here is my whole log file, if that helps:

Code: Select all
    0.00 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:467:Created multi-app mutex, we are in writeable mode
    0.00 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\main.cxx:467:CrashRpt enabled
    0.00 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\main.cxx:494:FlightGear:  Version 2019.2.0
    0.00 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\main.cxx:495:FlightGear:  Build Type Dev
    0.00 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\main.cxx:496:Built with Microsoft Visual C++ version 1914
    0.00 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\main.cxx:498:Jenkins number/ID 0:none
    0.01 [INFO]:gui        :0:Loaded translations for locale "en_US"
    0.01 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\options.cxx:2950:platform default fg_root = Path "../data"
   15.48 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:576:Reading global defaults
   15.49 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:1273:init package root at:Path "C:/Users/Chris Calef/Documents/FlightGear/Aircraft"
   15.49 [INFO]:input      f:\flightgear\fgmeta\flightgear\src\main\options.cxx:2208:No user specified aircraft, using default
   20.65 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:279:Loading aircraft -set file from:Path "F:/FlightGear/fgdata_git/Aircraft/c172p/c172p-set.xml"
   20.70 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\locale.cxx:110:User langauge 0:en-US
   20.70 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\locale.cxx:160:Found language resource for: en
   20.70 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\locale.cxx:298:Reading localized strings for 'en' from Path "F:/FlightGear/fgdata_git/Translations/default/sys.xml"
   20.70 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\locale.cxx:298:Reading localized strings for 'en' from Path "F:/FlightGear/fgdata_git/Translations/default/atc.xml"
   20.70 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\locale.cxx:298:Reading localized strings for 'en' from Path "F:/FlightGear/fgdata_git/Translations/default/tips.xml"
   20.70 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\options.cxx:2538:   option:fg-aircraft = F:\FlightGear\flightgear-fgaddon\Aircraft
   20.70 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\options.cxx:2538:   option:disable-real-weather-fetch =
   20.70 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\options.cxx:2563:Using default download dir: Path "C:/Users/Chris Calef/Documents/FlightGear"
   20.71 [WARN]:general    f:\flightgear\fgmeta\flightgear\src\main\globals.cxx:387:read-allowed path not found:Path "C:/Users/Chris Calef/Documents/FlightGear/AI"
   20.71 [WARN]:general    f:\flightgear\fgmeta\flightgear\src\main\globals.cxx:387:read-allowed path not found:Path "C:/Users/Chris Calef/Documents/FlightGear/Liveries"
   20.71 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\options.cxx:2587:Using default texture cache directory: Path "C:/Users/Chris Calef/Documents/FlightGear/TextureCache"
   20.71 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\options.cxx:2611:Using TerraSync dir: Path "C:/Users/Chris Calef/Documents/FlightGear/TerraSync"
   20.71 [WARN]:general    f:\flightgear\fgmeta\flightgear\src\main\globals.cxx:354:scenery path not found:Path "F:/FlightGear/fgdata_git/Scenery"
   20.71 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\main.cxx:591:EmbeddedResourceManager: selected locale 'en-US'
   20.71 [INFO]:opengl     f:\flightgear\fgmeta\flightgear\src\viewer\fg_os_osgviewer.cxx:366:Using stock OSG implementation of GraphicsWindow
   20.71 [INFO]:astro      f:\flightgear\fgmeta\simgear\simgear\scene\sky\cloud.cxx:343:initializing cloud layers
   20.73 [WARN]:io         f:\flightgear\fgmeta\simgear\simgear\scene\model\modelregistry.cxx:657:Image loading failed:
   20.75 [WARN]:io         f:\flightgear\fgmeta\simgear\simgear\scene\model\modelregistry.cxx:657:Image loading failed:
   20.76 [WARN]:io         f:\flightgear\fgmeta\simgear\simgear\scene\model\modelregistry.cxx:657:Image loading failed:
   20.77 [WARN]:io         f:\flightgear\fgmeta\simgear\simgear\scene\model\modelregistry.cxx:657:Image loading failed:
   20.79 [WARN]:io         f:\flightgear\fgmeta\simgear\simgear\scene\model\modelregistry.cxx:657:Image loading failed:
   20.80 [WARN]:io         f:\flightgear\fgmeta\simgear\simgear\scene\model\modelregistry.cxx:657:Image loading failed:
   20.94 [WARN]:general    f:\flightgear\fgmeta\flightgear\src\main\main.cxx:613:Enabling ATI/AMD viewport hack
   20.94 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:785:Configuration State
   20.94 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:786:============= =====
   20.94 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:788:aircraft-dir = "F:/FlightGear/fgdata_git/Aircraft/c172p"
   20.94 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:789:fghome-dir = "Path "C:/Users/Chris Calef/AppData/Roaming/flightgear.org""
   20.94 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:790:download-dir = "C:/Users/Chris Calef/Documents/FlightGear"
   20.94 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:791:terrasync-dir = "C:/Users/Chris Calef/Documents/FlightGear/TerraSync"
   20.94 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:793:aircraft-search-paths =
   F:/FlightGear/flightgear-fgaddon/Aircraft
   20.94 [INFO]:general    f:\flightgear\fgmeta\flightgear\src\main\fg_init.cxx:794:scenery-search-paths =
   C:/Users/Chris Calef/Documents/FlightGear/TerraSync
   20.97 [WARN]:io         f:\flightgear\fgmeta\simgear\simgear\scene\model\modelregistry.cxx:657:Image loading failed:

chriscalef
 
Posts: 279
Joined: Wed Feb 20, 2013 9:28 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest