Board index FlightGear Support Compiling

After compiling FG I get a runtime error  Topic is solved

Building FlightGear from source, and in the need for help?

After compiling FG I get a runtime error

Postby Necolatis » Thu Aug 29, 2019 2:47 pm

After compiling FG on Windows I get a runtime error:

Image

Anyone got a clue what that might be about?
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1941
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2019.1.2
OS: Windows 10

Re: After compiling FG I get a runtime error

Postby Alant » Thu Aug 29, 2019 10:54 pm

It looks like a difference between zlib versions at compile time and run time. Keep in mind that zlib is a dependency of many pre-built libraries that are used by Flightgear.

Are you using the 3rd party libraries from https://git.code.sf.net/p/flightgear/windows-3rd-party, or some other source?

Also check your Windows path environment in case some version of zlib.dll is in some path that is higher than fgfs.

Alan
Alant
 
Posts: 904
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Re: After compiling FG I get a runtime error  

Postby Necolatis » Fri Aug 30, 2019 3:00 am

Thank you Alant. However it was because I used a new version of QT5. Richard suggested version 5.9.3 and now it works. :)
"Airplane travel is nature's way of making you look like your passport photo."
— Al Gore


Hangar: https://sites.google.com/site/fghangar/
User avatar
Necolatis
 
Posts: 1941
Joined: Mon Oct 29, 2012 12:40 am
Location: EKOD
Callsign: Leto
IRC name: Neco
Version: 2019.1.2
OS: Windows 10


Return to Compiling

Who is online

Users browsing this forum: No registered users and 2 guests