Board index FlightGear Support Compiling

Getting Aeonwave to work

Building FlightGear from source, and in the need for help?

Getting Aeonwave to work

Postby kwanza » Sun Jul 07, 2019 6:46 pm

Has anyone ever got AeonWave to work within a Linux environment? From the source source of FG, it seems to recommend AeonWave over OpenAL, yet I cannot get it to work at all, i.e. there isn't the slightest sound. Instead I get a whole load of errors, such as:
AeonWave Error (sound manager): aaxBufferDestroy: Invalid or NULL handle type at release buffer
:
AeonWave Error (sound manager): aaxEmitterDestroy: Invalid internal state at release buffer
:
AeonWave Error (sound manager): aaxBufferDestroy: Invalid or NULL handle type at release buffer
:
AeonWave Error (sound manager): aaxEmitterDestroy: Invalid internal state at release buffer
:
AeonWave Error (sound manager): aaxBufferDestroy: Invalid or NULL handle type at release buffer
:
AeonWave Error (sound manager): aaxEmitterDestroy: Invalid internal state at release buffer
:
AeonWave Error (sound manager): aaxBufferDestroy: Invalid or NULL handle type at release buffer
:


I had the following packages for Aeonwave installed: aax , aax-utils, aa-support and aax-openal (including their libraries). I also rebuilt both SimGear and FG using these libraries (USE_AOENWAVE and FLITE).

I can get some of the AeonWave utilities to work, e.g. aaxplay. So it does work on its own. The issue appears to be its interaction with SimGear. I have tried the key drivers available ('SDL on pulseaudio: Built-in Audio Stereo' and 'Linux on HDA Intel: ALC1200 Analog') without success. Again, as a stand-alone application, both drivers will work, but not within FG.

Could it be that AeonWave just does not work with FG?

Thanks.
kwanza
 
Posts: 41
Joined: Tue Aug 12, 2008 7:07 am

Return to Compiling

Who is online

Users browsing this forum: No registered users and 2 guests