Board index FlightGear Support Compiling

Running SG/FG tests in Visual Studio

Building FlightGear from source, and in the need for help?

Running SG/FG tests in Visual Studio

Postby Lars » Wed May 29, 2019 2:52 pm

Hi all,
I'm still pretty new to unit and code testing in general . I saw the RUN_TESTS package within the VS project-explorer and also had a look at the code within the FG_SRC/test_suite folder.

But when using the VS "Test Explorer" it cannot find any tests. Is there a trick to run the tests in VS?
Lars
 
Posts: 28
Joined: Mon May 21, 2018 1:01 pm
Location: EDDL
OS: Win 10/Ubuntu 19.04

Re: Running SG/FG tests in Visual Studio

Postby xDraconian » Wed May 29, 2019 7:16 pm

If I recall correctly, compile the RUN_TESTS project. I believe that will trigger the test execution.
xDraconian
 
Posts: 238
Joined: Sun Jan 21, 2018 5:53 am
Version: Git
OS: Linux Mint

Re: Running SG/FG tests in Visual Studio

Postby Lars » Thu May 30, 2019 8:50 am

I already tried this but I'm getting this error message (translated to English):

Error MSB3073 The command "setlocal
S:\cmake\bin\ctest.exe --force-new-ctest-process -C RelWithDebInfo
if %errorlevel% neq 0 goto :cmEnd
:cmEnd
endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
:cmErrorLevel
exit /b %1
:cmDone
if %errorlevel% neq 0 goto :VCEnd
:VCEnd" returned code 8. RUN_TESTS C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets 138
Lars
 
Posts: 28
Joined: Mon May 21, 2018 1:01 pm
Location: EDDL
OS: Win 10/Ubuntu 19.04


Return to Compiling

Who is online

Users browsing this forum: No registered users and 3 guests