Board index FlightGear Support Compiling

CMake issue with Windows, could not find target WinDeps

Building FlightGear from source, and in the need for help?

CMake issue with Windows, could not find target WinDeps

Postby chriscalef » Thu Sep 27, 2018 6:45 am

Hey there, wondering if anyone could provide any insight into the following CMake log, produced on a Win7 system running Visual Studio v.15.7.3:

The C compiler identification is MSVC 19.14.26430.0
The CXX compiler identification is MSVC 19.14.26430.0
Check for working C compiler: F:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.14.26428/bin/Hostx86/x86/cl.exe
Check for working C compiler: F:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.14.26428/bin/Hostx86/x86/cl.exe -- works
Detecting C compiler ABI info
Detecting C compiler ABI info - done
Detecting C compile features
Detecting C compile features - done
Check for working CXX compiler: F:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.14.26428/bin/Hostx86/x86/cl.exe
Check for working CXX compiler: F:/Program Files (x86)/Microsoft Visual Studio/2017/Community/VC/Tools/MSVC/14.14.26428/bin/Hostx86/x86/cl.exe -- works
Detecting CXX compiler ABI info
Detecting CXX compiler ABI info - done
Detecting CXX compile features
Detecting CXX compile features - done
Default install dir set to F:/FlightGear/FlightGear_2018.2.2/flightgear_build/install
CMake Error at F:/Program Files/CMake/share/cmake-3.12/Modules/ExternalProject.cmake:2830 (get_property):
get_property could not find TARGET WinDeps. Perhaps it has not yet been
created.
Call Stack (most recent call first):
F:/Program Files/CMake/share/cmake-3.12/Modules/ExternalProject.cmake:3103 (_ep_add_configure_command)
CMakeLists.txt:84 (ExternalProject_Add)


Configuring incomplete, errors occurred!
See also "F:/FlightGear/FlightGear_2018.2.2/flightgear_build/CMakeFiles/CMakeOutput.log".
chriscalef
 
Posts: 236
Joined: Wed Feb 20, 2013 9:28 pm

Re: CMake issue with Windows, could not find target WinDeps

Postby chriscalef » Sat Nov 03, 2018 2:42 am

Just to respond to my own issue, I did find a fix for this problem, which is to remove the reference to WinDeps from CMakeLists.txt. The offending line looks like this:

Code: Select all
list(APPEND OSG_DEPS WinDeps)


Which is not to say that my build works yet, but at least I'm past that particular problem.
chriscalef
 
Posts: 236
Joined: Wed Feb 20, 2013 9:28 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest