Board index FlightGear Support Compiling

building 2018.2.2 fails

Building FlightGear from source, and in the need for help?

building 2018.2.2 fails

Postby [Lemmy] » Wed Jun 27, 2018 5:30 pm

Hi,

building simgear 2018.2.2 fails on openSUSE Leap 42.3, with the following:

Code: Select all
[   43s] /home/abuild/rpmbuild/BUILD/simgear-2018.2.2/simgear/canvas/elements/CanvasText.cxx:74:12: error: 'void simgear::canvas::Text::TextOSG::computePositions(unsigned int) const' marked 'override', but does not override


Tried GCC 4 and GCC 5, no difference.

Any ideas?

[L]
[Lemmy]
 
Posts: 44
Joined: Mon Jun 18, 2012 7:58 pm

Re: building 2018.2.2 fails

Postby wkitty42 » Wed Jun 27, 2018 5:50 pm

you probably ought to post this on the developer's mailing list... follow the "Mailing Lists" link at the very top of the page, sign up to the developer's list, and write your email message to the list... if you cannot do the mailing list thing, i can post a few messages back and forth to try to get your problem solved but it would be best if you signed up to the list so you could have direct comms with the developers...

FWIW:
    i'm building 2018.3.0 (aka next) on ubuntu 14.04.5 without problems...
    i'm using the download_and_compile.sh script... no idea if it will work on SUSE or not...
    my gcc is 4.8.4...
    my cmake is 3.7.20161029-gcc998...

make sure your simgear and your FG are the same version...


EDIT: oh! what version is your OSG (aka openscenegraph)? i believe that OSG 3.2 is still the minimum FG/SG can be built with... i'm using (self-built with d&c script) OSG 3.4 and looking at possibly updating to 3.6 soon-ish...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 5577
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: building 2018.2.2 fails

Postby [Lemmy] » Wed Jun 27, 2018 5:56 pm

OSG is 3.6.1, should I downgrade to something older?

by the way, here's my build project: https://build.opensuse.org/project/show ... ches:games
[Lemmy]
 
Posts: 44
Joined: Mon Jun 18, 2012 7:58 pm

Re: building 2018.2.2 fails

Postby Richard » Thu Jun 28, 2018 4:29 am

We're currently using OSG 3.4 - http://build.flightgear.org:8080/job/OSG-stable/

Probably using the main build server (as above) as a reference for versions (etc.) is a good idea.
Richard
 
Posts: 700
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: building 2018.2.2 fails

Postby [Lemmy] » Thu Jun 28, 2018 5:05 am

I can't use the "main build server", i have to build on OBS: https://bugzilla.opensuse.org/show_bug.cgi?id=1099288
[Lemmy]
 
Posts: 44
Joined: Mon Jun 18, 2012 7:58 pm

Re: building 2018.2.2 fails

Postby Richard » Thu Jun 28, 2018 9:16 am

I said "as a reference for versions" i.e. to see what we're building - not to specifically use the build server to build your packages.
Richard
 
Posts: 700
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: building 2018.2.2 fails

Postby [Lemmy] » Thu Jun 28, 2018 9:23 am

that's true.
[Lemmy]
 
Posts: 44
Joined: Mon Jun 18, 2012 7:58 pm

Re: building 2018.2.2 fails

Postby zakalawe » Fri Jun 29, 2018 12:47 pm

We need some code fixes to build against OSG 3.6, patches welcome.
zakalawe
 
Posts: 1152
Joined: Sat Jul 19, 2008 4:48 pm
Location: Edinburgh, Scotland
Callsign: G-ZKLW
Version: next
OS: Mac

Re: building 2018.2.2 fails

Postby JinJin » Tue Oct 23, 2018 7:59 pm

:shock:
JinJin
 
Posts: 12
Joined: Sat May 19, 2012 5:36 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest