Board index FlightGear Support Compiling

Problems generating Make file under Windows with CMake  Topic is solved

Building FlightGear from source, and in the need for help?

Problems generating Make file under Windows with CMake

Postby Jarvum » Mon Jun 25, 2018 3:16 pm

Hi all,
I tested around the entire weekend but I didn't get up a correct make file x64 following this tutorial: http://wiki.flightgear.org/Building_usi ... _-_Windows

I use CMake 3.11.4 and the latest VS version.

  • First I set up the folder structure as listed (expect renaming the msvc140-64 folder to msvc141-64 according to the make file for VS2017). There's the first problem that my boost-download (version 1.67.0) doesn't include a lib64 folder (perhaps replaced with the existing libs folder?)) I downloaded and copied the linked OSG and 3rdParty.x64 folder to the mentioned location.
  • After that I started CMake, entered the source folder of the downloaded simgear git repo and a build-output-folder.
  • After clicking on "Configure" and selecting VS 15 2017 Win64 on it's first run it didn't get the MSVC_3RDPARTY_ROOT. I entered the root path there, where the 3rdParty.x64, boost and install folder is located.
  • On a second run it didn't find boost because it is looking for it inside the folder above the MSVC_3RDPARTY_ROOT. As a solution for that I entered the variable "BOOST_ROOT" manual so it finds it (which is suppose shoudn't be like that :wink: )
  • In the next step it isn't able to find AAX INCLUDE_DIR and LIBRARY (is it needed for a "testing" build?) and OpenAL INCLUDE_DIR and LIBRARY. I set the OpenAL Library to 3rdParty.x64/lib/OpenAL32.lib and INCLUDE_DIR, in the hope it is correct, to 3rdParty.x64\include\AL.
  • On the next run it didn't find the OSG related stuff like OSGVIEWER and OSGUTIL (everytime the lib (_debug) and include dir).

Most likely it's my own fault... But after spending around 10-15 hours on this and searching a lot around the forum and wiki (and also looking into the CMakeList.txt) I have no clue what is going wrong.

Does anyone see my failure?

Thanks in advance!
Jarvum
 
Posts: 7
Joined: Mon May 21, 2018 1:01 pm

Re: Problems generating Make file under Windows with CMake  

Postby zakalawe » Mon Jun 25, 2018 3:30 pm

VS2017 isn't fully supported yet, you would need to use the fg-from-scratch script someone is working on. The official builds and windows3rd-party repo are build against VS2015, that's likely why the MSVC_3RDPARTY_ROOT stuff didn't work as expected for you
zakalawe
 
Posts: 1149
Joined: Sat Jul 19, 2008 4:48 pm
Location: Edinburgh, Scotland
Callsign: G-ZKLW
Version: next
OS: Mac


Return to Compiling

Who is online

Users browsing this forum: No registered users and 2 guests