Board index FlightGear Support Compiling

CMake warning at end of compilation: runtime library hidden?

Building FlightGear from source, and in the need for help?

CMake warning at end of compilation: runtime library hidden?

Postby iandmacp » Thu Nov 02, 2017 1:10 pm

Hi Everyone

I've been compiling Flightgear 2017.3.1 from the sources on GitHub and so far so good however I've run into a bit of a wall. After installing all the -dev type packages cmake asked for I have ended up with an error at the end of the process as follows:



CMake Warning at src/Main/CMakeLists.txt:96 (add_executable):
Cannot generate a safe runtime search path for target fgfs because files in
some directories may conflict with libraries in implicit directories:

runtime library [libGL.so.1] in /usr/lib64 may be hidden by files in:
/usr/X11R6/lib64
runtime library [libEGL.so.1] in /usr/lib64 may be hidden by files in:
/usr/X11R6/lib64

Some of these libraries may not be found correctly.



The section referenced by the file in the above message (src/Main/CMakeLists.txt:96) is as follows:


# important we pass WIN32 here so the console is optional. Other
# platforms ignore this option. If a console is needed we allocate
# it manually via AllocConsole()
# similarly pass MACOSX_BUNDLE so we generate a .app on Mac

add_executable(fgfs WIN32 MACOSX_BUNDLE
${SOURCES} ${FG_SOURCES} ${FG_HEADERS} ${HEADERS})

#-----------------------------------------------------------------------------
# MacOSX bundle packagaing




My operating system is openSUSE Leap 42.3 x86_64
My hardware Intel Core2 Duo with GTX 750Ti nvidia graphics card

Full output of CMake ....

linux:/home/ian/fgstuff/flightgearbuild # cmake ../flightgear-release-2017.3 -DCMAKE_BUILD_TYPE=Release
CMAKE Build type: Release
-- System is: Linux
-- Linux distro is: openSUSE project
-- Web browser launcher command is: xdg-open
-- Using explicit data directory for base package: /usr/local/lib/FlightGear
-- libudev stable: 1
-- Found UDev: /usr/lib64/libudev.so
-- include: /usr/include
fatal: Not a git repository: '/home/ian/fgstuff/flightgear-release-2017.3/.git'
-- Git revision is
-- Boost version: 1.54.0
-- Using DBus
-- Qt launcher enabled, checking for Qt 5.1 / qmake
-- Will enable Qt launcher GUI
-- Qt5Widgets version: 5.6.2
-- Qt5Widgets include dir: /usr/include/qt5/;/usr/include/qt5/QtWidgets;/usr/include/qt5/QtGui;/usr/include/qt5/QtCore;/usr/lib64/qt5//mkspecs/linux-g++;/usr/include
-- /usr/include
-- adding runtime JS dependencies
-- Min Simgear version is 2017.3.0
-- RTI: DISABLED
-- OpenMP: DISABLED
-- SSE/SSE2 support: ENABLED
-- found GLUT inc /usr/include, lib /usr/lib64/libglut.so;/usr/lib64/libXmu.so;/usr/lib64/libXi.so
-- Tests: ENABLED
-- Configuring done
CMake Warning at src/Main/CMakeLists.txt:96 (add_executable):
Cannot generate a safe runtime search path for target fgfs because files in
some directories may conflict with libraries in implicit directories:

runtime library [libGL.so.1] in /usr/lib64 may be hidden by files in:
/usr/X11R6/lib64
runtime library [libEGL.so.1] in /usr/lib64 may be hidden by files in:
/usr/X11R6/lib64

Some of these libraries may not be found correctly.


-- Generating done
-- Build files have been written to: /home/ian/fgstuff/flightgearbuild


Any comments welcome including the "fatal" git error which seems redundant because it is building from a local source tree not a repository.

Thanks in advance ...

Ian
iandmacp
 
Posts: 12
Joined: Tue Feb 25, 2014 10:41 am

Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest