Board index FlightGear Support Compiling

Compile 17.4 with Linux MINT 18.2

Building FlightGear from source, and in the need for help?

Compile 17.4 with Linux MINT 18.2

Postby abassign » Mon Oct 02, 2017 8:09 am

I have a machine with Linux MINT 18.2, I try install the last FGFS version (17.4 experimental) by "download_and_compile.sh" script, but the compile not work properly end return this error code. I think that the problem is relative to QT5 library, but I don't know where put my hands.
The half September compilation of 17.4 version with the same machine, work properly.

This is the error code:

Code: Select all
Building CXX object src/GUI/CMakeFiles/fglauncher.dir/qrc_resources.cpp.o
/media/lab_risv01/Salvataggi/backup/fgfs/flightgear/src/GUI/FlickableExtentQuery.cxx:3:47: fatal error: QtQuick/private/qquickflickable_p.h: File o directory non esistente
compilation terminated.
src/GUI/CMakeFiles/fglauncher.dir/build.make:839: set di istruzioni per l'obiettivo "src/GUI/CMakeFiles/fglauncher.dir/FlickableExtentQuery.cxx.o" non riuscito
make[2]: *** [src/GUI/CMakeFiles/fglauncher.dir/FlickableExtentQuery.cxx.o] Errore 1
make[2]: *** Attesa per i processi non terminati....
CMakeFiles/Makefile2:2374: set di istruzioni per l'obiettivo "src/GUI/CMakeFiles/fglauncher.dir/all" non riuscito
make[1]: *** [src/GUI/CMakeFiles/fglauncher.dir/all] Errore 2


Thank for your collaboration :)
abassign
 
Posts: 745
Joined: Mon Feb 27, 2012 5:09 pm
Location: Italy (living 5 Km from airport LIME)
Callsign: I-BASSY
Version: 2018.3
OS: Linux Mint 19. x

Re: Compile 17.4 with Linux MINT 18.2

Postby biloute974 » Mon Oct 02, 2017 8:41 am

Hi,

Try To install qtdeclarative5-private-dev first.
Code: Select all
sudo apt get install qtdeclarative5-private-dev


After, retry your compil.
Intel I7 7700 - 16Gb DDR4 - Nvidia GTX970 - FG 2017.4.0 from D&C
biloute974
 
Posts: 180
Joined: Mon Feb 23, 2015 8:49 am
Callsign: U974
Version: 2016.1.0
OS: Mint 17.2

Re: Compile 17.4 with Linux MINT 18.2

Postby abassign » Mon Oct 02, 2017 11:48 am

biloute974 wrote in Mon Oct 02, 2017 8:41 am:Hi,

Try To install qtdeclarative5-private-dev first.
Code: Select all
sudo apt-get install qtdeclarative5-private-dev


After, retry your compil.


Thank, I try it, is work ok :)
abassign
 
Posts: 745
Joined: Mon Feb 27, 2012 5:09 pm
Location: Italy (living 5 Km from airport LIME)
Callsign: I-BASSY
Version: 2018.3
OS: Linux Mint 19. x

Re: Compile 17.4 with Linux MINT 18.2

Postby biloute974 » Mon Oct 02, 2017 12:22 pm

;)
Intel I7 7700 - 16Gb DDR4 - Nvidia GTX970 - FG 2017.4.0 from D&C
biloute974
 
Posts: 180
Joined: Mon Feb 23, 2015 8:49 am
Callsign: U974
Version: 2016.1.0
OS: Mint 17.2

Re: Compile 17.4 with Linux MINT 18.2

Postby abassign » Mon Oct 16, 2017 7:16 am

To morrow (October 16 2017) I try to compile the 17.4 version, but I found this surprise:

Code: Select all
[ 50%] Building CXX object src/Main/CMakeFiles/fgfs.dir/main.cxx.o
[ 50%] Building CXX object src/Main/CMakeFiles/fgfs.dir/options.cxx.o
[ 50%] Building CXX object src/Main/CMakeFiles/fgfs.dir/__/EmbeddedResources/FlightGear-resources.cxx.o
[ 50%] Building CXX object src/Main/CMakeFiles/fgfs.dir/__/GUI/FGPUIDialog.cxx.o
[ 50%] Building CXX object src/Main/CMakeFiles/fgfs.dir/__/GUI/new_gui.cxx.o
/media/lab_risv01/Salvataggi/backup/fgfs/flightgear/src/GUI/new_gui.cxx: In member function ‘virtual void NewGUI::setStyle()’:
/media/lab_risv01/Salvataggi/backup/fgfs/flightgear/src/GUI/new_gui.cxx:419:8: error: ‘class SGPropertyNode’ has no member named ‘copy’
     n->copy(selected_style);
        ^
src/Main/CMakeFiles/fgfs.dir/build.make:2590: set di istruzioni per l'obiettivo "src/Main/CMakeFiles/fgfs.dir/__/GUI/new_gui.cxx.o" non riuscito
make[2]: *** [src/Main/CMakeFiles/fgfs.dir/__/GUI/new_gui.cxx.o] Errore 1
make[2]: *** Attesa per i processi non terminati....
CMakeFiles/Makefile2:3318: set di istruzioni per l'obiettivo "src/Main/CMakeFiles/fgfs.dir/all" non riuscito
make[1]: *** [src/Main/CMakeFiles/fgfs.dir/all] Errore 2
Makefile:149: set di istruzioni per l'obiettivo "all" non riuscito
make: *** [all] Errore 2
[  0%] Built target fgsqlite3
[  8%] Built target iaxclient_lib


I use the Linux Mint 18.2 with download_and_compile.sh, I want to know if some programmer know the problem and the relative solution.

Thank for the collaboration :)
abassign
 
Posts: 745
Joined: Mon Feb 27, 2012 5:09 pm
Location: Italy (living 5 Km from airport LIME)
Callsign: I-BASSY
Version: 2018.3
OS: Linux Mint 19. x

Re: Compile 17.4 with Linux MINT 18.2

Postby FlugHund » Mon Oct 16, 2017 7:41 am

/me thinks the script should use LANG=C
User avatar
FlugHund
 
Posts: 500
Joined: Thu Mar 01, 2007 3:27 pm
Callsign: D-HUND
IRC name: D-HUND / debdog
Version: next
OS: Devuan

Re: Compile 17.4 with Linux MINT 18.2

Postby abassign » Mon Oct 16, 2017 8:56 am

FlugHund wrote in Mon Oct 16, 2017 7:41 am:/me thinks the script should use LANG=C


Where put the switch: "LANG=C" ?

This is the compile script for FGFS:

Code: Select all
#######################################################
# FGFS
#######################################################
FGFS_INSTALL_DIR=flightgear
INSTALL_DIR_FGFS=$INSTALL_DIR/$FGFS_INSTALL_DIR
cd "$CBD"
if [[ "$(declare -p WHATTOBUILD)" =~ '['([0-9]+)']="FGFS"' || "$(declare -p WHATTOBUILD)" =~ '['([0-9]+)']="DATA"' ]]; then
  echo "****************************************" | tee -a $LOGFILE
  echo "************** FLIGHTGEAR **************" | tee -a $LOGFILE
  echo "****************************************" | tee -a $LOGFILE

  mkdir -p "flightgear"
  cd "$CBD"/flightgear

  if [[ "$(declare -p WHATTOBUILD)" =~ '['([0-9]+)']="FGFS"' ]]; then
    _gitDownload https://git.code.sf.net/p/flightgear/flightgear
    _gitUpdate $FGVERSION

    if [ "$RECONFIGURE" = "y" ]; then
      cd "$CBD"
      mkdir -p build/flightgear
      cd "$CBD"/build/flightgear
      rm -f CMakeCache.txt
      "$CMAKE" -DCMAKE_BUILD_TYPE="$BUILD_TYPE" \
            -DENABLE_FLITE=ON \
            -DCMAKE_INSTALL_PREFIX:PATH="$INSTALL_DIR_FGFS" \
            -DCMAKE_PREFIX_PATH="$INSTALL_DIR_SIMGEAR;$INSTALL_DIR_OSG;$INSTALL_DIR_OPENRTI;$INSTALL_DIR_PLIB" \
            $FG_CMAKEARGS \
            ../../flightgear 2>&1 | tee -a $LOGFILE
    fi

    _make flightgear
  fi

  mkdir -p $INSTALL_DIR_FGFS/fgdata
  cd $INSTALL_DIR_FGFS/fgdata
abassign
 
Posts: 745
Joined: Mon Feb 27, 2012 5:09 pm
Location: Italy (living 5 Km from airport LIME)
Callsign: I-BASSY
Version: 2018.3
OS: Linux Mint 19. x

Re: Compile 17.4 with Linux MINT 18.2

Postby ctesc356 » Mon Oct 16, 2017 1:43 pm

Hello,
I have the same error as abassign
/fgfs/flightgear/src/GUI/new_gui.cxx:419:8: error: ‘class SGPropertyNode’ has no member named ‘copy’
n->copy(selected_style);
^

I also do not understand the proposal of FlugHund

Apparently the error comes from the last changes in "new_gui.cxx"
I commented on lines 417 and 419 (//) and the compilation is going well.

compilation by d & c script.
ctesc356
 
Posts: 45
Joined: Wed Aug 25, 2010 8:20 am

Re: Compile 17.4 with Linux MINT 18.2

Postby wkitty42 » Mon Oct 16, 2017 1:57 pm

leave LANG alone... the script generally works quite well... this looks more like a missing library or update... specifically, SG means simgear and you should always update simgear, flightgear and fgdata when you build... they need to be the same level or you will have mismatching code in some cases... so, update your simgear repo and build again...

FWIW: i (basically) always run the d&c script as

dnc SIMGEAR FGFS DATA

and even wrote a script to handle it all for me...

[EDIT]

i will also confirm this specific problem... i'm on ubuntu trusty (14.04.5)... looks like someone maybe forgot to push an update to a file... i'm passing this on to the dev list since i don't see anything from anyone else about it, yet...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4895
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Compile 17.4 with Linux MINT 18.2

Postby abassign » Mon Oct 16, 2017 4:17 pm

I remove the precedent compilation and I restart the command "download_and_compile.sh", but but there is always the same problem :(
It's definitely possible to comment the two lines that make the mistake ... ;) but I think it's better to fix it.
abassign
 
Posts: 745
Joined: Mon Feb 27, 2012 5:09 pm
Location: Italy (living 5 Km from airport LIME)
Callsign: I-BASSY
Version: 2018.3
OS: Linux Mint 19. x

Re: Compile 17.4 with Linux MINT 18.2

Postby ctesc356 » Mon Oct 16, 2017 5:00 pm

abassign wrote in Mon Oct 16, 2017 4:17 pm: but I think it's better to fix it.

I also think
It was just to identify the problem
ctesc356
 
Posts: 45
Joined: Wed Aug 25, 2010 8:20 am

Re: Compile 17.4 with Linux MINT 18.2

Postby Richard » Mon Oct 16, 2017 6:53 pm

/fgfs/flightgear/src/GUI/new_gui.cxx:419:8: error: ‘class SGPropertyNode’ has no member named ‘copy’
n->copy(selected_style);
^


This one is my fault - I forgot a simgear push (which I've now done). sorry for the inconvenience.
Richard
 
Posts: 646
Joined: Sun Nov 02, 2014 10:17 pm
Version: Git
OS: Win10

Re: Compile 17.4 with Linux MINT 18.2

Postby abassign » Mon Oct 16, 2017 7:10 pm

Richard wrote in Mon Oct 16, 2017 6:53 pm:
/fgfs/flightgear/src/GUI/new_gui.cxx:419:8: error: ‘class SGPropertyNode’ has no member named ‘copy’
n->copy(selected_style);
^


This one is my fault - I forgot a simgear push (which I've now done). sorry for the inconvenience.



No problem, thank for all :)
abassign
 
Posts: 745
Joined: Mon Feb 27, 2012 5:09 pm
Location: Italy (living 5 Km from airport LIME)
Callsign: I-BASSY
Version: 2018.3
OS: Linux Mint 19. x

Re: Compile 17.4 with Linux MINT 18.2

Postby wkitty42 » Mon Oct 16, 2017 7:18 pm

looks like that got it... thanks, Richard! i can confirm that FG builds all the way through, now... i hadn't seen anything on the dev list or in the commit list but i did pull something in simgear...

Code: Select all
********** 2017-10-16 15:16:29 **********
********** Total elapsed update and compile time is 0 days 0 hours 6 minutes 38 seconds **********

PLib:    a542b8a03f8de1fe844af6ab4734b64d11e272e9
OSG 3.4: cb2b0a5fe84bf862613b46432226a0201005fced
Simgear: 7be1fcc32e4bfa7e48bd143ecee778b69afa85ee
FGFS:    9d590feaf3abf3936098c2b291eba6de81bd1c90
FGData:  a7d0c9ccd7c9195575382f85baa717a7b8684814
FGAddon: r3052 | forgolai | 2017-10-15 20:29:41 -0400 (Sun, 15 Oct 2017)
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 4895
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 14.04.5

Re: Compile 17.4 with Linux MINT 18.2

Postby abassign » Mon Nov 13, 2017 5:45 pm

Now (nov 13 2017) I try to compile 17.4 FGFS version in the Linux Mint 18.2 PC, but something go bad:

Code: Select all
****************************************
************** FLIGHTGEAR **************
****************************************
https://git.code.sf.net/p/flightgear/flightgear exists already
Current branch next is up to date.
Si è già su 'next'
Your branch is up-to-date with 'origin/next'.
CMAKE Build type: RelWithDebInfo
-- Setting build type to 'Dev' as none was specified.
-- System is: Linux
-- Linux distro is: LinuxMint
-- Web browser launcher command is: xdg-open
-- Using default data directory for base package:  /media/lab_risv01/Salvataggi/backup/fgfs/install/flightgear/lib/FlightGear
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- libudev stable: 1
-- Found UDev: /usr/lib/x86_64-linux-gnu/libudev.so
--    include: /usr/include
-- Found Git: /usr/bin/git 
-- Git revision is 2bf5a96aec3ca758d5f37e31a8815554460003e3
-- event-based input enabled. Using /usr/lib/x86_64-linux-gnu/libudev.so
-- Boost version: 1.58.0
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so 
-- Found osgText: /usr/local/lib64/libosgText.so 
-- Found osgSim: /usr/local/lib64/libosgSim.so 
-- Found osgDB: /usr/local/lib64/libosgDB.so 
-- Found osgParticle: /usr/local/lib64/libosgParticle.so 
-- Found osgFX: /usr/local/lib64/libosgFX.so 
-- Found osgUtil: /usr/local/lib64/libosgUtil.so 
-- Found osgViewer: /usr/local/lib64/libosgViewer.so 
-- Found osgGA: /usr/local/lib64/libosgGA.so 
-- Found osg: /usr/local/lib64/libosg.so 
-- Found OpenThreads: /usr/local/lib64/libOpenThreads.so 
-- Found OpenSceneGraph: /usr/local/lib64/libosgText.so;/usr/local/lib64/libosgSim.so;/usr/local/lib64/libosgDB.so;/usr/local/lib64/libosgParticle.so;/usr/local/lib64/libosgFX.so;/usr/local/lib64/libosgUtil.so;/usr/local/lib64/libosgViewer.so;/usr/local/lib64/libosgGA.so;/usr/local/lib64/libosg.so;/usr/local/lib64/libOpenThreads.so (found suitable version "3.4.1", minimum required is "3.2.0")
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1")
-- Checking for module 'dbus-1'
--   Found dbus-1, version 1.10.6
-- Using DBus
-- Qt launcher enabled, checking for Qt 5.4 / qmake
-- Will enable Qt launcher GUI
--   Qt5Widgets version: 5.6.1
--   Qt5Widgets include dir: /usr/include/x86_64-linux-gnu/qt5/;/usr/include/x86_64-linux-gnu/qt5/QtWidgets;/usr/include/x86_64-linux-gnu/qt5/QtGui;/usr/include/x86_64-linux-gnu/qt5/QtCore;/usr/lib/x86_64-linux-gnu/qt5//mkspecs/linux-g++-64;/usr/include
-- Checking whether private include directories for module Qt5Gui exist
CMake Error at CMakeLists.txt:323 (message):
  The private include directory /usr/include/x86_64-linux-gnu/qt5/QtGui/5.6.1
  for module Qt5Gui do not exist! Please make sure your Qt5 installation
  contains private headers.


The last week the compilation go well.
I try on another PC with Kubuntu/Ubuntu 17.10, the compilation go well ...
I want to understand the problem, is strange ...
abassign
 
Posts: 745
Joined: Mon Feb 27, 2012 5:09 pm
Location: Italy (living 5 Km from airport LIME)
Callsign: I-BASSY
Version: 2018.3
OS: Linux Mint 19. x

Next

Return to Compiling

Who is online

Users browsing this forum: No registered users and 3 guests