Board index FlightGear Support Compiling

terragear wont build

Building FlightGear from source, and in the need for help?

terragear wont build

Postby www2 » Sun Sep 04, 2016 11:11 am

Hi i have a problem with terraear (latest git) that won't build on ubuntu 16.04.


Code: Select all
[ 97%] Linking CXX executable tg-construct
CMakeFiles/tg-construct.dir/tgconstruct_output.cxx.o: In function `TGConstruct::AddCustomObjects()':
/home/jean-paul/fgfs/terragear/src/BuildTiles/Main/tgconstruct_output.cxx:45: undefined reference to `SGPath::str_native[abi:cxx11]() const'
/home/jean-paul/fgfs/terragear/src/BuildTiles/Main/tgconstruct_output.cxx:49: undefined reference to `SGPath::str_native[abi:cxx11]() const'
/home/jean-paul/fgfs/terragear/src/BuildTiles/Main/tgconstruct_output.cxx:73: undefined reference to `SGPath::str_native[abi:cxx11]() const'
/home/jean-paul/fgfs/terragear/src/BuildTiles/Main/tgconstruct_output.cxx:95: undefined reference to `SGPath::str_native[abi:cxx11]() const'
collect2: error: ld returned 1 exit status
src/BuildTiles/Main/CMakeFiles/tg-construct.dir/build.make:538: recept voor doel 'src/BuildTiles/Main/tg-construct' is mislukt
make[2]: *** [src/BuildTiles/Main/tg-construct] Fout 1
CMakeFiles/Makefile2:1125: recept voor doel 'src/BuildTiles/Main/CMakeFiles/tg-construct.dir/all' is mislukt
make[1]: *** [src/BuildTiles/Main/CMakeFiles/tg-construct.dir/all] Fout 2
Makefile:149: recept voor doel 'all' is mislukt
make: *** [all] Fout 2
[ 14%] Built target terragear
[ 16%] Built target gdalchop
[ 20%] Built target HGT
[ 22%] Built target srtmchop
[ 24%] Built target Array
[ 26%] Built target fillvoids
[ 28%] Built target DEM
[ 30%] Built target demchop
[ 32%] Built target hgtchop
[ 34%] Built target testassem
[ 43%] Built target Terra
[ 48%] Built target terra_bin
[ 50%] Built target terrafit
[ 52%] Built target ogr-decode
[ 54%] Built target test_array
[ 56%] Built target landcover
[ 58%] Built target test_landcover
[ 78%] Built target genapts850
[ 80%] Linking CXX executable tg-construct
CMakeFiles/tg-construct.dir/tgconstruct_output.cxx.o: In function `TGConstruct::AddCustomObjects()':
/home/jean-paul/fgfs/terragear/src/BuildTiles/Main/tgconstruct_output.cxx:45: undefined reference to `SGPath::str_native[abi:cxx11]() const'
/home/jean-paul/fgfs/terragear/src/BuildTiles/Main/tgconstruct_output.cxx:49: undefined reference to `SGPath::str_native[abi:cxx11]() const'
/home/jean-paul/fgfs/terragear/src/BuildTiles/Main/tgconstruct_output.cxx:73: undefined reference to `SGPath::str_native[abi:cxx11]() const'
/home/jean-paul/fgfs/terragear/src/BuildTiles/Main/tgconstruct_output.cxx:95: undefined reference to `SGPath::str_native[abi:cxx11]() const'
collect2: error: ld returned 1 exit status
src/BuildTiles/Main/CMakeFiles/tg-construct.dir/build.make:538: recept voor doel 'src/BuildTiles/Main/tg-construct' is mislukt
make[2]: *** [src/BuildTiles/Main/tg-construct] Fout 1
CMakeFiles/Makefile2:1125: recept voor doel 'src/BuildTiles/Main/CMakeFiles/tg-construct.dir/all' is mislukt
make[1]: *** [src/BuildTiles/Main/CMakeFiles/tg-construct.dir/all] Fout 2
Makefile:149: recept voor doel 'all' is mislukt
make: *** [all] Fout 2
www2
 
Posts: 223
Joined: Thu Apr 16, 2009 1:58 pm

Re: terragear wont build

Postby elgaton » Sun Sep 04, 2016 2:41 pm

Just to confirm, are you also building SimGear from source?

(Also, the master branch of TerraGear is meant only for development purposes; to build scenery, you should use the "ws2.0" branch.)
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: terragear wont build

Postby www2 » Sun Sep 04, 2016 2:57 pm

elgaton wrote in Sun Sep 04, 2016 2:41 pm:Just to confirm, are you also building SimGear from source?

(Also, the master branch of TerraGear is meant only for development purposes; to build scenery, you should use the "ws2.0" branch.)

I use the "ws2.0" branch
www2
 
Posts: 223
Joined: Thu Apr 16, 2009 1:58 pm

Re: terragear wont build

Postby psadro_gm » Tue Sep 06, 2016 1:24 pm

This is probably due to James' work in simgear to properly handle SGPath encoding.
I haven't been keeping terragear up to date as of late, as I am still experimenting with Torsten and Thorsten's experimental scenery. I'll try to take a look this week.

Pete
8.50 airport parser, textured roads and streams...
psadro_gm
 
Posts: 750
Joined: Thu Aug 25, 2011 2:23 am
Location: Atlanta, GA USA
IRC name: psadro_*
Version: git
OS: Fedora 21

Re: terragear wont build

Postby mffly » Sat Sep 24, 2016 11:21 pm

Hello, my first post.
First off, I'd like to thank all of you that have anything to do with flightgear development for your passion and hard work... believe me, I know, although it's rewarding, it's certainly not always easy.

I'm not actually replying to this post, but re-asking, as I too have this exact same problem when trying to build Terragear.

My main development virtual machine,
Ubuntu 16.04.2,
gcc 5.4.0 cross compiler

I started out using ws2.0 'users version', and have now changed to pull request '082ee9b82f15c8067183925a2ce48da817fa3748'.

.Now I'm having the same problem as www2:
tgconstruct_output.cxx:45: undefined reference to `SGPath::str_native[abi:cxx11]() const' (4 places, all in 'tgconstruct_output.cxx'

I added different variations of '#include <simgear/misc/sg_path.hxx>', but I believe it's missing an object/lib file at link time. Possibly a simple mis-configured Cmake?

Anyway, I'm not yet famirilar enough with any of this to track down errors. If anyone knows of a different git branch and/or a modified CMake, or anything to allow Terragear to build, I sure would appreciate it.

PS:
I don't mean this in a sarcastic way, but it appears there's been very little attention payed to the 'users' version of Terragear in the last couple of years,or so. I get the feeling that you all want a much better version of Terragear before lot's of 'normal users' begin using this on a large scale...

I certainly don' mind helping debug/improve the software (once I can get it built and actually start playing around with it). But would I be better off just waiting until you all release a brand new version sometime in future? Please be honest.

Thank you very much,
Hal 'Spud' Williams
mffly
 
Posts: 1
Joined: Sat Sep 24, 2016 4:08 pm

Re: terragear wont build

Postby psadro_gm » Fri Oct 07, 2016 11:52 am

Terragear was never meant as a 'users' tool. It was designed to generate world scenery ( the whole planet at once ), not individual custom scenery locations.
That said, there have been some ( mostly unsuccessful ) attempts to make it more user friendly. We will see how far the new scenery experiments get us. If it shows enough promise, perhaps it will become the way forward, and terragear will mostly disappear. QGIS or GRASS, along with a few scripts will all that you would need to generate custom scenery, then.

Pete
8.50 airport parser, textured roads and streams...
psadro_gm
 
Posts: 750
Joined: Thu Aug 25, 2011 2:23 am
Location: Atlanta, GA USA
IRC name: psadro_*
Version: git
OS: Fedora 21

Re: terragear wont build

Postby tlwest446 » Mon Oct 24, 2016 1:41 pm

Having the same problem as the other 2, exactly the same undefined reference. As a new scenery designer trying to update local airports in northern Illinois, USA, I would like to test my revisions before submitting them to Robin's system. I am not yet confident enough of my skills to just send the WorldEditor output without checking it by flying, or at least taxiing the revised layouts. All the info I have seen requires genapts to be able to do that, and to get genapts requires building terragear. Am I missing something? is there another way?
tlwest446
 
Posts: 1
Joined: Sun Sep 04, 2016 2:47 am

Re: terragear wont build

Postby elgaton » Sun Dec 04, 2016 3:25 pm

Just a heads up for those that are still interested in this issue - I have developed a fix.

Right now, I am testing it on my machine to check if everything runs correctly. If my tests are successful, I'll submit a pull request for the ws2.0 branch.
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1107
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest