Board index FlightGear Support Compiling

can't make flightgear work form git

Building FlightGear from source, and in the need for help?

can't make flightgear work form git

Postby lomar » Wed Jan 06, 2016 2:12 pm

well, i installed the latest fgdata from git, but when i try to launch i get the following message:

Code: Select all
Version check failed: please check your installation
Found data files for version '2016.1.0 at C:/program Files/flighgear/data, version 3.4.1 is required


what can i do to solve this?
lomar
 
Posts: 276
Joined: Mon Jun 30, 2014 1:38 am
Location: Rio de Janeiro, Brazil
Callsign: lomar
Version: nightly
OS: win 10

Re: can't make flightgear work form git

Postby Hooray » Wed Jan 06, 2016 2:23 pm

update simgear, flightgear and fgdata - rebuild everything in order
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12090
Joined: Tue Mar 25, 2008 8:40 am

Re: can't make flightgear work form git

Postby lomar » Wed Jan 06, 2016 2:45 pm

and what do i need to do to rebuild this?
sorry, but i have never installed FG this way, so i need some help
lomar
 
Posts: 276
Joined: Mon Jun 30, 2014 1:38 am
Location: Rio de Janeiro, Brazil
Callsign: lomar
Version: nightly
OS: win 10

Re: can't make flightgear work form git

Postby Hooray » Wed Jan 06, 2016 2:57 pm

Then you have quite a bit of reading to do (see the wiki for details).

Unfortunately, there isn't much more that I can tell you, because you didn't tell us how you obtained/installed/built FlightGear - i.e. how to proceed from here depends entirely on your way of installing FlightGear.

But basically you are trying to use a base package in conjunction with binaries that are meanwhile outdated.

Currently, that is not even critical, i.e. easy to work around by editing the version file to revert those changes - but you will almost certainly want to update sg/fg instead of doing that.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12090
Joined: Tue Mar 25, 2008 8:40 am

Re: can't make flightgear work form git

Postby elgaton » Wed Jan 06, 2016 2:59 pm

The best option would be downloading the new nightly build from download.flightgear.org (assuming you install FG from there).

An explanation of what happened: FG changed version number; specifically, we went from 3.7 to 2016.1.0. The version number is hardcoded in FlightGear as well as in FGData. Whenever the simulator is run, it checks whether those numbers match, so that you won't experience problems caused by incompatibilities between old FG versions/new FGData or vice versa.
In your case, you probably had an older nightly build installed/built (which had version 3.7 hardcoded in). By pulling yesterday's FGData, you pulled in the change in version number as well, so that FG will now - legitimately - refuse to start due to the mismatch. The latest nightly FG build on the build server should fix the problem.

As an alternative, if you have Visual Studio installed, you can do what Hooray suggested (rebuild FlightGear from source).
NIATCA 2nd admin, regular ATC at LIPX and creator of the LIPX custom scenery
elgaton
 
Posts: 1106
Joined: Tue Mar 19, 2013 4:58 pm
Callsign: I-ELGA/LIPX_TW
Version: Git
OS: Windows + Arch Linux

Re: can't make flightgear work form git

Postby FlugHund » Wed Jan 06, 2016 3:01 pm

On a quick glance it seems you've compiled SG/FG 3.4.1 but did not switch to fgdata's 3.4.x branch:
Code: Select all
git checkout origin/release/3.4.0
User avatar
FlugHund
 
Posts: 550
Joined: Thu Mar 01, 2007 3:27 pm
Callsign: D-HUND
IRC name: D-HUND / debdog
Version: next
OS: Devuan

Re: can't make flightgear work form git

Postby legoboyvdlp » Wed Jan 06, 2016 3:23 pm

It looks like he actually has 3.4.1 FlightGear, but 2016.1.0 FGDATA.


Not going to work...
:)
User avatar
legoboyvdlp
 
Posts: 7849
Joined: Sat Jul 26, 2014 1:28 am
Location: Northern Ireland
Callsign: G-LEGO
Version: next
OS: Windows 10 HP

Re: can't make flightgear work form git

Postby Alant » Wed Jan 06, 2016 4:35 pm

The version numbers have only just been updated. It seems that the OP did his last git update during the version number change. All that is needed is a fresh git pull of simgear, flightgear and fgdata, followed by cmake and compile and install of simgear , then cmake and compile and install flightgear to get everything back in sync.

All is in order here.
Alant
 
Posts: 1026
Joined: Wed Jun 23, 2010 5:58 am
Location: Portugal
Callsign: Tarnish99
Version: from Git
OS: Windows 10

Re: can't make flightgear work form git

Postby lomar » Wed Jan 06, 2016 5:20 pm

well, i downloaded the latest binaries and it worked. thanks everyone for the help :) !!!!!
lomar
 
Posts: 276
Joined: Mon Jun 30, 2014 1:38 am
Location: Rio de Janeiro, Brazil
Callsign: lomar
Version: nightly
OS: win 10


Return to Compiling

Who is online

Users browsing this forum: No registered users and 2 guests