Board index FlightGear Support Compiling

Tonight I can not update the 3.7 :(

Building FlightGear from source, and in the need for help?

Re: Tonight I can not update the 3.7 :(

Postby Hooray » Sat Jan 09, 2016 4:57 pm

@abassign: I happen to agree with Thorsten and Torsten on this one, the RSS feeds can be found on sourceforge, e.g. using the wiki template: http://wiki.flightgear.org/Template:Commit_log

Also, please don't get this wrong (no offense intended or taken), but all this complaining is kinda pointless and also proving that we were right in the other thread, i.e. if you cannot fix such trivial cmake-level issues yourself (even if just by disabling the offending tests), you are unlikely to succeed at "implementing Python support in FlightGear" (as per FGPython an propose for Python as an nasal alternative), because you would have to do quite a bit of reading/learning to understand more about cmake and C++ before you should even consider commenting on replacing existing subsystems in SimGear/FlightGear.

I am just saying this so clearly, because you put quite a bit of energy into your postings/drawings in that other thread, to make us believe that you were serious about that, and at least bugman and myself offered our support and help to get you started with all this - and apparently, you are not even remotely in a position to deal with trivial build issues, which tells us that you should not have made certain (all) postings in the other thread, i.e. you were not just wasting your own time, but also our's. So if you were serious about wanting Python in FlightGear, you would ensure that we allocate our time better, to ensure that our postings actually bear fruits.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12090
Joined: Tue Mar 25, 2008 8:40 am

Re: Tonight I can not update the 3.7 :(

Postby dutchguy » Sat Jan 09, 2016 6:24 pm

I can confirm that it builds correctly now. Thanks for the fix!
dutchguy
 
Posts: 108
Joined: Mon Mar 31, 2014 4:16 pm

Re: Tonight I can not update the 3.7 :(

Postby Amarildojr » Tue Jan 12, 2016 9:47 pm

dutchguy wrote in Sat Jan 09, 2016 6:24 pm:I can confirm that it builds correctly now. Thanks for the fix!

Could you confirm that it's NOT working now? :P A simple SIMGEAR compile at a random folder, doesn't work. I'll look more into this. I thought Stable wouldn't suffer from Next's problems.
Amarildojr
 
Posts: 94
Joined: Sat Jan 02, 2016 10:32 pm
Location: Basil
Callsign: TAM91
OS: Arch Linux

Re: Tonight I can not update the 3.7 :(

Postby wkitty42 » Wed Jan 13, 2016 4:57 pm

Amarildojr wrote in Tue Jan 12, 2016 9:47 pm:
dutchguy wrote in Sat Jan 09, 2016 6:24 pm:I can confirm that it builds correctly now. Thanks for the fix!

Could you confirm that it's NOT working now? :P A simple SIMGEAR compile at a random folder, doesn't work. I'll look more into this. I thought Stable wouldn't suffer from Next's problems.

stable is stable... it has not been modified since it was locked down...

but please tell us that you are not attempting to do this in your following quote...
Amarildojr wrote in Thu Jan 07, 2016 12:59 am:So we can use, say, SIMGEAR stable, and FGFS Next on the same compilation "master folder"?

you can/should not mix and match code like that... especially when both have been modified in the "next" branch for new features, capabilities and bug fixes...

i've even switch back from using CURL to using the built-in http code to help test it with terrasync...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6966
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 20.04

Re: Tonight I can not update the 3.7 :(

Postby Amarildojr » Wed Jan 13, 2016 5:02 pm

It worked 2 days ago. Then I Zero-Filled my drive and re-installed Arch, downloaded the scrip, did the same setps as I always do, and it doesn't work anymore.

Code: Select all
[amarildo@amarildo Compile]$ ./download_and_compile.sh -s
**************************************
*                                    *
* Warning, the compilation process   *
* is going to use 12 or more Gbytes  *
* of space and at least a couple of  *
* hours to download and build FG.    *
*                                    *
* Please, be patient ......          *
*                                    *
**************************************
****************************************
**************** SIMGEAR ***************
****************************************
Cloning into '.'...
remote: Counting objects: 33033, done.
remote: Compressing objects: 100% (7499/7499), done.
remote: Total 33033 (delta 25707), reused 32343 (delta 25205)
Receiving objects: 100% (33033/33033), 9.35 MiB | 670.00 KiB/s, done.
Resolving deltas: 100% (25707/25707), done.
Checking connectivity... done.
Branch release/3.6.0 set up to track remote branch release/3.6.0 from origin.
Switched to a new branch 'release/3.6.0'
Current branch release/3.6.0 is up to date.
-- The C compiler identification is GNU 5.3.0
-- The CXX compiler identification is GNU 5.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- version is 3 dot 6 dot 0
-- ignoring: ^/home/amarildo/Documents/Jogos/FlightGear/Compile/simgear/.git;\\.gitignore;Makefile.am;~$;
-- Library installation directory: lib64
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Boost version: 1.60.0
-- SimGear mode: NORMAL
-- Found OpenGL: /usr/lib64/libGL.so 
-- Found OpenAL: /usr/lib64/libopenal.so 
-- Sound support: ENABLED
-- Could NOT find osgText (missing:  OSGTEXT_LIBRARY OSGTEXT_INCLUDE_DIR)
-- Could NOT find osgSim (missing:  OSGSIM_LIBRARY OSGSIM_INCLUDE_DIR)
-- Could NOT find osgDB (missing:  OSGDB_LIBRARY OSGDB_INCLUDE_DIR)
-- Could NOT find osgParticle (missing:  OSGPARTICLE_LIBRARY OSGPARTICLE_INCLUDE_DIR)
-- Could NOT find osgGA (missing:  OSGGA_LIBRARY OSGGA_INCLUDE_DIR)
-- Could NOT find osgViewer (missing:  OSGVIEWER_LIBRARY OSGVIEWER_INCLUDE_DIR)
-- Could NOT find osgUtil (missing:  OSGUTIL_LIBRARY OSGUTIL_INCLUDE_DIR)
-- Could NOT find osg (missing:  OSG_LIBRARY OSG_INCLUDE_DIR)
-- Could NOT find OpenThreads (missing:  OPENTHREADS_LIBRARY OPENTHREADS_INCLUDE_DIR)
CMake Error at /usr/share/cmake-3.4/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
  Could NOT find OpenSceneGraph (missing: OPENSCENEGRAPH_LIBRARIES
  OPENSCENEGRAPH_INCLUDE_DIR OSGTEXT_FOUND OSGSIM_FOUND OSGDB_FOUND
  OSGPARTICLE_FOUND OSGGA_FOUND OSGVIEWER_FOUND OSGUTIL_FOUND OSG_FOUND
  OPENTHREADS_FOUND) (Required is at least version "3.2.0")
Call Stack (most recent call first):
  /usr/share/cmake-3.4/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.4/Modules/FindOpenSceneGraph.cmake:234 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:206 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/amarildo/Documents/Jogos/FlightGear/Compile/build/simgear/CMakeFiles/CMakeOutput.log".
See also "/home/amarildo/Documents/Jogos/FlightGear/Compile/build/simgear/CMakeFiles/CMakeError.log".
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.


If Stable doesn't change, how is it not working anymore?
Amarildojr
 
Posts: 94
Joined: Sat Jan 02, 2016 10:32 pm
Location: Basil
Callsign: TAM91
OS: Arch Linux

Re: Tonight I can not update the 3.7 :(

Postby wkitty42 » Wed Jan 13, 2016 5:21 pm

it is not working any more because you do not have OSG installed...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6966
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 20.04

Re: Tonight I can not update the 3.7 :(

Postby Amarildojr » Wed Jan 13, 2016 6:46 pm

I'm quite surprised it required OSG this time. Last time I started with a blank folder and SIMGEAR compiled first.

Thanks!
Amarildojr
 
Posts: 94
Joined: Sat Jan 02, 2016 10:32 pm
Location: Basil
Callsign: TAM91
OS: Arch Linux

Re: Tonight I can not update the 3.7 :(

Postby wkitty42 » Thu Jan 14, 2016 4:50 pm

simgear has always required OSG, AFAIK... either the system installed one or the custom built one from the repo... when i first ran the dnc script, it downloaded and installed numerous packages that were needed for proper operation... i can easily switch between the system's installed OSG or the 3.2 from the repo...

i don't understand why you would want to compile simgear only, though...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6966
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 20.04

Re: Tonight I can not update the 3.7 :(

Postby Amarildojr » Thu Jan 14, 2016 4:55 pm

I wouldn't, but that's what compiles first if using just the option "-s" after "./download_and_compile.sh".
Amarildojr
 
Posts: 94
Joined: Sat Jan 02, 2016 10:32 pm
Location: Basil
Callsign: TAM91
OS: Arch Linux

Re: Tonight I can not update the 3.7 :(

Postby wkitty42 » Thu Jan 14, 2016 6:39 pm

ahhh... ok... i thought you were trying to compile ONLY simgear...

yes, it is the first one unless you edit your script's WHATTOBUILDALL variable OR if you specify what you want to build on the command line...

eg: this says to pull only from the last stable repo (that would have been release/3.6.0 by my copy of the dnc script), install necessary system packages, compile with eight jobs going at once (i have an 8-core system), update and compile PLIB, OSG, SIMGEAR, FGFS and FGData from the fgfs repos...
Code: Select all
./download_and_compile.sh -s -p y -j 8 PLIB OSG SIMGEAR FGFS DATA

this is using OSG from the repo and not the system's installed version... it is not compiling FGRUN or any of those other options...
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6966
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 20.04

Re: Tonight I can not update the 3.7 :(

Postby Amarildojr » Thu Jan 14, 2016 9:23 pm

Interesting how you can use "PLIB OSG SIMGEAR" etc at once. I though we needed to wait for a job to finish and only then start another.
Amarildojr
 
Posts: 94
Joined: Sat Jan 02, 2016 10:32 pm
Location: Basil
Callsign: TAM91
OS: Arch Linux

Re: Tonight I can not update the 3.7 :(

Postby wkitty42 » Fri Jan 15, 2016 4:57 pm

"./download_and_compile.sh -h" tells most all of the majikal inkantashuns ;)
"You get more air close to the ground," said Angalo. "I read that in a book. You get lots of air low down, and not much when you go up."
"Why not?" said Gurder.
"Dunno. It's frightened of heights, I guess."
User avatar
wkitty42
 
Posts: 6966
Joined: Fri Feb 20, 2015 3:46 pm
Location: central NC, USA
Callsign: wk42
Version: git next
OS: Kubuntu 20.04

Previous

Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest