Board index FlightGear Support Compiling

"Detected incompatible version of the data files" (v3.6.0)

Building FlightGear from source, and in the need for help?

"Detected incompatible version of the data files" (v3.6.0)

Postby salafrance » Thu Jul 23, 2015 6:31 pm

Hi,

I downloaded and compiled SimGear and FlightGear version 3.6, using the git sources, via git://git.code.sf.net/p/flightgear/simgear simgear and git://git.code.sf.net/p/flightgear/flightgear. I'm compiling on a very recent update of Archlinux. The code appeared to compile and run successfully, but I was reminded by the startup dialog to download the base data files. After a couple of false starts due to downloading an earlier version of the base files, I obtained the version 3.6 datafiles, again from git.

However, I'm *still* getting the above dialog message, updated to reflect the version of the data files I obtained from git.

"Detected incompatible version of the data files: version 3.6.0 found, but this is FlightGear 3.6.0."

I'm running flightgear from the command line, using the fgfs executable. Is there anything obviously wrong, here?

Thanks,

S.
salafrance
 
Posts: 4
Joined: Thu Jul 23, 2015 6:17 pm

Re: "Detected incompatible version of the data files" (v3.6.

Postby clrCoda » Fri Jul 24, 2015 6:51 pm

I'd be interested to know what file name was given to your installed data. Seems there has been a name change and the file folder name is now 'fgdata'.

hope this was the problem and if not, lets keep looking
--Ray
Ray St. Marie
clrCoda
 
Posts: 1228
Joined: Wed Apr 07, 2010 11:04 am

Re: "Detected incompatible version of the data files" (v3.6.

Postby salafrance » Sat Jul 25, 2015 8:21 am

Hi Ray,

The folder name was fgdata, but in my earlier attempts to set up the base data I downloaded versions with the folder name 'data', which gave me a different (and more promising) error message. I renamed 'fgdata' to 'data' for that reason.

I tried FlightGear with both folder names, with the git-sourced base data. In both cases I got an error dialog; in the 'data' case, I got the incompatibility warning, although it listed both FLightGear and base data versions as 3.6.0. I might rebuild with debug turned on to try to narrow the problem down.

Thanks for the reply,

S.
salafrance
 
Posts: 4
Joined: Thu Jul 23, 2015 6:17 pm

Re: "Detected incompatible version of the data files" (v3.6.

Postby ludomotico » Sat Jul 25, 2015 9:10 am

FlightGear is changing the version codes these days, and they may be unstable.

Try "git pull"-ing again FlightGear, simgear and fgdata
User avatar
ludomotico
 
Posts: 1130
Joined: Tue Apr 24, 2012 1:01 pm
Version: nightly
OS: Windows 10

Re: "Detected incompatible version of the data files" (v3.6.

Postby salafrance » Sun Jul 26, 2015 10:51 am

Will do, thanks.
salafrance
 
Posts: 4
Joined: Thu Jul 23, 2015 6:17 pm

Re: "Detected incompatible version of the data files" (v3.6.

Postby salafrance » Sun Jul 26, 2015 11:33 am

Okay, mystery at least partly solved. I'd tried two approaches to the data/fgdata change. Firstly, I renamed the directory (this gave the incompatibility dialog). Then I tried symlinking fgdata to data - same message. I *then* followed your suggestion and updated from repository. This still didn't work.

Finally, I chose the fgdata folder from the dialog - this did work. I'd tried the same thing but with pre-3.6.0 versions of fgdata (unsuccessfully), so it didn't immediately occur to me to try it with the 3.6.0 data.

Thanks for the suggestions.

^^

S.
salafrance
 
Posts: 4
Joined: Thu Jul 23, 2015 6:17 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest