Board index FlightGear Support Compiling

Building FlightGear has problems

Building FlightGear from source, and in the need for help?

Building FlightGear has problems

Postby doublegj526 » Sat Jun 27, 2015 12:05 am

I've been staring at this for a while, I've been following the instructions on the INSTALL file and I still keep getting this error. Can someone suggest advice?

Code: Select all
Johns-MacBook-Air-4:fgbuild johngee$ cmake ../'flightgear-3.4.0' -DCMAKE_BUILD_TYPE=Release
-- System is: Darwin
-- Using explicit data directory for base package: /usr/local/lib/FlightGear
fatal: ambiguous argument 'HEAD': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions, like this:
'git <command> [<revision>...] -- [<file>...]'
-- Git revision is HEAD
CMake Error at /Applications/CMake.app/Contents/share/cmake-3.2/Modules/FindBoost.cmake:1182 (message):
  Unable to find the requested Boost libraries.

  Unable to find the Boost header files.  Please set BOOST_ROOT to the root
  directory containing Boost or BOOST_INCLUDEDIR to the directory containing
  Boost's headers.
Call Stack (most recent call first):
  CMakeLists.txt:222 (find_package)


CMake Error at /Applications/CMake.app/Contents/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
  Could NOT find Threads (missing: Threads_FOUND)
Call Stack (most recent call first):
  /Applications/CMake.app/Contents/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:374 (_FPHSA_FAILURE_MESSAGE)
  /Applications/CMake.app/Contents/share/cmake-3.2/Modules/FindThreads.cmake:204 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:224 (find_package)


-- Configuring incomplete, errors occurred!
See also "/Users/johngee/Downloads/fgbuild/CMakeFiles/CMakeOutput.log".
doublegj526
 
Posts: 5
Joined: Sat Jun 27, 2015 12:01 am

Re: Building FlightGear has problems

Postby hamzaalloush » Sat Jun 27, 2015 3:15 am

apparently you do have the FindBoost cmake module installed system-wide, yet you are getting "Unable to find the Boost header files".

so do you have Boost installed?
hamzaalloush
 
Posts: 632
Joined: Sat Oct 26, 2013 9:31 am
OS: Windows 10

Re: Building FlightGear has problems

Postby doublegj526 » Sat Jun 27, 2015 5:53 am

I do :\ I don't know what's the issue
I just tried reinstalling it and I still get the same error
doublegj526
 
Posts: 5
Joined: Sat Jun 27, 2015 12:01 am

Re: Building FlightGear has problems

Postby doublegj526 » Mon Jun 29, 2015 2:59 pm

Bump please help! I've tried almost everything I know and nothing seems to be working! I even tried reinstalling git but that didn't work.

I saw these links:
viewtopic.php?f=20&t=13675
viewtopic.php?f=18&t=21458&start=30
and tried what they suggested but none of that helped in my case :\
Thanks, much appreciated!
doublegj526
 
Posts: 5
Joined: Sat Jun 27, 2015 12:01 am

Re: Building FlightGear has problems

Postby Philosopher » Mon Jun 29, 2015 4:32 pm

Use this: -DBOOST_ROOT=/path/to/boost
Thanks,
Philosopher
(inactive but lurking occasionally...)
Philosopher
 
Posts: 1590
Joined: Sun Aug 12, 2012 6:29 pm
Location: Stuck in my head...
Callsign: AFTI
Version: Git
OS: Mac OS X 10.7.5


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest