Board index FlightGear Support Compiling

CrashRpt setup failed / Missing language file

Building FlightGear from source, and in the need for help?

CrashRpt setup failed / Missing language file

Postby rreiter » Sun Mar 23, 2014 9:05 pm

Note re "CrashRpt setup failed" / "Missing language file or wrong language file version" message when running a 64-bit executable.
The issue is known to occur for SuperBuild generated v3.10 64-bit executables.
It happens because the file crashrpt_lang.ini is missing from the \bin folder, which in turn is because it is missing from the original 3rdparty dependencies download source currently used by SuperBuild. The 32-bit build does not have this issue because the 32-bit download source does contain the file.

One workaround is to simply copy the crashrpt_lang.ini file from a 32-bit installation if you have one. Alternatively, you can obtain it directly from the 32 bit download source SuperBuild uses, which currently is at:
http://fgfs.goneabitbursar.com/fgwin3rd ... k/msvc100/
(you can double-check that inside C:\FGFS\fgmeta\CMakeLists.txt by searching for the "ExternalProject_Add" setting for "WinDeps").

I've also documented this in the wiki.
I'm not sure it's a "bug" per-se... should I add it there?
rreiter
 
Posts: 35
Joined: Thu Jan 16, 2014 4:33 am
Location: Newmarket, Ontario Canada
OS: Windows

Re: CrashRpt setup failed / Missing language file

Postby F-JJTH » Sun Mar 23, 2014 9:15 pm

I've fixed it, you can revert your change on wiki ;)
Thanks you for your report.

http://fgfs.goneabitbursar.com/fgwin3rd ... y.x64/bin/

Regards,
Clément
User avatar
F-JJTH
 
Posts: 697
Joined: Fri Sep 09, 2011 11:02 am

Re: CrashRpt setup failed / Missing language file

Postby rreiter » Sun Mar 23, 2014 9:49 pm

Ok, will do.. thanks.
rreiter
 
Posts: 35
Joined: Thu Jan 16, 2014 4:33 am
Location: Newmarket, Ontario Canada
OS: Windows


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest