Board index FlightGear Support Compiling

Clarification on "package versions"

Building FlightGear from source, and in the need for help?

Clarification on "package versions"

Postby grimdon » Thu Jan 02, 2014 8:26 pm

Greetings
I am beginning the process of building flightgear. I am following the wiki entry "Building Flightgear - Debian".
When being instructed as to what libraries to install, a list for "Squeeze" is given, with the advice to "check package versions" for other Debian versions. This implies that flightgear 2.12.1 and Debian Wheezy have some mutually agreed upon library packages which should be installed. How would I obtain a list of such packages to replace the list given in the wiki?
Thank you for your attention to this (elementary, I'm sure) matter.
grimdon
 
Posts: 52
Joined: Sat Jun 23, 2012 4:08 am

Re: Clarification on "package versions"

Postby AndersG » Thu Jan 02, 2014 8:42 pm

Just use the listed package names - the version available for your Debian should be fine in most cases.
You do need to build (internally) matching versions of both SimGear and FlightGear and get the matching version of fgdata too, however.
Callsign: SE-AG
Aircraft (uhm...): Submarine Scout, Zeppelin NT, ZF Navy free balloon, Nordstern, Hindenburg, Short Empire flying-boat, ZNP-K, North Sea class, MTB T21 class, U.S.S. Monitor, MFI-9B, Type UB I submarine, Gokstad ship, Renault FT.
AndersG
 
Posts: 2416
Joined: Wed Nov 29, 2006 9:20 am
Location: Göteborg, Sweden
Callsign: SE-AG
OS: Debian GNU Linux

Re: Clarification on "package versions"

Postby Hooray » Thu Jan 02, 2014 9:11 pm

use "apt-cache search" if you cannot find a certain package's name.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11273
Joined: Tue Mar 25, 2008 8:40 am

Re: Clarification on "package versions"

Postby grimdon » Thu Jan 02, 2014 11:49 pm

Thanks AndersG, I will proceed installing the listed packages, but are you implying that there is no way to tell which packages are compatible except by trial and error? What do you think is meant by "check package versions" if the list is in doubt?
grimdon
 
Posts: 52
Joined: Sat Jun 23, 2012 4:08 am

Re: Clarification on "package versions"

Postby Hooray » Fri Jan 03, 2014 12:23 am

you could try the superbuild first, and only if that doesn't work for some reason, use brisa's d&c script:

http://wiki.flightgear.org/Superbuild
http://wiki.flightgear.org/Scripted_Com ... ian/Ubuntu
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11273
Joined: Tue Mar 25, 2008 8:40 am

Re: Clarification on "package versions"

Postby AndersG » Fri Jan 03, 2014 6:01 pm

grimdon wrote in Thu Jan 02, 2014 11:49 pm:Thanks AndersG, I will proceed installing the listed packages, but are you implying that there is no way to tell which packages are compatible except by trial and error? What do you think is meant by "check package versions" if the list is in doubt?


Yes, somebody has to do that. Presumably, known incompatibilities have either been fixed already (FG/git v.s. new versions of the dependencies) or can be found by searching here and in the bug tracker. I track Debian/testing so for me it makes no sense to add package versions to any "long lived" document - the current versions change all the time. YMMV, though.

/Anders
Callsign: SE-AG
Aircraft (uhm...): Submarine Scout, Zeppelin NT, ZF Navy free balloon, Nordstern, Hindenburg, Short Empire flying-boat, ZNP-K, North Sea class, MTB T21 class, U.S.S. Monitor, MFI-9B, Type UB I submarine, Gokstad ship, Renault FT.
AndersG
 
Posts: 2416
Joined: Wed Nov 29, 2006 9:20 am
Location: Göteborg, Sweden
Callsign: SE-AG
OS: Debian GNU Linux

Re: Clarification on "package versions"

Postby grimdon » Sat Jan 04, 2014 9:02 pm

Thanks Anders, I have now successfully built FG and am undertaking mod's for my own purposes.

One more thing - I believe there is a typo in the "Build & Installi", "plib" section.
One command line is given as: "cd plib" and I believe it should be: "cd plib.svn"

Thanks again for your help.
grimdon
 
Posts: 52
Joined: Sat Jun 23, 2012 4:08 am


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest