Board index FlightGear Support Compiling

SimGear 2.12 (needed 2.99)  Topic is solved

Building FlightGear from source, and in the need for help?

SimGear 2.12 (needed 2.99)  

Postby chris_blues » Tue Jul 23, 2013 2:18 pm

Code: Select all
-- found SimGear version: 2.12.0 (needed 2.99.0)
CMake Error at CMakeModules/FindSimGear.cmake:112 (message):
  You have installed a mismatching SimGear version 2.12.0 instead of 2.99.0
  as required by FlightGear.  When using multiple SimGear installations,
  please use 'SIMGEAR_DIR' to select the SimGear library location to be used.

This message popped up, when I tried to compile/update my FG-git today! (Using Brisa's script)
The solution was to change /location/of/script_/fgfs/flightgear/version.txt. I had to change 2.99.0 to 2.12.0 and run the script with the following options:
Code: Select all
./download_and_compile.sh -a n -p n -d n -j 3 FGFS

(the -a and -p switches are set to no, because ArchLinux doesn't know what to do with an "apt-get update" :mrgreen:
The trick did the "-d n" switch, which stops the script from re-downloading the sources from the internet and overwrite my "custom-version 2.12.0" ...

I guess someone tried to make a joke or accidently put some wrong numbers there...

Cheers, I hope this will prevent someone to search for the cause like I did...
chris
Don't hesitate to let me know if I'm incorrect or just annoying! As long as you do it gently! :)
Debian testing 64bit - Athlon II 2x2.6GHz - 8GB RAM - GeForce GTS 450
Citation II
User avatar
chris_blues
 
Posts: 1531
Joined: Mon May 03, 2010 1:30 pm
Location: claws of real life
Callsign: chris_blues
Version: GIT
OS: Debian 8 64

Re: SimGear 2.12 (needed 2.99)

Postby Hooray » Tue Jul 23, 2013 2:57 pm

it's a known build system issue (solved by reconfiguring via cmake), see the updated wiki article: http://wiki.flightgear.org/Scripted_Com ... n_Pitfalls
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11309
Joined: Tue Mar 25, 2008 8:40 am

Re: SimGear 2.12 (needed 2.99)

Postby chris_blues » Wed Jul 24, 2013 10:23 am

Funny, FG was quite set to be 2.99 (data too!) Only Simgear believed to be 2.12...
Don't hesitate to let me know if I'm incorrect or just annoying! As long as you do it gently! :)
Debian testing 64bit - Athlon II 2x2.6GHz - 8GB RAM - GeForce GTS 450
Citation II
User avatar
chris_blues
 
Posts: 1531
Joined: Mon May 03, 2010 1:30 pm
Location: claws of real life
Callsign: chris_blues
Version: GIT
OS: Debian 8 64

Re: SimGear 2.12 (needed 2.99)

Postby Hooray » Wed Jul 24, 2013 10:53 am

Run cmake . in the build folders for SG and FG and the issue is solved.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 11309
Joined: Tue Mar 25, 2008 8:40 am

Re: SimGear 2.12 (needed 2.99)

Postby chris_blues » Thu Jul 25, 2013 1:39 pm

"cmake ." didn't work for me, because Brisa's script works with custom paths and folders for the included libs. But deleting the folders "fgfs" and "simgear" in the build-folder did the trick.

Thanks for your input anyway! :)
Don't hesitate to let me know if I'm incorrect or just annoying! As long as you do it gently! :)
Debian testing 64bit - Athlon II 2x2.6GHz - 8GB RAM - GeForce GTS 450
Citation II
User avatar
chris_blues
 
Posts: 1531
Joined: Mon May 03, 2010 1:30 pm
Location: claws of real life
Callsign: chris_blues
Version: GIT
OS: Debian 8 64


Return to Compiling

Who is online

Users browsing this forum: No registered users and 2 guests