Board index FlightGear Support Compiling

Cmake failure to find osg  Topic is solved

Building FlightGear from source, and in the need for help?

Cmake failure to find osg

Postby marawuti » Sat Mar 30, 2013 1:51 am

Attempting to build fg 2.10 after apparent success installing osg 3.0.1
I'm getting the following:
[ FindOpenSceneGraph.cmake:130 ] Failed to parse version number, please report this as a bug
CMake Error at /usr/share/cmake-2.8/Modules/FindOpenSceneGraph.cmake:199 (message):
ERROR: Version 3.0.0 or higher of the OSG is required. Version .. was
found.
Call Stack (most recent call first):
CMakeLists.txt:190 (find_package)

This is on Debian 6.0.7 squeeze.
marawuti
 
Posts: 2
Joined: Sat Mar 30, 2013 1:12 am

Re: Cmake failure to find osg  

Postby Hooray » Sat Mar 30, 2013 1:54 am

HI & welcome

Thanks for providing feedback, but it seems that OSG was not found at all - are you sure that you have it installed, including the devel package on Linux ?
What about your package manager, what does it say ?
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12059
Joined: Tue Mar 25, 2008 8:40 am

Re: Cmake failure to find osg

Postby marawuti » Sat Mar 30, 2013 5:15 pm

Thanks for the welcome.

The debian package manager seems to be useless for packages installed from non-repository source. I've put up a query in another forum about that to get an education.

It is possible that I don't have the devel package. I thought I followed the same procedure I used in building osg 2.8.3. I'll check the osg source package and site.

Thx consider this resolved.

BTW, the reason I came straight to the forum is there was an identical error output in a pastebin and I assumed someone would have clarified it here. No joy.
marawuti
 
Posts: 2
Joined: Sat Mar 30, 2013 1:12 am

Re: Cmake failure to find osg

Postby Hooray » Sat Mar 30, 2013 6:24 pm

you can use pkg-config to check if OSG is found at all - that should work even after installing from source.
Please don't send support requests by PM, instead post your questions on the forum so that all users can contribute and benefit
Thanks & all the best,
Hooray
Help write next month's newsletter !
pui2canvas | MapStructure | Canvas Development | Programming resources
Hooray
 
Posts: 12059
Joined: Tue Mar 25, 2008 8:40 am


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest