Board index FlightGear Support Compiling

Anybody else having trouble with static_pointer_cast?  Topic is solved

Building FlightGear from source, and in the need for help?

Anybody else having trouble with static_pointer_cast?

Postby chriscalef » Sat Mar 16, 2013 1:02 am

Hi,

I'm not sure how or when this problem started, but two or three weeks ago I got started in FG and embarked upon the task of building everything for linux and windows... there were a lot of things to solve in windows but linux flew right together with nary a complaint.

Now, however, I've gone back and tried to compile it again, and it's dying on a file that I believe worked fine before... I did a fresh install from gitorious to make sure it wasn't a local change, and got the same error. Could there be some dependency on my system (OSG perhaps?) that might have changed, that would cause this failure? Curious if anyone else has seen this problem.

Code: Select all
/home/chris/projects/flightgear/flightgear/src/Navaids/positioned.hxx: In static member function ‘static SGSharedPtr<T> FGPositioned::loadById(PositionedID)’:
/home/chris/projects/flightgear/flightgear/src/Navaids/positioned.hxx:236:12: error: ‘static_pointer_cast’ was not declared in this scope
/home/chris/projects/flightgear/flightgear/src/Navaids/positioned.hxx:236:12: note: suggested alternative:
In file included from /usr/include/simgear/scene/model/particles.hxx:22:0,
                 from /home/chris/projects/flightgear/flightgear/src/Main/fg_init.cxx:56:
/usr/local/include/osg/ref_ptr:128:12: note:   ‘osg::static_pointer_cast’


Seeing that, with I went ahead and halfheartedly attempted to fix it by adding osg:: in front of static_pointer_cast, knowing this was almost certainly not the real problem, and was rewarded with the following:

Code: Select all
/home/chris/projects/flightgear/flightgear/src/Navaids/positioned.hxx: In static member function ‘static SGSharedPtr<T> FGPositioned::loadById(PositionedID)’:
/home/chris/projects/flightgear/flightgear/src/Navaids/positioned.hxx:236:12: error: ‘static_pointer_cast’ is not a member of ‘osg’
/home/chris/projects/flightgear/flightgear/src/Navaids/positioned.hxx:236:38: error: expected primary-expression before ‘>’ token


Is it possible the OSG version shifted under me and I didn't stay on top? Anyone else see anything like this with a current build from the repo?

Cheers,
Chris
chriscalef
 
Posts: 279
Joined: Wed Feb 20, 2013 9:28 pm

Re: Anybody else having trouble with static_pointer_cast?  

Postby TheTom » Sat Mar 16, 2013 11:36 pm

I've added static_pointer_cast to simgear/structure/SGSharedPtr.hxx about two weeks ago. Are you sure you have an up-to-date SimGear?
TheTom
 
Posts: 322
Joined: Sun Oct 09, 2011 10:20 am

Re: Anybody else having trouble with static_pointer_cast?

Postby chriscalef » Tue Mar 19, 2013 1:24 am

Hm, I thought I did, but thanks for the info, I'll double check.
chriscalef
 
Posts: 279
Joined: Wed Feb 20, 2013 9:28 pm

Re: Anybody else having trouble with static_pointer_cast?

Postby chriscalef » Thu Apr 04, 2013 3:00 am

Update: it was a local problem, I started over with clean builds for simgear and flightgear and it went away. Thanks!
chriscalef
 
Posts: 279
Joined: Wed Feb 20, 2013 9:28 pm


Return to Compiling

Who is online

Users browsing this forum: No registered users and 1 guest